Skip navigation

How to fix iTunes 10.6 iPhone's USB Personal Hotspot problem

48285 Views 47 Replies Latest reply: Dec 13, 2013 2:36 PM by jamesfrompleasanton RSS
  • billfromstittsville Level 1 Level 1 (0 points)

    See this discussion:



    for a description of how this info fixed a similar problem triggered by an iTunes 10.7 upgrade.


    Thanks again to David Empson for the research.

  • Kineva Level 1 Level 1 (0 points)

    Spent hours trying to fix this; finally I found this discussion and away went my sorrows -Thanks a lot!!!

  • Topolinux Level 1 Level 1 (10 points)

    I found my way to fix the issue in two macs, check the thread and you'll find the link to the AppleUSBEthernetHost.kext v2.3.0 (from iTunes 10.6.3 installation) and the link to an utility that installs kext files in your OS



  • Beezie Level 1 Level 1 (0 points)

    The other work around I found that just worked for me was to upgrade to ios 6 and and I iTunes 7 then go to the general settings on the iphone and reset network settings, Volia all conntected via USB again.

  • Sea S Level 1 Level 1 (0 points)

    I got this problem, cannot connect to iPhone hotspot via USB, after iTunes 11.0 installation 3 days ago. I read the discussion and fixed the problem in two minutes. What I did was:

    1. download (Mac unziped it during downloading automatically)

    2. logon as user su from terminal

    3. cp correct AppleUSBEthernetHost file, 180K, to the dir

    4. restart Mac, and the problem fixed.

  • NielsChristensen Level 1 Level 1 (0 points)

    Can you explain this in details for a guy who´s not on the same level as you?


    Thank you.



  • Sea S Level 1 Level 1 (0 points)

    1. download from

    and unzip it (my MBP unziped it during downloading automatically).


    2. create a new dir under your hard disk 'Macintosh HD', such as USBHotspotFile and save AppleUSBEthernetHost.kext under it. You may keep it there forever as every time you upgrade iTune, you may have to do this fix again. The problem had been reported 1+ year ago, but Apple never tried to fix it. In step-9 below, I assume you have done this step-2.


    3. enable su (root) user:

    how to enable su user on mac.jpg

    4. bring up Terminal: Applications->Utilities->Terminal, which is a unix command line interface. After enter a command string, you always press <return> key to issue it. Please note that you can just use your mouse highlight following commands in step-5 to step-10, one at a time, and drag-drop it to Termianl's command prompt position and press <return>


    5. issue command: su


    6. system will ask you for Password:, just enter the password you set in above step-3


    7. issue command: cd /System/Library/Extensions/AppleUSBEthernetHost.kext/Contents/MacOS


    8. issue command: mv AppleUSBEthernetHost AppleUSBEthernetHost.bad


    9. issue command: cp /USBHotspotFile/AppleUSBEthernetHost.kext/Contents/MacOS ./


    10. issue command: ls -l


    11. you will see system displaying something like following for above command:

    -rwxr-xr-x@ 1 root  wheel  180760 Dec  1 23:07 AppleUSBEthernetHost

    -rwxr-xr-x    1 root  wheel  118720 Aug 10 18:02 AppleUSBEthernetHost.bad

    here you can see that the correct file has size 180760 (which is what you will get from downloaded .zip file) and the incorrect file has size 118720 (which is what I got from ITune 11.0 upgrade)
    12. PLEASE REMEMBER do above step-3 again, but for DISABLE su (root) user.
    Hope this will reslove your problem. Cood Luck!

  • Sea S Level 1 Level 1 (0 points)

    Niels, Sorry, just found a typo in step-9, which is copying file but without giving file name to be copied. correct step-9 is:
    cp /USBHotspotFile/AppleUSBEthernetHost.kext/Contents/MacOS/AppleUSBEthernetHost ./

  • Sea S Level 1 Level 1 (0 points)

    Niels, also missed last step:

    13. RESTART your Mac...

  • thinkOTB Level 1 Level 1 (0 points)

    It has been less than a month since I deleted the usb interface in my network preferences on my MacBookPro. I have read all the above replies and fixes. It wasn't a problem, just a challenge cuz wifi works well.


    I can connect to my tv and any other computer in the house with wifi on. The usb connection is quick and easy, but a little limiting. It is ok to be limited as long as I only want to connect to the one computer.


    I re established my usb connection by:

    1. removed .kext per above instructions
    2. reinstalled itunes
    3. resetting my network settings on my phone,
    4. restarting my phone
    5. turning off wifi and hotspot on phone
    6. plugging phone into computer with usb
    7. opening network preferences on computer and hit the "+" sign, it recognised the phone and asked if I wanted to name the connection my phone's name
    8. turn Personal Hotspot "on" on the phone
    9. wait for phone to connect, watch and wait for connection to go green in Network preferences, it takes a few seconds
    10. if not, try turning Hotspot connection on phone off and on again, be patient


    iOS 6.1

    OS 10.7.5

    iTunes on computer 11.0.1


    good luck

  • AnetDan Level 1 Level 1 (0 points)

    Sorry, this is not actually a reply I just don't know where else to ask..


    I basically have the same problem (I think), but I do not understand a sigle word of how anybody fixed it and I'm quite desperate to know...

    Could anybody help me?


    All I know is after i updated the software for my MacBook to Mac OS X 10.6.8 (I hope it's written correctly...) I could not connect to the internet using my iPhone 3GS which latest update is iOS 6.1.2 as hotspot. And as far as I can understand some think it is because of iTunes updates?. I have updated it to iTunes 11.0.2. -still it does not work.



    So help ? (if possible in danish...)



  • thinkOTB Level 1 Level 1 (0 points)

    I am unable to help with any info in Danish. Try to follow the steps below, or have someone translate for you.

    1. restart MacBook
    2. reset network settings on iphone: Settings/General/Reset/Reset Network Settings
    3. power off iphone and then restart iphone
    4. turn off wifi and hotspot on phone
    5. plug iphone into computer with usb cable
    6. open System preferences/network preferences on MacBook,
    7. hit the "+" sign in the lower right hand corner of the connections panel
    8. name the connection your iphone's name, or an easily recognized name
    9. turn Personal Hotspot "on" in the iphone settings/Personal Hotspot
    10. wait for the iphone to connect, watch and wait for connection to go green in the MacBook's Network preferences panel, it takes a few seconds
    11. if not connecting, try turning Hotspot connection in iphone Settings off and back on again, be patient
  • jordan251 Level 1 Level 1 (0 points)

    This worked for me. I didn't try any of the complicated file replacement stuff.

  • SoundShaman Level 1 Level 1 (0 points)

    To make this simple for anyone who happens to be as big of a stoner as me, this worked for me.


    Download this and run it:



    Then download this and drag it into the window of the above program.  Let it do its thing til it says all is cool.




    Boom!  You're in buisness.

  • Can.S Level 1 Level 1 (0 points)

    I Just delete the file and reload itunes. But my problem is I cannot see my iphone at the system/ network preferancesand also after hitting the "+" I can only see wi-fi, Firewire, Ethernet, Bluetooth DUN, VPN, PppoE and 6-4 .


    I can see my iphone in itunes and iphoto but cannot use hotspot via usb.


    I'm using a macbook pro lion and my phone is using ─░os 7.0


    Please help


More Like This

  • Retrieving data ...

Bookmarked By (11)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.