6 Replies Latest reply: Oct 2, 2012 12:29 PM by ExciteWalk
DD193 Level 1 Level 1 (0 points)

Just did a software update, I think it was an iphoto and some stability update. My MB (early 2011) rebooted fine, was on facebook and then it randomly restarted without prompting me. It now constantly boots into what I'm assuming is recovery. It does say Mac OS X Utilities at the top..

Can't get past the "Enter your system lock PIN code to unlock this mac" screen which I don't believe I ever set! Have tried the 2 combinations I would only ever use...which did not work!!

Tried holding the option key at boot, prompts me for a password which I enter (user account password), doesn't show the recovery partition..just machintosh HD.

Tried resetting PRAM by command+option+p+r. Prompts me for a password..goes to the pin code screen again.

Normal boot boots into the pin code screen without prompting for a password like when holding down combinations.

 

So essentially, I'm locked out of my Mac and can't get past this PIN code screen that shouldn't have a PIN code to begin with! Any ideas on what I can do OTHER than going to an apple store? (Its ages away!)


MacBook Pro, Mac OS X (10.7.2)