Skip navigation

mdworker32 takes up 97% of CPU all the time?

70752 Views 36 Replies Latest reply: Mar 21, 2013 11:09 AM by HornBlowR RSS
  • pravin1 Calculating status...
    Currently Being Moderated
    Mar 25, 2011 10:58 AM (in response to Viztang)
    I was having the same problem, but after I Iet it run for about 2 hrs it went back to normal. I think it was re-indexing since I had just installed the 10.6.7 OSX update.
    MacBook Pro 15", Mac OS X (10.6.7), 4GB
  • arno_o Calculating status...
    Currently Being Moderated
    Apr 6, 2011 1:47 AM (in response to Viztang)
    same problem here.
    Running office 2010
    Having an external (network) 'dropbox' drive.
    Processing to 100%, due to mdworker32.

    - checked via the activity monitor which files where listed and found 2 excell files with .xlsx
    - these where saved there by another person from an Microsoft machine.

    - opened the files, saved them as .xls and deleted the .xlsx versions.

    Processing went back to 'normal' ..
    macbook alu 2.4 dual - 4 gig, Mac OS X (10.6.7)
  • gef_cal Calculating status...
    Currently Being Moderated
    May 31, 2011 7:44 PM (in response to OverPowerFred)

    Thanks for this. I was having issues doing an initial TC backup to an external RAID 1 HD. Kept freezing at various stages of the backup. Removed the Microsoft Office.mdimporter files and the backup re-engaged and is moving along nicely.




    Macbook Pro OSX 10.6.7

    2TB G-Drive External - Firewire

  • bugcounter Calculating status...

    Same problem here.


    Used: Activity monitor, select the mdworker32 process, click "inspect" and select "Open Files & Ports"


    Found an .xlsx file that was emailed as an attachment.  I had opened and closed the attachment, and left excel open, then forwarded the message with attachment. "Open Files & Ports" showed the same filename listed twice.


    I closed excel and restarted and the problem went away.

  • mileszhou Calculating status...
    Currently Being Moderated
    Sep 23, 2011 6:06 PM (in response to FrequentFlyer)

    Okay, the problem was gone once "Microsoft Office.mdimporter" had been removed!

  • xairbusdriver Level 2 Level 2 (160 points)
    Currently Being Moderated
    Oct 2, 2012 7:49 PM (in response to mileszhou)

    I found this thread while searching for mdworker32 problems. It had started causing mutiple crashes on my iMac a few days ago and became almost continuous yesterday. The crash reports usually said the same thing. I never tried reading/understanding those reports but I finally noticed it was claiming an 'importer' file in a word processor I rarely use anymore was the possible problem. I had tried many changes, removing things from the Startup Items list, etc. to no avail. However, I also found Time Machine stalling and decided I needed to do something. Activity Monitor was showing 100%+ almost constantly for mdworker32!


    I followed the path the crash report gave, found the "WriteImporter.mdimporter" file and compressed it and then deleted it. Restarted. Not had a crash for any reason for over 24 hours! mdworker32 doesn't even show up in AM!


    Lessons learned:

    1. Look at those crash reports more carefully! Some of it is actually in English!

    2. Try removing the file(s) that are reported by those crash reports, but make a copy before deleting them, they may not be the direct cause of a problem.


    I've established a habit of always copressing the current version of any app before I install an update. That's a safe method to use when you suspect a pref file to be corrupted; Quuit the app, compress its plist, then just move the original to the Desktop and restart the app.

  • HornBlowR Calculating status...
    Currently Being Moderated
    Mar 21, 2013 11:09 AM (in response to Viztang)

    I had problems with mdworker32 hogging CPU when I created a backup drive.  It really got bad using Time Machine.  The problem was solved when I added the backup drive to the privacy list under Spotlight preferences.

1 2 3 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (2)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.