Skip navigation

The new version of iTunes has screwed things up - help!

799 Views 1 Reply Latest reply: Oct 3, 2012 8:18 AM by MrHoffman RSS
JMaloney90 Calculating status...
Currently Being Moderated
Oct 3, 2012 4:52 AM

Hi, I recently downloaded the newest version of iTunes (10.6.1) on my Mac and now it won't sync with my iPhon. A message appears saying I require MAC OS X version 10.6.8 or later. I currently have version OS X 10.5.8.

 

What do I do???

 

Please someone help me. I'm strressing out as I can't sync my iPhone and I use it for absolutely everything! And I'm a complete novice when it comes to anything technology-related.

 

Heeeeeeeelp!

MacBook, Mac OS X (10.5.8)
  • MrHoffman Level 6 Level 6 (11,745 points)

    If you need the newest version of iTunes because (for instance) you have a new iPhone or iOS 6 device, then you will need to purchase and upgrade your OS X software; to Snow Leopard 10.6 and then patch to 10.6.8, or to a more recent release of OS X...  See this thread or this thread for some related details; for information on how to learn what hardware is supported by Snow Leopard 10.6, on how to order the DVD, etc.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.