Skip navigation

iMessage not working

30944 Views 83 Replies Latest reply: May 6, 2013 2:27 PM by JustMeOnlyme RSS
  • sergey275 Calculating status...
    Currently Being Moderated
    Sep 24, 2012 7:10 AM (in response to Colourful)

    the same problem on 2 devices in russia

  • xscottish Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 24, 2012 7:29 AM (in response to twinsmake5)

    Mine stopped working after upgrading to IO6 I found that messaging was turned of during the update . Did you check your settings ?

  • kdahab Calculating status...
    Currently Being Moderated
    Sep 24, 2012 6:33 PM (in response to Colourful)

    still not working in UAE etisalat

  • kdahab Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 25, 2012 5:34 AM (in response to Colourful)

    if you have a USA apple ID  u can use it ,it will help using imessage and face time on that mail but not on mobile number.

    this worked with me.

  • DVX100Shooter Level 3 Level 3 (840 points)
    Currently Being Moderated
    Sep 25, 2012 10:14 AM (in response to freeflyin180)

    I got it back today. For some reason Facetime and iMessage was turned off on my phone. I never turned them off and nobody uses my phone but me.

  • Adamskt Calculating status...
    Currently Being Moderated
    Sep 30, 2012 2:18 AM (in response to Colourful)

    Just discovered that we have both been missing messages due to this iMessage service

    The worst part is that it claims the message is delivered when its not

    Unbelievably poor service apple, worse even that the new maps.

  • Gevmo Calculating status...
    Currently Being Moderated
    Oct 1, 2012 10:33 AM (in response to Colourful)

    Hi,

    i have and old mac with mac osx lion and i cannot upgrade it to mountain lion. before several months i had download imessages beta and i would like to know why i can not update it or why my phone number from iphone cannot upear to my imessages in mac.

     

    thanks you in advance

  • MadTogger Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 3, 2012 3:41 AM (in response to Colourful)

    I have been suffering with the loss of iMessage on my iPod Touch 4th gen, 3Gs, 4s and my 5, all running iOS6 but I think I may have cracked it, only time will tell.

     

    In Settings > General > Date & Time

     

    I had 'Set Automatically' switched to 'ON' but 'Time Zone' was showing the spinning pinwheel.

     

    I realised that in Settings > Privacy > Location Services > System Services

     

    I had 'Setting Time Zone' switched to 'OFF'

     

    This I assume was causing the 'Time Zone' to be unable to update, thus causing the spinning pinwheel.

     

    If I switched 'Setting Time Zone' to 'ON' I noticed that 'Time Zone' did update to my current time zone but only if there was either a network connection or WiFi connection, seems quite obvious.

     

    After doing this I done a hard reset on my device.

     

    After the device rebooted I went to Settings > Messsages

     

    And turned iMessage 'OFF' then 'ON' again and waited for it to activate.

     

    Once iMessage activated, I was able to send and receive iMessages.

     

    I hadn't finished though, something struck me in the relationship between iMessage and the 'Time Zone' setting.

     

    I went back into Settings > Privacy > Location Services > System Services and turned 'Setting Time Zone' back to 'OFF'

     

    This initially didn't seem to effect the use of iMessage and looking in Settings > General > Date & Time showed my location in 'Time Zone'

     

    At this point I made sure that WiFi was turned off on my device and then switched Airplane mode to 'ON' for a brief period and then 'OFF' again and waited to get network reception.

     

    I now tried to send an iMessage but had no joy, there were no blue speech bubbles next to contacts names and the 'SEND' button was green indicating SMS Only.

     

    Again I had a look at Settings > General > Date & Time and noticed straight away that 'Time Zone' was showing the spinning pinwheel once again.

     

    Now the reason I had turned 'OFF'  'Setting Time Zone' in Settings > Privacy > Location Services > System Services was that I had heard various reports of it consuming vasts amounts of battery power and also because I didn't really see a use for it.

     

    Now what I did was to go to Settings > General > Date & Time and change 'Set Automatically' to 'OFF'

     

    I again checked iMessage by attempting to send a text, hey presto it was back up and running and relevent contacts had the blue speech bubble.

     

    I held back my excitement for a while and tried a few things first.

     

    I made sure once again that WiFi was off on my device then again turned Airplane mode on, left it for a minute and then turned Airplane mode back to off. Once my network had been found I tried to send a text and yes, it sent as an iMessage and my contacts that had iDevices showed the blue speech bubbles.

     

    Well, I thought that it could be this easy to solve so I did another hard reset on my device, waited for it to reboot and connect to my network.

     

    Then I thought I would try to send an iMessage and opened the Messages app, started to type a known iDevice contacts name, initially the name appeared but without the blue speech bubble so I cancelled the message, closed the Messages app and then tried to do the same again, this time success, blue speech bubble next to contacts name and I was able to send an iMessage without a hitch.

     

    Just to clarify, I have got 'Cellular Data' switched to 'ON'

     

    So to me, for some reason iMessage is linked to it's ability to locate the 'Time Zone' that the iDevice is in and from my experience as laid out above, if the 'Time Zone' is unavailable then iMessage will also become unavailable.

     

    Hopefully this information will help others in a similar position.

     

    regards..,

  • geniusinthemaking Calculating status...
    Currently Being Moderated
    Oct 3, 2012 5:13 AM (in response to Colourful)

    If you are tethering from your iPad to your iPhone via Bluetooth, switch to tethering via WiFi. It's fixed it for me. Good luck!

  • geniusinthemaking Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 3, 2012 8:53 AM (in response to geniusinthemaking)

    I stand corrected..I can receive but can't send.. Driving me nuts!

  • Mattasaur Calculating status...
    Currently Being Moderated
    Oct 3, 2012 10:26 AM (in response to Colourful)

    I'm having the same problem with sending.. it's intermittent and I found if I reactivate imessage I'm more likely to be able to send successfully.  Frustrating!

  • geniusinthemaking Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 3, 2012 12:44 PM (in response to geniusinthemaking)

    Ok! I called apple today and they got me sorted.

     

    First my setup is as follows:

    Ipad2 tethered to iPhone4 w/ iMessage synced from iPhone to IPad

     

    Solution:

    Disable iMessage on iPhone via Settings -> iMessage OFF

    With iMessage enabled on iPad hard boot the iPad hold Lock & Menu button until logo appears

    After restart attempt test iMessage

    If success, re-enable iMessage on iPhone

    Good luck!

  • Maisonxr6 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 4, 2012 5:20 AM (in response to Colourful)

    Same issue here in Australia since updating ios. Did the whole date time, checked apple id settings, re entered details and phone number. Rebooted, reset everything. Have spoken to my carrier and apple. Nothing worked!

     

    Haven't tried throwing it under a bus yet, although I'm so frustrated, it's only a matter of time!

  • MadTogger Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 4, 2012 11:03 AM (in response to MadTogger)

    MadTogger wrote:

     

    I have been suffering with the loss of iMessage on my iPod Touch 4th gen, 3Gs, 4s and my 5, all running iOS6 but I think I may have cracked it, only time will tell.

     

    In Settings > General > Date & Time

     

    I had 'Set Automatically' switched to 'ON' but 'Time Zone' was showing the spinning pinwheel.

     

    I realised that in Settings > Privacy > Location Services > System Services

     

    I had 'Setting Time Zone' switched to 'OFF'

     

    This I assume was causing the 'Time Zone' to be unable to update, thus causing the spinning pinwheel.

     

    If I switched 'Setting Time Zone' to 'ON' I noticed that 'Time Zone' did update to my current time zone but only if there was either a network connection or WiFi connection, seems quite obvious.

     

    After doing this I done a hard reset on my device.

     

    After the device rebooted I went to Settings > Messsages

     

    And turned iMessage 'OFF' then 'ON' again and waited for it to activate.

     

    Once iMessage activated, I was able to send and receive iMessages.

     

    I hadn't finished though, something struck me in the relationship between iMessage and the 'Time Zone' setting.

     

    I went back into Settings > Privacy > Location Services > System Services and turned 'Setting Time Zone' back to 'OFF'

     

    This initially didn't seem to effect the use of iMessage and looking in Settings > General > Date & Time showed my location in 'Time Zone'

     

    At this point I made sure that WiFi was turned off on my device and then switched Airplane mode to 'ON' for a brief period and then 'OFF' again and waited to get network reception.

     

    I now tried to send an iMessage but had no joy, there were no blue speech bubbles next to contacts names and the 'SEND' button was green indicating SMS Only.

     

    Again I had a look at Settings > General > Date & Time and noticed straight away that 'Time Zone' was showing the spinning pinwheel once again.

     

    Now the reason I had turned 'OFF'  'Setting Time Zone' in Settings > Privacy > Location Services > System Services was that I had heard various reports of it consuming vasts amounts of battery power and also because I didn't really see a use for it.

     

    Now what I did was to go to Settings > General > Date & Time and change 'Set Automatically' to 'OFF'

     

    I again checked iMessage by attempting to send a text, hey presto it was back up and running and relevent contacts had the blue speech bubble.

     

    I held back my excitement for a while and tried a few things first.

     

    I made sure once again that WiFi was off on my device then again turned Airplane mode on, left it for a minute and then turned Airplane mode back to off. Once my network had been found I tried to send a text and yes, it sent as an iMessage and my contacts that had iDevices showed the blue speech bubbles.

     

    Well, I thought that it could be this easy to solve so I did another hard reset on my device, waited for it to reboot and connect to my network.

     

    Then I thought I would try to send an iMessage and opened the Messages app, started to type a known iDevice contacts name, initially the name appeared but without the blue speech bubble so I cancelled the message, closed the Messages app and then tried to do the same again, this time success, blue speech bubble next to contacts name and I was able to send an iMessage without a hitch.

     

    Just to clarify, I have got 'Cellular Data' switched to 'ON'

     

    So to me, for some reason iMessage is linked to it's ability to locate the 'Time Zone' that the iDevice is in and from my experience as laid out above, if the 'Time Zone' is unavailable then iMessage will also become unavailable.

     

    Hopefully this information will help others in a similar position.

     

    regards..,

    I thought I would post back my findings with my above "fix"

     

    Well it has been just over a day now and where I would love to say that all is OK, it isn't.

     

    I attempted to send an iMessage to my wife today but as soon as I started to type her name in the 'TO' section, the list of contacts appeared and yes my wife's contact details were there as they should be but the blue speech bubble indicating iMessage was non existant beside her mobile number, it was however showing against her email addresses.

     

    I thought I would check the function of iMessage again by trying to send an iMessage to my daughter and got exactly the same result as I did for my wife, only emails were showing as actively available for iMessaging and not the actual mobile number.

     

    A few hour later I tried again sending an iMessage to my daughter, this time success, her mobile number had the blue speech bubble next to it.

     

    I then tried my wife's with no luck, same as before.

     

    When my wife got home from work I deactivated iMessage on her 4s and then reactivated it, started to send her a test iMessage and low and behold the blue speech bubble was there beside her mobile number.

     

    So I guess my so called fix actually did nothing but was just a total coincidence that the time I started messing around, iMessage decided itself to play ball and I thought I had solved it.

     

    iMessage just seems totally sporadic at the moment, sometimes you can use it, sometimes you can't.

     

    On a side note I have seen lots of complaints from Vodafone UK customers that they are being charged 24p each time that iMessage is activated as the system send a premium rate SMS message to Apple's server to check the mobile number for activation, I am on Orange UK, does anyone know if Orange UK charge for iMessage activation?

     

    Just wondering because over the last few days I have been activating, deactivating and reactivating the service over and over.

     

    Regards..,

  • Maisonxr6 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 4, 2012 6:25 PM (in response to Colourful)

    After re doing all the suggested fixes, including taking the sim out for a few minutes. I woke up this morning, for some reason checked my settings-messages and it no longer said waiting to activate. I sent a test iMessage which worked from my actual phone number (not email like last time)

    Problem is I'm not sure if it is a coincidence or which one of the fixes worked.

     

    Anyway, happy days.. So far! :)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.