Skip navigation

I can't sync "Contacts" because of an error

698 Views 6 Replies Latest reply: Jan 15, 2013 8:51 AM by Mark Gaipo RSS
JYTX Calculating status...
Currently Being Moderated
Sep 9, 2012 10:56 AM

I've got a systematic error. Contacts don't sync. I've got an alert triangle in front of iCloud group with this error :

"[NSInvalidArgumentException] *** -[__NSSetM addObject:]: object cannot be nil"

I cannot search in "all"

 

Other users have this with Mail or Contacts

See : mail preview windown blank

 

(I can't insert the save screen here because of a bug (insert image button inactive after the file be chosen.)

MacBook Pro (Retina, Mid 2012), OS X Mountain Lion (10.8.1), French
  • regista Calculating status...
    Currently Being Moderated
    Sep 17, 2012 9:22 AM (in response to JYTX)

    I have ther exact same problem. Just upgraded to Mountain Lion. Contacts don't show in my All Contacts window, and next to iCloud there's a triangle:

     

    NSInvalidArgumentException] *** -[__NSSetM addObject:]: object cannot be nil

     

    It lets me see my groups, and click on them and search within the groups, but it doesn't let me search my entire database anymore, which renders it unusable (5000+ records).

     

    Please adivse.

  • Sylavin Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 3, 2012 2:24 PM (in response to JYTX)

    I have got the same problem have you fix it?

    Thanks,

    Syl

  • Darryl Zurn Calculating status...
    Currently Being Moderated
    Oct 11, 2012 3:52 AM (in response to JYTX)

    I think I found the root cause. I couldn't get my contacts to sync because of the same "object cannot be nil".

     

    I had Contacts open when I turned off the iCloud Contacts in Preferences. I said don't keep a copy on my Mac. When I did that, I found a couple of groups wiht no name (the group names were just  blank). I gave them names (nil and non-nil!) and then was able to delete the groups from my Mac's contacts. Then I re-checked Contacts syncing, and it worked much better!

     

    I think that the object that couldn't be nil was the group name, which prevented iCloud syncing. That makes sense.

     

    Darryl

  • Mark Gaipo Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jan 15, 2013 8:51 AM (in response to JYTX)

    Open System Preferences > iCloud Deselect iCloud Syncing on Contacts.  You will be asked if you want to delete the contacts from your computer - select yes.   Wait 2 minutes.  Select Contacts you will see a dialogue "setting up".    Contacts on your computer.   Open iCloud.com > Contacts - wait a moment, everything syncs back to normal including recently added contacts and group settings.   Worked for me.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.