Skip navigation

External hard drive ejects on sleep

68027 Views 430 Replies Latest reply: Apr 20, 2014 2:53 PM by Danielle Smit RSS Branched to a new discussion.
  • molarmech Calculating status...
    Currently Being Moderated
    Sep 26, 2012 10:20 PM (in response to ah_mostin)

    This is getting very interesting!  I, too, have a case open with Apple.  In fact, I was referred to a "senior advisor".  I have done a "P ram reset, a cache reset, unchecked the "put drives to sleep" box in energy saver, sent in ACCD repots which are obtained via a special piece of software from Apple called "Capture Data".  Nothing has made a difference.  In fact I havent heard back from the senior advisor since I have sent all this stuff to him! Drobo is looking into the problem, and is asking me to send them "diagnostic reports" from the Drobo Dashboard.  They said there is a known problem with FW connections.  Whether the problem is Apple's or Drobo's I don't konw, but I haven't gotten any help or advise yet from either Apple or Drobo.

    I agree, this never was a problem with Lion!  Come on Apple!

  • jjack92 Calculating status...
    Currently Being Moderated
    Sep 26, 2012 10:48 PM (in response to molarmech)

    I have the same problem with my Synology Diskstation. At home I have a Mac Mini that was running Lion without problem. On the same network, I have a Synology DS212 which is used partly for Time Machine and the rest as external storage mounted via Finder (afp). Usually I have a hot corner on the screen allowing me to put the Mac Mini to sleep when I leave the machine.

     

    I upgraded to Mountain Lion successfully. But now when I put the Mac Mini in sleep mode and come back, my mounted partition of Synology is ejected (icon on desktop disappeared). Even if I had a browser connected to the Synology DiskStation web interface, I have been logged out (popup message).

  • fkoehn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 27, 2012 3:37 AM (in response to molarmech)

    Interesting - first time I hear them admitting it's in the Firewire code. My drives are Western Digitam MyBook Duo Firewire.

     

    Yesterday I had the first eject while in operation, the other ones occured after sleep.

     

    Sad to see how long it takes to fix this - maybe someone should point the Gadget blogs to this thread...

  • countertransference Calculating status...
    Currently Being Moderated
    Sep 30, 2012 10:25 AM (in response to iamapple)

    Hi. I've had the same issue after I upgraded my mid 2011 iMac from 10.7.5 to 10.8.2. My two external G-Tech FW 800 drives would unmount when (I think) the iMac went to sleep. I unchecked the allow to sleep button and the issue seems resolved. However, won't this seriously shorten the life of my external drives?

  • Eric-Thierry Calculating status...
    Currently Being Moderated
    Oct 3, 2012 5:56 PM (in response to countertransference)

    I have the same issue with my Synology Diskstation. Everything was working smoothly until I upgraded from Lion to Mountain Lion. Now, the NAS unmounts after inactivity on the Mac during night time, which screws up my daily 3 AM backups as the NAS volumes cannot be found. When I open the Finder in the morning, I see that the NAS is disconnected and I have to reconnect manually to access it.

     

    This is really annoying and I would have never upgraded to Moutain Lion if I had known about the issue.

     

    I strongly encourge any users who are wondering whether to install ML, NOT TO UPGRADE TO MOUTAIN LION if they they are using any network connected drives. I am currently running the latest version of ML (10.8.2).

     

    Hopefully, Apple will read this thread and do something about it. This is really a show stopper for me.

  • BlessedKev Calculating status...
    Currently Being Moderated
    Oct 4, 2012 6:27 AM (in response to iamapple)

    Similar issues:

     

    Lion 10.7.4 MacBook Pro

    2 Seagate external hard drives, one always ejects when computer sleeps. Upon waking it tells me the drive was not ejected properly. Disabled both "sleep mode" and "put hard drives to sleep when possible" in energy saver while I await news of a solution!

     

    Kevin

  • molarmech Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 4, 2012 8:05 AM (in response to Eric-Thierry)

    I was having the problem with my external backup devise using Time Machine, and began to think it was my Drobo S since the Senior Apple Support Advisor said there was nothing wrong with the OS (10.8.2) based on the diagnostics gathered from Capture Data (an Apple piece of software he emailed me).  So, I began working with Drobo Tech. Support, and they deduced from their diagnostics, that 1 of the 5 drives in the Drobo enclosure was defective.  I removed it, and everything is fine.  I'm connected via FW 800, and have the box checked to "put drives to sleep when possible" in energy saver.  I have even reconnected some other drives and card readers to the Drobo unit via daisey chain as it had been in Lion.  Everything is working fine now, and has been for about a week.

    I returned the drive to Amazon, and ordered a new one of the exact size and kind to see what happens when I have all five bays filled with similar drives as the Drobo is intened to operate.

    The drives I have are WD 2TB Red, which are designed for use in NAS backups.

    Once I get the new drive I'll keep you informed.

  • jjack92 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 4, 2012 10:13 AM (in response to Eric-Thierry)

    For the time being, on my Mac Mini, I worked around the issue with the Synology Diskstation by setting "Computer Sleep" slider to "Never". This fixed as well the RDP/VNC disconnections during sleep as well.

  • Little Nelle Calculating status...
    Currently Being Moderated
    Oct 4, 2012 10:35 AM (in response to jjack92)

    I had the same problem with my external hard drive disconnecting. As I posted on Sept. 26:

     

    Go to System Preferences/Energy Saver. Deselect the box that says "Put hard disks to sleep when possible", then close the lock.

     

    This solution has solved the problem for me, but apparenty not for others. It was the result of almost an hour with Apple tech help, one level up from the first guy who answered the phone and couldn't help me.

     

    Since then, I've heard back from the Apple help desk technician, who, with my permission, captured the data history of my computer so their engineers could examine the problem. So it sounds like they're looking into this conflict.

  • Eric-Thierry Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 5, 2012 11:30 AM (in response to Little Nelle)

    Deselecting "Put Hard disks to sleep when possible" did not work for me. The only workaround that worked is to set the Mac to never sleep, same of jjack92.

     

    FYI - I can leave all the Diskstation settings intact, i.e., the way I had it set up under Lion. I have it set up to hibernate after 20 minutes of inactivity - the hard drives will stop spinning to save energy and prolong life time - and it will wake without problems with the Mac set to never sleep.

     

    This is clearly a Mountain Lion problem. Hopefully Apple will fix this very soon. Not being able to let the Mac sleep is not an acceptable solution.

  • mavicmakefastwheels Calculating status...
    Currently Being Moderated
    Oct 7, 2012 7:09 AM (in response to Eric-Thierry)

    I repaired permissions & now the problem is not recurring. The machine is a MacBookPro, now on its 3rd OS upgrade (to Mountain Lion), the external drive is a Drobo connected though USB.

  • rhjph Level 1 Level 1 (15 points)
    Currently Being Moderated
    Oct 14, 2012 11:00 AM (in response to mavicmakefastwheels)

    I have a USB 3 3TB LaCie drive connected to my 2010 MacPro as Time Machine Backup. This has started spontaneously unmounting, under Lion. I installed the September 2012 LaCie USB 3 driver which has marginally improved performance but has not prevented the problem. Quite often  after it has unmounted it is impossible to get the OS to see the the connected drive (rebooting, replugging, changing leads, etc), although the remedy suggested by one poster, to rapidly pull out the USB 3 lead and immediately re-insert it seems to work 2 times out of 3. It is therefore, in my case, nothing to do with ML.

  • Patrick Quinn-Paquet Calculating status...
    Currently Being Moderated
    Oct 22, 2012 3:31 PM (in response to rhjph)

    I have a similar issue here. Western Digital drive 1 TB used for TimeMachine. I got the error message on wakeup many times and now, my drive refuses to mount 4 out of 5 times. Once it finally mounts, the TimeMachine backup starts and fails after 10-15 min. I did all my updates on my iMac 27. Now running 10.8.2.

     

    Is my external drive dead now?

  • rhjph Level 1 Level 1 (15 points)
    Currently Being Moderated
    Oct 29, 2012 12:08 PM (in response to Patrick Quinn-Paquet)

    It might be, but probably not. I have recreated all my Time Machine back-ups from scratch by erasing and repairing the disks, and then copying all the data again (losing all older back-ups of course). At the moment everything is working as it should, but I have not reinstated the "Put hard disks to sleep when possible" option. So far neither of the LaCie USB3 disks has unmounted spontaneously. I have also invested in a big G-Tech eSATA disk running SuperDuper to protect me (I hope) from any more Time Machine Grand Failures.

  • debaire Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 4, 2012 3:41 AM (in response to iamapple)

    All of my problems seemed to have disappeared for no reason. My lone problem hard drive has not ejected for any reason for the past couple of weeks. It's kind of a daze, but was there a supplemental update to 10.8.2? I can't remember now. If there was, it seemed to have done the trick. 10.8.2 (12C60) running on a mid-2010 15" MacBook Pro. The problem HD was a LaCie 2TB USB drive.

1 ... 6 7 8 9 10 ... 29 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (38)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.