Skip navigation

how do I use a cups printer on a linux machine from mountain lion

6129 Views 37 Replies Latest reply: Jan 19, 2014 8:57 AM by rminot RSS
1 2 3 Previous Next
ralf_on_iMac Calculating status...
Currently Being Moderated
Oct 3, 2012 2:03 PM

I have always used a linux cups printer on my network from my iMac. You could even browse the printer when looking for it. Worked fine.

Now in the updated Mountain Lion (10.8.2) is cannot see the remote printer anymore. 

If I create the printer using cups through the web interface on my iMac, which is conected to the linux server, I can create teh printer, and print a test page on this printer on the linux server! Great.

But I cannot pick the printer from a list from any application on my Mac. It is as if it does not exist (but I can print a testpage though ...).

This a a real bad change in Mountain Lion. I consider to go back to Lion (10.7).

 

Isn't there any way to get this working or do I realy need to downgrade to 10.7

 

Thanks for any hints!

iMac, Mac OS X (10.7.2)
  • VikingOSX Level 5 Level 5 (4,675 points)

    In the Print & Scan preferences, unlock and then click the + to add a printer. Once the Add panel pops up, right-button click on the icon bar and click Customize Toolbar ...

     

    Now drag the Advanced gear icon up next to the Windows icon.

     

    With your networked Linux printer turned on, single-click the Advanced icon and see if it discovers your Linux cups printer. If it doesn't, it will default to Fax. The Type selector has other print connection choices.

     

    Though I have a networked HP printer, my OS X and Fedora boxes each access it independently. I didn't want to disrupt my work environment to make the printer "owned" by cups in Fedora and shared with ML.

    Mac mini, OS X Mountain Lion (10.8.2), • 8GB • Vertex 4 128GB SSD • 500GB
  • Grant Bennet-Alder Level 8 Level 8 (48,105 points)

    Take alook at this discussion, too:

     

    Connecting to linux cups server

    Mac Pro (Early 2009), Mac OS X (10.6.8), & Server, PPC, & AppleTalk Printers
  • VikingOSX Level 5 Level 5 (4,675 points)

    Good catch! Been West of Boston myself several times.

  • VikingOSX Level 5 Level 5 (4,675 points)

    On 10.7.5, CUPS is 1.5.4, same as on Fedora 17.

    On 10.8.2, CUPS is 1.6.1.

     

    I think here is a contributing factor to not seeing remote CUPS printers on 10.8.2. This is the only difference between files except that all of the nice informative comments have been ripped out of the 10.8.2 config file. The same differences occur in the cupsd.conf.default file. The snmp.conf files are the same.

     

    10.7.5 cupsd.conf                                   10.8.2 cupsd.conf

     

    BrowseLocalProtocols CUPS dnssd          BrowseLocalProtocols dnssd

     

    Try updating the 10.8.2 config files and restarting cups. Then see if your Linux printer is visible through the Print & Scan pref pane.

  • VikingOSX Level 5 Level 5 (4,675 points)

    Neither cupsd.conf file on Lion or Mountain Lion use the trailing true syntax for:

     

    BrowseProtocols CUPS dnssd

     

    I also thought it strange that Lion would capitalize “cups.”

     

    Try the following:

     

    BrowseLocalProtocols cups dnssd

    BrowseProtocols cups dnssd

     

    Probably same result, but stranger things do happen.

     

    Short of reading every bit of Cups documentation, I am out of ideas.

  • Grant Bennet-Alder Level 8 Level 8 (48,105 points)

    One thing that has been extremely vexing about Mac remote printing (to remote ANYTHING, not just linux), is "when and where do you put the driver?"

     

    The answer has usually been to send Postscript or .pdf data across the network, and only invoke the Driver to do the rasterization (if needed) at the most remote location, right next to the physical printer.

     

    What you have just done in your experiment is to eliminate the Driver at the near-end, pass the postscript across the network, re-assign the ouput at the last minute and invoke the Driver to rasterize and print. Replicate that in your current set-up (specifically, eliminating the rasterizing Driver at the near-end) and you have a working Printer.

    Mac Pro (Early 2009), Mac OS X (10.6.8), & Server, PPC, & AppleTalk Printers
  • Grant Bennet-Alder Level 8 Level 8 (48,105 points)

    I think you might be able to call it a generic IPP printer or an LPD (Line Printer Daemon) printer, rather that specify its actual type and driver. In some cases, you would then mention its IP Address (or the address of the computer holding it), since Bonjour will not help you find it in Unix-land.

    Mac Pro (Early 2009), Mac OS X (10.6.8), & Server, PPC, & AppleTalk Printers
1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.