Skip navigation

DynDNS as mail relay for Mountain Lion Server

1774 Views 7 Replies Latest reply: Oct 9, 2012 10:31 AM by ribizzl RSS
LincNesh Calculating status...
Currently Being Moderated
Sep 5, 2012 4:33 PM

Greetings ~

 

After installing Mountain Lion Server, I proceeded to configure the Mail Service to relay mail through my ISP as available in the Mail Services tab -- as many mail servers do not accept mail from residential IP numbers.  I have entered in the credentials that work successfully on client machines (DyDNS user id + outbound.mailhop.org).

 

There aren't really any options for these settings - just userID, password, and relay host.

 

While my credentials work fine in the Mail.app on non-server installs... it seems the options aren't avaible in the GUI to configure for DynDNS's relay server in the Server OS.  DynDNS support is far from helpful.  They just say -- it works; not our problem.

 

http://dyn.com/support/why-cant-i-send-mail/

 

Here is an exerpt from my SMTP logs... seems the ML Server isn't sending the credentials in a format DynDNS likes. 

 

<-------log example------->

 

Aug 30 07:48:24 mini.local postfix/smtp[22564]: warning: SASL authentication failure: No worthy mechs found
Aug 30 07:48:24 mini.local postfix/smtp[22564]: 0FDCE2EA981: SASL authentication failed; cannot authenticate to server outbound.mailhop.org[204.13.248.72]: no mechanism available
Aug 30 07:48:24 mini.local postfix/smtp[22564]: warning: SASL authentication failure: No worthy mechs found
Aug 30 07:48:24 mini.local postfix/smtp[22564]: 0FDCE2EA981: to=<user@example.com>, relay=outbound.mailhop.org[204.13.248.71]:25, delay=80548, delays=80547/0.07/0.91/0, dsn=4.7.0, status=deferred (SASL authentication failed; cannot authenticate to server outbound.mailhop.org[204.13.248.71]: no mechanism available)

 

Ideas?

  • Mark23 Level 3 Level 3 (975 points)
    Currently Being Moderated
    Sep 6, 2012 9:38 AM (in response to LincNesh)

    Using DNS Made Easy for your DNS (set other name servers at your registrar), combined with their SMTP Mail service should do the trick. Their support team is one of the best I have seen to date!

     

    You can use alternative ports for incoming and outgoing mail using their servers to circumvent the ISP's restrictions.

  • Mark23 Level 3 Level 3 (975 points)
    Currently Being Moderated
    Sep 6, 2012 12:44 PM (in response to LincNesh)

    Maybe you should call your ISP to check if and how port 25 TCP can be opened to you.

  • Mark23 Level 3 Level 3 (975 points)
    Currently Being Moderated
    Sep 10, 2012 10:01 AM (in response to Mark23)

    Enter this into terminal to get you going:

     

    sudo serveradmin settings mail:postfix:relayhost_enabled = yes

    sudo serveradmin settings mail:postfix:relayhost = "server.dyndns.com"

    sudo serveradmin settings mail:postfix:luser_relay_enabled = yes

    sudo serveradmin settings mail:postfix:smtp_auth_relay_dict:smtp_auth_relay_userid = "dyndns_username"

    sudo serveradmin settings mail:postfix:smtp_auth_relay_dict:smtp_auth_relay_pwd = "dyndns_password"

    Hope this helps

  • ribizzl Calculating status...
    Currently Being Moderated
    Oct 4, 2012 1:49 AM (in response to LincNesh)

    LincNesh,

     

    Did you find a solution to your problem? I have the same trouble with DynDNS and Mark23's last answer hasn't helped.

     

    Something must be different with Mountain Lion Server because the connection to DynDNS' Mail Relay has worked well in Lion Server for me.

     

    Cheers.

  • ribizzl Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 9, 2012 10:31 AM (in response to LincNesh)

    LincNesh,

     

    Seems the problem has been solved by Peter Rauen.

    See this discussion: Mail relay SASL problem / postconf -n

     

    I checked on my server and Peter is right. Although there are configs in /etc/postfix there is another path with postfix conf files: /Library/Server/Mail/Config/postfix

     

    I actually only had to insert this line to main.cf there: smtp_sasl_security_options =

     

    After a postfix reload my mails are being delivered via dyndns again.

     

    Cheers!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.