1 Reply Latest reply: Oct 4, 2012 5:37 AM by diesel vdub
Nicolebella2009 Level 1 Level 1 (0 points)

I have an iphone 3g and it has the version 4.2.1 and temple run needs the version 1.6 but when I went to download it, it said that I needed IOS 4.3.....It is wierd because I have an ipod touch 2nd generation with the same version as my iphone and it downloaded it perfectly...PLESE HELP and It isn't just temple run that won't download...


iPhone 3G, Other OS