Skip navigation

Mountain Lion 'requires 10.6.8' or later. Am I stuffed?

299 Views 6 Replies Latest reply: Oct 4, 2012 1:34 PM by Tobysphotos RSS
Tobysphotos Calculating status...
Currently Being Moderated
Oct 4, 2012 12:55 PM

My iMac is running fine on OSX 10.5.8 but I have just upgraded my iPhone to 6 and had to download iTunes10.7 which of course won't run without Mountain Lion.  I was about to buy it when I notice the web site says 'requires 10.6.8 or later. Am I stuffed?

iMac, Mac OS X (10.5.8)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.