Skip navigation

iPhone 5 confusing Wi-Fi data with Cellular?

12585 Views 31 Replies Latest reply: Oct 24, 2012 1:23 PM by hugahorse RSS
  • cdbarreras Calculating status...
    Currently Being Moderated
    Sep 22, 2012 6:45 AM (in response to TechnoSam)

    Contacted Apple Tech Support and their fix is to turn off all the apps running in the background because one of those could be using cellular data even though you are connected to wifi. So as I said to the rep, this confirms that cellular is being used while connected to wifi. The response is no, this would only be if that app relied on cellular and in that case yes it would use it, sounds fishy to me.

  • jefebarrio Calculating status...
    Currently Being Moderated
    Sep 22, 2012 9:44 AM (in response to TechnoSam)

    Same thing happening to me. I just got off the phone with Apple and Verizon. Apple sent me to over to Verizon, even though it is clearly an iphone glitch. They can't have us reverting to cellular for everything when we want to use wifi. Or if they do want us to revert back to cellular, we need to be able to cap speeds or something. It's a shady deal.

  • brian84 Calculating status...
    Currently Being Moderated
    Sep 22, 2012 10:32 AM (in response to TechnoSam)

    Also having this issue. Even when on WiFi (all last night), my data usage keeps going up. Have used 300MB in one day even though I've visited only a couple mobile friendly sites in this time, and I've been on WiFi 80% of the time.

  • cdbarreras Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 23, 2012 5:43 AM (in response to TechnoSam)

    Update: Since I called Verizon and Apple I have not had my phone use data while connected to wifi. I did a test also by unplugging my data connection to my router. My phone still connected to my wifi in my house but there was no feed from the internet. My phone never grabbed LTE and linked to the internet. It informed me that the connection was lost. This allowed me to find out if the phone would automatically grab LTE and it didn't. Up to this point the problem has not occurred again. Have no clue why but I am glad....

  • Gregord Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 24, 2012 6:51 AM (in response to Juice Searls)

    Juice, I have indeed done a test similar to the one you describe. My router fimware (tomato) has an option to block access to a given IP address. I just set a temporary block on my phone's IP. It resulted in the following:

     

    wifi and cellular lte turned ON. status bar indicated wifi for data. Visit webpage (youtube) spinning icon in status bar for a second, then page loads. Checked the usage page in settings. Sent and Received had increased.

     

    Clearly the Wifi Plus Cellular option is ON all the time now. My hunch is that there is a bug in the gracefully fallback to cellular mode or perhaps Apple is making some assumptions (such as latency or switching over too quickly) that result in falling back to cellular even when a wifi connection exists and could service the traffic, albeit perhaps a bit slower.

     

    This is concerning to me as I have only 1gb allotted on my verizon shared data plan. For now I am turning off cellular data unless I am away from wifi, and have turned off most icloud features.

     

    I suspect Apple will make some improvements to this soon, perhaps re-add the manual wifi plus cellular option. The carriers may have pressured Apple to remove the manual option, as it allows users to believe they are using wifi when in fact they are using their precious cellular megabytes. If that is the case, I am very disappointed in Verizon. Profit trumps customer experience yet again.

     

    My preference: re-add the wifi plus cellular option. That way we can explicitly turn it off. Also, there absolutely needs to be a statusbar indication that the phone is falling back to cellular when wifi is active and connected. In my tests the phone was using cellular data but the statusbar had the wifi icon.

  • 2eUser Calculating status...
    Currently Being Moderated
    Sep 24, 2012 6:52 AM (in response to TechnoSam)

    I'm having similar issues, 500MB used in 2 days.  That was more than I used in an average month on my 4.  I haven't changed any of my habits, I have wifi at home and work. The weird thing is it is only happening to 1 of the three iphone 5s in our household.  I turned off cell data last night and my usage counter hasn't gone up since.  Oddly enough the verizon web sute only shows 256MB of usage this morning.  Hopefully they get this ironed out.

  • scoooby-doo Calculating status...
    Currently Being Moderated
    Sep 24, 2012 7:10 AM (in response to pwdougherty)

    pwdougherty wrote:

     

    My iOS build is 10A405 so I know it's not a beta version... GM was 10A403

    Mine is still the 10A403. How did you update to the 405 build? Is there a big difference?

  • pwdougherty Calculating status...
    Currently Being Moderated
    Sep 24, 2012 9:58 AM (in response to scoooby-doo)

    @scooby

     

    My phone came out of the box with 10A405 I haven't updated it. Could it be slight differences based on carrier I am  on Verizon.

  • pwdougherty Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 24, 2012 10:03 AM (in response to Gregord)

    Greg I tried the same test and until I plugged WAN port back into my modem I could not load a safari page. I will try with YouTube tonight tho. As soon as my airports light went green though (plugged WAN port back in) the safari page loaded. I wonder if this is based on per app coding aka YouTube used wifi plus cellular API but apple corrected in its coding before releasing GM??

  • N64BOY39 Calculating status...
    Currently Being Moderated
    Sep 24, 2012 11:31 AM (in response to TechnoSam)

    I'm seeing a similar problem. I've used 2.4 GB in 3 days, and looking at my Verizon usage, a lot of it is coming at times like 4:34am, or in the evening when I know I was at home on WiFI. I've never used more than 3.5 a month while traveling and using my iPhone 4/4S to tether, but am on pace for 25GB this month. I even noticed the problem yesterday when at 1.1 GB and was mindful not to use the device when not on WiFi, and still jumped up to 2.4GB somehow.

  • RAFREEB Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 4, 2012 11:36 AM (in response to TechnoSam)

    I am having this issue of wifi being on but the phone is reverting to 3g. LTE is turned off due to a battery issue and I am not on Verizon. I am on Virgin Mobile Canada.

  • RAFREEB Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 4, 2012 4:32 PM (in response to TechnoSam)

    I'm on Virgin Mobile Canada and my iphone 5 is having this issue. I'm not on Verizon.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.