1 2 Previous Next 20 Replies Latest reply: Mar 19, 2013 1:31 PM by Csound1
rachelepoche Level 1 Level 1 (0 points)

Hello,

 

The gmail account is listed on the side bar under 'MAILBOX'> 'inbox'> 'gmail'. This works fine.

 

Further down the sidebar the account appears again under 'GMAIL'> [Gmail]> then all the sub folders like junk, sent mail etc. This is driving me mad. If I delete anything it reappears. Plus it holds duplicates of the emails in the inbox. If I try to delete the whole account from the sidebar it says 'IMAP command delete failed with server error: Internal folder cannot be deleted'. I haven't deleted the account through preferences because I want the account in Mail.

 

How do I get the mails to stay deleted? Can I prevent the dupllication of mails in the inbox?

 

Any help is much appreciated, I miss the satisfaction of a neat inbox!

 

Thank you.

 

Rachel


g4, s
  • 1. Re: Problem with Mail and gmail IMAP
    Csound1 Level 8 Level 8 (35,445 points)

    rachelepoche wrote:

     

    Hello,

     

    The gmail account is listed on the side bar under 'MAILBOX'> 'inbox'> 'gmail'. This works fine.

     

    Further down the sidebar the account appears again under 'GMAIL'> [Gmail]> then all the sub folders like junk, sent mail etc. This is driving me mad. If I delete anything it reappears.

    Where does it reappear? in the All Mail folder?

  • 2. Re: Problem with Mail and gmail IMAP
    rachelepoche Level 1 Level 1 (0 points)

    It will reapear in the folder it was deleted from. If I empty the spam folder, for example, the same messages reappear in the spam folder.

  • 3. Re: Problem with Mail and gmail IMAP
    Csound1 Level 8 Level 8 (35,445 points)

    Can you try something for me, pick a piece of mail, delete it, exit mail, restart and tell me if it reappears?

  • 4. Re: Problem with Mail and gmail IMAP
    rachelepoche Level 1 Level 1 (0 points)

    will do...

  • 5. Re: Problem with Mail and gmail IMAP
    rachelepoche Level 1 Level 1 (0 points)

    ..it has reappeared

     

    no wait! i forgot to exit mail. let me try again...

  • 6. Re: Problem with Mail and gmail IMAP
    rachelepoche Level 1 Level 1 (0 points)

    ...yup it reappears

  • 7. Re: Problem with Mail and gmail IMAP
    Csound1 Level 8 Level 8 (35,445 points)

    Now go to your gmail account on the website, is it in both places there as well?

  • 8. Re: Problem with Mail and gmail IMAP
    rachelepoche Level 1 Level 1 (0 points)

    yes, it is there in both places as well

  • 9. Re: Problem with Mail and gmail IMAP
    Csound1 Level 8 Level 8 (35,445 points)

    Then the problem is not with Mail, it is apparently accurately reflecting the account on the server (website). I would deal the problem by suppressing the display of any but the required mailboxes, in Gmail, Settings>Labels will allow the choice of folders displayed in Mail, while in you are in settings check what (if any) are for Spam. Then, in Mail make sure that 'Move Deleted Messages to the Trash Mailbox' is selected and finally check Mail's rules for any that pertain to Spam.

     

    Restart Mail after the changes.

  • 10. Re: Problem with Mail and gmail IMAP
    rachelepoche Level 1 Level 1 (0 points)

    I suppose that the problem is one of communication between Mail and gmail. I don't want to muddy the waters but I thought it might have something to do with gmail archieveing mail instead of deleting it. Gmail does show the option:

    "When a message is marked as deleted and expunged from the last visible IMAP folder:

    "

    but it cannot be changed from the default.

     

    However I really really don't know.

  • 11. Re: Problem with Mail and gmail IMAP
    Csound1 Level 8 Level 8 (35,445 points)

    GMail is non standard, if you suppress the All Mail folder it's easier

  • 12. Re: Problem with Mail and gmail IMAP
    Chris Winkler1 Level 2 Level 2 (165 points)

    Csound1 wrote:

     

    Then the problem is not with Mail, it is apparently accurately reflecting the account on the server (website). I would deal the problem by suppressing the display of any but the required mailboxes, in Gmail, Settings>Labels will allow the choice of folders displayed in Mail, while in you are in settings check what (if any) are for Spam. Then, in Mail make sure that 'Move Deleted Messages to the Trash Mailbox' is selected and finally check Mail's rules for any that pertain to Spam.

     

    Restart Mail after the changes.

    That got rid of the 2nd folder. I went in Gmail settings>Labels and unchecked every Show check box, with the Inbox grayed out. Its the only one showing and the 2nd one is now gone after quitting Mail and restarting. Great help!

  • 13. Re: Problem with Mail and gmail IMAP
    jeremymaxwell Level 1 Level 1 (10 points)

    This is all great info! Unfortunately, it has only worked on One of my Three gmail accounts. Very weird. I have gone into Gmail>Settings>Labels and everything expect "Inbox" is unchecked. So, One would think that on rebooting Mac Mail, only the inbox for the three Gmail accounts would show. But The All Mail/ Spam, etc folders are still there for 2 Gmail accounts!  I have even deleted the accounts completely from MacMail and started from scratch, but with the same results.  Any extra advice for troubleshooting this?

  • 14. Re: Problem with Mail and gmail IMAP
    Csound1 Level 8 Level 8 (35,445 points)

    You have to change which folders show from the Gmail website,

     

    In Gmail: Settings>Labels will allow the choice of folders displayed in Mail, (selecting Imap on will display them)

1 2 Previous Next