2 Replies Latest reply: Oct 4, 2012 2:53 PM by AnaMusic
ninar23 Level 1 Level 1 (0 points)

Please i really need help because i don't wanna get the itunes upgrade and then have one ipod work and not the other


iPod touch (4th generation), iOS 6, also a 3G ipod touch on 5.1.1