Skip navigation

My iphoto library has disappeared. How do I find it?

67275 Views 157 Replies Latest reply: Mar 14, 2014 5:58 AM by clodo9 RSS
  • Terence Devlin Level 10 Level 10 (121,655 points)

    We do see reports on here from folks whose Libraries have disappeared from time to time. However, no one has demonstrated a cause, or even a possible cause for these events. I don't think iPhoto can do it, simply because it doesn't have the code base to do that. It can delete material from a library but that's not the same as deleting an entire one. Finder can do it, it's possible that some back up apps might do it if misconfigured in some way, but no one has managed to definitively point to a cause. In that case we cannot rule out human error of some form. I've known of people who deleted their iPhoto Library accidentally, (moving something to trash while not realising that it was also selected) and one person who overwrote theirs with a blank one - in spite of a warning from the OS that exactly this would happen.


    In the meantime, until someone can point to a cause we can only suggest file recovery utilities and point out the absolute necessity of always having an up-to-date back up.






  • Doctor Random Calculating status...

    This worked for me, after an idea presented here:



    if you do a


    Finder> Go> Go to Folder


    enter /Volumes in the search box


    Click Go


    You should get a list of Volumes the machine knows about.


    I deleted the Macintosh HD alias file listed, and magically iPhoto Library reappeared and iPhoto worked normally.




  • beijaflor22 Calculating status...

    Hi Terence,


    I am experiencing a problem similar to the OP wherein my entire iPhoto library has disappeared. I don't know if this happened as a result of me moving files between my external hd and my macbook hd (although my library was not on my external) or something else. I didn't open iPhoto while making the transfer so I don't think it was human error, but at this point that is the only thing that seems plausible. The photos weren't backed up. Not a single photo is left. You mentioned about paying for a recovery. Is that even possible when the library wasn't backed up?

  • Terence Devlin Level 10 Level 10 (121,655 points)

    An app like

    File Salvage will scan your drive for recoverable file - but you'll need to pay for actual recovery. Set it to search for Jpegs and, as many files may have the same name, always restore the largest file it finds. That's most likely to be the master or original.

  • Polo_Mon Level 1 Level 1 (0 points)

    Hi All,


    I had the same problem several months back:  iPhoto library gone from my daily hard drive, AND more pernicious, its backup MIA on TimeMachine. Practically speaking, recovered my iPhoto library from my daily hard drive using DataRescue3. A bit arduous, but all photos recovered.


    MORE to the point what can be done as prevention? A recent problem on TimeMachine took me to a site, Apple  OSX  and  Time  Machine  Tips, which talked about iPhoto:


    TimeMachine does funny things to iPhoto Library when it runs with the Library open! Maybe disappearing iPhoto Library is a severe case? Maybe not. But again practically speaking, for the future, suspend TimeMachine backups during sessions of work with an open iPhoto Library?

  • Old Toad Level 10 Level 10 (113,115 points)

    What system and iPhoto versions are you running.  A while back iPhoto had a problem with Time Machine in that TM would not backup the library if it was open.  That was with an earlier system and iPhoto version.  Don't remember which at this time. With Mt. Lion and Lion (also Snow Leopard) with the current iPhoto at that time the library backups are working OK.

  • DivaCarla Calculating status...

    I came looking for some help because my iphoto has been emptied of photos. It happened when I was searching for a photo in Time Machine Backups. I accidentally started restoring an old version of the library. I stopped the restoration and that's when things went nuts.


    The photos are still on my hard drive because the space is taken up. I can't restore yesterday's back up because there is no room. I am not a tech person, and should not be doing any of this. But there is no one else here, so how do I find iphoto on my hard drive and restore the empty shell with (0) photos and events to function?


    I am still running leopard. I just bought snow leopard, but haven't installed yet? Might that installation help or do I need to solve this problem first?


    Thank you for your help.

  • DivaCarla Level 1 Level 1 (0 points)

    I kept looking and found the solution here:


    It was easy. Thank you.



  • sobarch Calculating status...

    I too have had my iPhoto Library disappear. I didn't do anything other than the usual. I found all my events and albums gone and my photos in a recovered file. Anything I did made it worse. It wouldn't point to the library I thought I was using to rebuild it and I accidentally turned my pictures folder into an iPhoto library. When I looked at what I thought was my library using Finder and show contents, the library was only updated to when I loaded OS 10.8, whichever cat that is. The library that was being updated is gone and I can't find it. I found a backup with photos I had taken recently on my backup drive and I 'rebulit' that library using iPhoto Library Manager. I still don't have all the albums and events that I made in the ensuing three months.


    I really do think there is a bug out there. I have made a giant mess of my data trying to sort this out. Any ideas for next steps?



  • beijaflor22 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2012 3:14 AM (in response to sobarch)

    I'm inclined to agree with Sherry's comment about there being a bug out there. I downloaded and ran FileSavage and not a single file from my iPhoto library was recovered. Instead it pulled up hundreds of pictures that I've viewed on the internet. I'm pretty computer proficient although definitely not tech savvy. Either I ran the search wrong or my files haven't been "deleted" per se but just some how vanished into a black hole of computer coded language.


    Also, when I connected my iPhone last night to upload some pictures, iPhoto told me there were no pictures to import. There are over 200 photos on my iPhone. Something weird is going on and I don't think I'm the only one this is happening to.

  • Old Toad Level 10 Level 10 (113,115 points)

    Did you try Doctor Random's suggestion above?



  • Stas Slobodyanik Calculating status...
    Currently Being Moderated
    Oct 29, 2012 12:25 PM (in response to Old Toad)

    @Old Toad, I'm sorry for offtopic (semi-offtopic) message, but could you please take a look at this thread:



    it's all about the issue when iPhoto replaces all original photos with thumbnails without permission.

    To me it's like my whole library has dissapeared!


    Really appreciate your expertise on Apple software.


    Thanks in advance!

  • Old Toad Level 10 Level 10 (113,115 points)

    I've been to that thread before and have nothing to add over what Terence has.  Do you have any backups in Time Machine that you can restore to see if you can find the newest library with full sized masters?

  • Stas Slobodyanik Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 30, 2012 12:13 AM (in response to Old Toad)

    No TImeMachine backups, unfortunately.


    Can't beleive Apple could be knowing about such a HUGE hole in their product, and did nothing to help the customers. Seems that I'm not alone with this issue.


    I just want to know for sure is there any chance to get original photos from this existing lib? Manually? With some additional plugins etc.?

  • Stas Slobodyanik Level 1 Level 1 (0 points)

    No TImeMachine backups, unfortunately.


    Can't beleive Apple could be knowing about such a HUGE hole in their product, and did nothing to help the customers. Seems that I'm not alone with this issue.


    I just want to know for sure is there any chance to get original photos from this existing lib? Manually? With some additional plugins etc.?


    Please-please-please, give me some insights about possible solution for this issue. Why should we miss our memories because of some software fault?


    Thanks in advance for any further ideas!

1 2 3 4 5 ... 11 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.