Skip navigation

time machine very slow with mountain lion

167830 Views 650 Replies Latest reply: Feb 11, 2014 4:45 PM by Booker T. RSS Branched to a new discussion.
  • Yuk12 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 4, 2012 6:07 PM (in response to r.geromin)

    Supplemental update is availabe as of today for 10.7.5. Check to see whether 10.8.2 Supplemental update is also available. Good luck.

  • berthej Calculating status...
    Currently Being Moderated
    Oct 5, 2012 3:41 AM (in response to Yuk12)

    Excluding my external time machine drive (thunderbolt) in Sophos, and then doing the 10.7.5 (Lion) Supplement update solved the issue for me, without tinkering with Spotlight. Backed up 16GB in no time.

  • JDfunky Level 1 Level 1 (145 points)
    Currently Being Moderated
    Oct 5, 2012 6:06 AM (in response to lauhub)

    lauhub wrote:


    Can you let us know if this solution is definitive. In my case, it was not: the day after, my TM backup went slow again.


    @lauhub: yes, just downloaded some stuff a day later, TM had 2GB to backup, zipped through it in about a minute or so.


    To others who are posting about the supplemental update for 10.8.2 Mountain Lion (i.e. relevant to this particular discussion), this update does not (at least as far as Apple describes it) address the issue of slow TM backups. TM issue is only dealt with in the supplemental update for 10.7.5 (Lion) users.


    For me, as I posted earlier, deleting the Spotlight Index and reindexing has solved my TM problems in 10.8.2 and Spotlight is working fine.... and I have not downloaded the 10.8.2 supp update. (Nor will I... I looked at it and thought, why would I bother to download that with three bizarre bug fixes that would not apply to me.. nope, I don't use Japanese characters in Mail, don't use Parental controls in Safari, and I have somewhat less than 64GB of RAM.)

  • David Schwab Level 1 Level 1 (110 points)
    Currently Being Moderated
    Oct 5, 2012 7:51 AM (in response to 1tombhome)

    Hello everyone. I'm here reading this because of similar Time Machine problems. In my case I'm using Time Machine with a new USB 1TB hard drive connected directly to my iMac. I started using this when I was running Lion probably in February. It had been working fine, even after I updated to Mountain Lion the day it was released.


    The initial backup took a while, and then the hourly backups were fairly quick.


    Then earlier this week I starting having an issue with my Mac where applications wouldn't launch, and that turned out to be a permissions issue. I don't know what brought it on, but I booted into the recovery partition, checked out the hard drive with Disk Utility, and then repaired the permissions. That fixed that issue.


    Upon rebooting, the next hourly Time Machine backup never would get anywhere. In fact two days had gone by without a backup. They wouldn't fail, but they wouldn't finish either. It stayed at about 50MB out of 500 or so MBs for two days. So I found this thread and a few others, and tried the various fixes people proposed; I reset my PRAM. I deleted the Spotlight indexes and let it rebuild them. I ran that command in the terminal. Nothing worked.


    I downloaded the Time Machine Buddy widget, and it showed it was "Forcing deep traversal on source".


    So I decided that since there wasn't anything in my backup from the beginning of August that I needed, I formatted the backup drive and started over. It said it was going to take 11 days!  It didn't take that long the first time I backed up my drive! So I started over again, and now it said 30 days!  I stopped it again, reformatted the drive again, ran Disk Warrior on it to optimize the directory, and started over. Now it  said it was going to take 12 hours. Great! Left it over night, and... now it says 3 days. It had gone from 4.92 GB to 17GB. I have 553GB of data on my 1TB hard drive.


    Finally I decided that was enough. I wasn't going to go any longer without a recent backup. I liked using Time Machine, but honestly I rarely went to retrieve a file from a particular day. The other issue is when it was backing up the Mac became very sluggish, sometimes to the point that I had to stop the backup to get anything done. It wasn't like that in Lion. So I reformatted the drive again, and now I'm using Carbon Copy Cloner. In one hour it has copied 25GB.  It took Time machine 8 hours to copy 12GB. I have CCC set up to do hourly backups, and to temporarily archive changed or deleted files, so it should work about the same.


    So clearly something broke with Time Machine. This supplemental update to Lion released today says it fixes this issue on Lion, but not the one for Mountain Lion.

  • cfsdoriga Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 5, 2012 8:48 AM (in response to David Schwab)

    I tried backing up with an external HD (LaCie Quadra 1 TB using FireWire 800) using crash plan+ and Get Backup2 and the process also took ages. For me it's not a problem  with TM, but it's a problem with ML communication with external HD, network HD or other partition of the same HD.


    Apple, please fix the bug ASAP.

  • gobigbue24 Calculating status...
    Currently Being Moderated
    Oct 5, 2012 8:51 AM (in response to 1tombhome)

    Yeah !!! Supplemental 10.7.5 update fixed the issue for me. Seems there were two "builds" or versions for 10.7.5. Unfortunately we were never told that !!!!

  • gobigbue24 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 5, 2012 11:45 AM (in response to cfsdoriga)

    Fixed with Supplemental update.

  • r.geromin Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 5, 2012 2:28 PM (in response to cfsdoriga)

    ML 10.8.2 with Supplementary Update.

    TM doesn't work. The only way is to disable Spotlight.


    I decided to delete /.fseventsd.

    reboot but same bug, TM very slow but it finished everytime.


    So I tryed this way:

    - sudo mdutil -E / (rebuilt spotlight index)

    - select a new TM in the TM menu

    - new backup in a new HD

    TM is working now (1 hour @ 283 GB with FW800). Not yed finished but after 15 min --> 50 GB backupped (before, with the old time machine, after 8 hour less than 10 GB copied).


    I hope this can be the solution.

    Good luck

  • TStam Level 1 Level 1 (75 points)
    Currently Being Moderated
    Oct 5, 2012 2:51 PM (in response to r.geromin)

    Mine does work, just slowly. Mac Pro, ethernet and Mac Book Pro, wireless. I don't have to disable Spotlight. I've just got it disabled for drives other than Macintosh HD.

  • David Schwab Level 1 Level 1 (110 points)
    Currently Being Moderated
    Oct 5, 2012 7:52 PM (in response to 1tombhome)

    OK, so I decided to give it another try. I used OnyX to delete the Spotlight index. Last time Spotlight went through its thing and was done rather quickly. This time it took about 4 hours. Then later on it started indexing again, said it was going to take eight hours, but finished in about three.


    So once it was finsihed, I reformatted the hard drive and added it to Time Machne. I also changed its name slightly—it was "Backup Drive" and now it's "BackupDrive"—and thewn I started the TimeMachine backup.


    So far so good. It's only been running a short time and is at 1.57GB of 579GB. It says it will take three days.  I'll just sit it out and see what happens.


  • Ringale Calculating status...
    Currently Being Moderated
    Oct 6, 2012 4:53 AM (in response to 1tombhome)

    Dear All, after fully review this discussion and tried everything out, including a ML 1.8.2 update, the only thing that works out for me was to DELETE my entire previous backups.



    The first backup of aprox. 135GB took 6hrs. and from then every backup it's been done OK!

  • r.geromin Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 6, 2012 5:31 AM (in response to r.geromin)

    First backup completed in 1 hour (283 GB).

    Second backup (incremental) of 10 MB copied.

    Now TM works good.


    Well, but my previous backups probably are unusable and this is not a good thing!

  • David Schwab Level 1 Level 1 (110 points)
    Currently Being Moderated
    Oct 6, 2012 7:10 AM (in response to r.geromin)

    1 hour huh?  I'm back to 11 days.   I should have stuck with Carbon Copy Cloner. That was only going to take about 4 days.

  • David Schwab Level 1 Level 1 (110 points)
    Currently Being Moderated
    Oct 6, 2012 6:42 PM (in response to David Schwab)

    OK, now, over 11 hours later, it's up to 13 days!  It's been hovering around 36.90 GB of 579.46 GB for quite a while.


    This $ucks, and I REALLY should have stuck with CCC.

  • William Abbott Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 6, 2012 7:15 PM (in response to David Schwab)

    I wish I knew how to help but I don't. Maybe the wizards of Cupertino will hear your bleat. Let's hope.


1 ... 17 18 19 20 21 ... 44 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (24)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.