1 2 3 4 Previous Next 52 Replies Latest reply: Sep 6, 2013 12:03 PM by bal07 Go to original post
  • 15. Re: 10.8.2 spotlight indexing issue
    Ted Savas Level 1 Level 1 (10 points)

    I tried the suggestions here to remove the two files and reinstall ML but it did nothing to fix it on my system.

     

    I do have to say that I reinstalled ML by booting to the recovery partition and re-installing over my exisiting system.  I did NOT install on an empty drive.  Not going to go through that pain.

  • 16. Re: 10.8.2 spotlight indexing issue
    adrianruica Level 1 Level 1 (0 points)

    I think it is something related to the home folder. I am in the same situation. I made a new user and everything was OK. I have moved everything from the existed user to the new user, correted the privileges of every file to be related to the new user and the problem came again. I deleted coresymbolicationd, caches, everything in /private/var/folders, restarted Spotlight. Everything works until the first restart or shutdown and then turn on.

    If I limit mdworker to use less CPU, using AppTammer it is interesting, but Dropbox will start an endless indexing and will use 100% CPU.

  • 17. Re: 10.8.2 spotlight indexing issue
    FatMac>MacPro Level 4 Level 4 (2,380 points)

    jianglai wrote:

     

    ...I suspect that there might be some issue with spotlight and the sandbox mechanism? When I boot the computer I also notice that lsboxd keeps running in activity monitor, which wasn't the case prior to 10.8.2 update...

    Have you tried the 10.8.2 Supplemental Update Apple has just posted here: http://support.apple.com/kb/DL1600 ?

  • 18. Re: 10.8.2 spotlight indexing issue
    adrianruica Level 1 Level 1 (0 points)

    Hi. I have news.

    1. The problem not happens on all of my Macs (2 iMacs 2008). One of them runs well, mdworker uses 0.1 to 1 % CPU. But even in this one, I checked in /Library/Caches and I have found the folder "com.apple.coresymbolicationd". So it not seems to be related with the bad funtion of mdworker.

    2. I updated Mountain Lion to 10.8.2 supplemental and the 100% cpu used by mdworker persists

     

    I still need to use AppTamer on mdworker and I really don't like this compromise.

  • 19. Re: 10.8.2 spotlight indexing issue
    hkim823 Level 1 Level 1 (0 points)

    The 10.8.2 supplemental update did not fix my problems with Spotlight. 

  • 20. Re: 10.8.2 spotlight indexing issue
    Lanny Level 5 Level 5 (4,485 points)

    Either the update added, "/Library/Cache/com.apple.coresymbolicationd," back, or it came back on its own. I deleted it again.

  • 21. Re: 10.8.2 spotlight indexing issue
    LThib Level 1 Level 1 (0 points)

    I have just upgraded from Snow Leopard to Mountain Lion (10.8.2) over the weekend, and I was having problems with my Smart Folders in Outlook not displaying the correct results. For instance I have a smart folder for Today's Mail, Yesterday's Mail, Since Yesterday's Mail....etc.  Navigating between these smart folders would give erratic, unreliable results. For instance I could see all the messages in my inboxes that came in today, but my Today's smart folder would not display them all, and navigating away and then back to it would not always display the same results.

     

    After performing some suggested resolutions, like having Spotlight re-index my identity folder (did this more than once), and did not correct the problem, I ran upon this thread. I reviewed the messages in Console and found one message that was targeted directly at the Office 2011 Identities folder:

     

    11/25/12 4:23:31.745 AM sandboxd[47051]: ([47049]) mdworker(47049) deny file-read-xattr /Users/lthib/Documents/Microsoft User Data/Office 2011 Identities/Main Identity_2012/Data Records/Schedules/0T/0B/0M/8K/x06_8299.olk14Schedule (pre-plugin fstype:hfs fsflag:480D000 flags:240000005E diag:0 uti:public.data plugin:internalPlainTextImporter - find suspect file using: sudo mdutil -t 49186957)

     

    Next thing I did was go to Disk Utility and ran Verify Disk Permissions, and found quite a bit of incorrect permissions. I ran Repair Disk Permissions, re-verified (no incorrect permissions remained).  Then I went to System Preferences...Spotlight, dropped my identity folder into the Privacy list, then removed it from that list. Using Activity Monitor, I filtered the processes by "md", watched those processes run. After a few minutes, I could see there was no longer any activity.  I then went back into Outlook and all of my Smart Folders now display the correct the results.  Quit and restarted Outlook a few times to make sure my results were consistent, and they were.

     

    At this point, I believe the problem is resolved.  Some posts in this thread led me to the solution. Took a while to find it. Hope my post helps.

     

    LThibx

  • 22. Re: 10.8.2 spotlight indexing issue
    Vojvoda Level 1 Level 1 (0 points)

    Hi All,

     

    I had the same problem on my MBP mid 2010 ML 10.8.2 with Crucial M4 256Gb. After sleep spotlight was not showing any results for applications, contacts etc. Re-boot seemed solving the issue until next time I close the lid. Silly of me to try upgrading Crucials firmware from 000F to 010G. Since the upgrade OS X refuses to boot. Spinning wheel with apple logo for ages. Cannot boot into Safe mode neither.

     

    Round 1.

    Tricky thing is that I tried to format the drive for a new clean install (have time machine bcp) with recovery mode. No luck, I see the partition with the 10.8.2 install however disk utility says: Unable to unmount the drive, and stops formatting.

    Round 2

    Put the SSD Crucial to my usb casing. Installed 10.8.2 to original MBP HD via recovery mode of the SSD. Tried to format the SSD drive with Disk utility ran from the original HD. Niet.

    Round 3

    Tried to re-instal the 10.8.2 via recovery mode to my original HD, unable to format the drive: Unable to unmount the drive, and stops formatting.

    Round 4

    I was able to format the drive with recovery DVD with 10.6.3 (came with the MBP), Installed new copy of 10.6.3 via original recovery DVD to my original drive, updated the Snow Leopard to be able to download the Mountain lion. Installed the 10.8.2 via bootable USB key, restored my datas from Time machine. Everything works fine on the original HD.

    Round 5

    Since I tried to format it with Linux ubuntu live CD, Gparted. It seems GPT locked SSD for any modification. Now I am not sure my drive is working correctly and its a kind of software problem.

    Round 6

    I give up!

  • 23. Re: 10.8.2 spotlight indexing issue
    stereoscott Level 1 Level 1 (0 points)

    FWIW, I have a new macbook pro retina with an SSD (fresh install, did not transfer any files over) and have applied OS X software updates as they come. I'm on 10.8.2 now and will notice spotlight indexing at random times for seemingly no reason.

  • 24. Re: 10.8.2 spotlight indexing issue
    miller.2676 Level 1 Level 1 (0 points)

    stereoscott -- I have the exact same situation as you. Please post back if you figure it out, and I'll do the same.

  • 25. Re: 10.8.2 spotlight indexing issue
    smides Level 1 Level 1 (0 points)

    Same issue as stereoscott and miller.2676.  Spotlight decides to index randomly and it seems to consume a lot of CPU.

     

    I'm using MBA 13", Late 2010.  OS X 10.8.2.

     

    I use Mail to connect to a Microsoft Exchange server.  Not sure if this is an additional clue.  (Certainly not a normal configuration at Apple).

  • 26. Re: 10.8.2 spotlight indexing issue
    adrianruica Level 1 Level 1 (0 points)

    Go to /System/Library/Sandbox/Profiles/ and there should be a file named "system.sb".

    1 Make a backup of the original one and place somewhere safe on your harddisk.

    2 Copy system.sb on the desktop to can edit.

    3 Open it with a text editor and check for the block thext:

    ;;; Allow IPC to standard system agents.

    (allow mach-lookup

           (global-name "com.apple.bsd.dirhelper")

           (global-name "com.apple.system.logger")

           (global-name "com.apple.system.notification_center")

           (global-name "com.apple.system.opendirectoryd.libinfo")

           (global-name "com.apple.system.DirectoryService.libinfo_v1")

           (global-name "com.apple.system.opendirectoryd.membership")

           (global-name "com.apple.xpcd"))

     

    4 Add these 2 lines (in bold), then the block thext will look like this:

    ;;; Allow IPC to standard system agents.

    (allow mach-lookup

           (global-name "com.apple.bsd.dirhelper")

           (global-name "com.apple.system.logger")

           (global-name "com.apple.system.notification_center")

           (global-name "com.apple.system.opendirectoryd.libinfo")

           (global-name "com.apple.system.DirectoryService.libinfo_v1")

           (global-name "com.apple.system.opendirectoryd.membership")

           (local-name "com.apple.ls.boxd")

           (global-name "com.apple.is.boxd")

           (global-name "com.apple.xpcd"))

     

    5 Save system.sb on the destop, then delete the original one in the /System/Library/Sandbox/Profile and replace with this modified one. Spotlight (mdworker) should calm down.

     

    Thanks to Phobos.

  • 27. Re: 10.8.2 spotlight indexing issue
    buffett424 Level 1 Level 1 (0 points)

    Thank you adrianruica and Phobos.  This fix has worked perfectly so far!  I'll post back if there is some unforseen problem.

     

    Did I just prevent spotlight from indexing at all, or just a fix for this specific issue?

     

    Thanks agian, my iMac is once again running smoothly.

  • 28. Re: 10.8.2 spotlight indexing issue
    adrianruica Level 1 Level 1 (0 points)

    There are some months when I did this and all works smooth. It seem to be an error of programming, the process mdworker (spotlight) is erroneous sandboxed. It happens more on some Macs and less on others, no idea why. Spotlight works normal to me. Before this fix I should de-activate it, now this is ok. I always keep the "Activity Monitor" icon on the dock set on "CPU History". I was happy when I saw and tried the fix from Phobos and I am happy to help.

     

    Happy seasonal greetings.

  • 29. Re: 10.8.2 spotlight indexing issue
    ericnepean Level 1 Level 1 (50 points)

    I note that the two names that are added are slighlty different.

     

    one is: "com.apple.ls.boxd"  ilth a lower case "L"

    the other is ""com.apple.is.boxd" with a lower case "I"

     

    Is this difference intentional or a typo?