13 Replies Latest reply: Jul 7, 2014 12:11 AM by paciific
allanes5 Level 1 Level 1 (0 points)

Updated wife's iPhone 4 to iOS 5.0.1 and

 

Settings > Phone > My Number

shows UNKNOWN.

 

I assume this prevents imessages and sms messages from working because they are not going through, unless she has wifi signal.

She does not have 3g service so if she wanted to send an iMessaage without wifi signal, the phone should automatically switch to sms... and it doesn't.

All messaging settings are on: iMesages and Send as SMS.

 

I tried my sim from my iPhone 4 on 5.0.1 on her phone and get UNKNOWN number as well.

Tried her sim on my phone and her number shows. So it's definitely an issue with her phone.

 

Any ideas how to fix this.

  • 1. Re: Settings > Phone > My Number > Unknown
    randers4 Level 9 Level 9 (57,240 points)

    Long shot, but you could try resetting network settings: Settings>General>Reset>Reset Network Settings.  (This will also remove passwords for all previously joined wifi networks.)

  • 2. Re: Settings > Phone > My Number > Unknown
    Hydrex Level 1 Level 1 (5 points)

    I would restore the phone with iTunes and see if it fixes it.

  • 3. Re: Settings > Phone > My Number > Unknown
    kvs008 Level 1 Level 1 (10 points)

    Hey guys I had the same problem and there is such a simple fix to it.

     

    1. Turn on Airplane Mode - You will notice that you can not access your phone settings while airplane mode is on.

    2. Turn off Airplane Mode and Immediately go to your phone settings and click on the unknown number tab and you will be able to manually enter your number. After this you should also get a message from imessage saying that you might be charged some amout or something like that. Say okay and you are all set to go. Hopefully this helps for regular messaging also, my regualr messaging was already working only imessage was going through my email and not as my no. Enjoy!!!

  • 4. Re: Settings > Phone > My Number > Unknown
    allanes5 Level 1 Level 1 (0 points)

    Wow, thank you sooo much for your completly helpful answer.

    It fixed it!!! Worked lie a charm!!

    I had practically given up.

     

    Everybody on all the forums I posted this question would only suggest restoring as a possible fix.

  • 5. Re: Settings > Phone > My Number > Unknown
    Julio_Enrique Level 1 Level 1 (0 points)

    Thats does not worked for me on iPhone 5 iOS 6, somebody told me to put he sim pn another iPhone where could change the number in sertings and then put on the actually iPhone you uses... But not sure for now, still waiting for the sim cards adapters...

  • 6. Re: Settings > Phone > My Number > Unknown
    menores Level 1 Level 1 (0 points)

    After switching from ATT to T-Mobile I had the same problem. I was told it has to do with the number being ported and that it would take at least 24 hours. Then I tried all kinds of remedies like turning iMessage on and off, resetting network settings and so on. Nothing worked and as a result MMS did not work. Today I simply took the SIM card out while the phone was on and about 15 seconds later put it back in. The number immediately showed and all is fine now.

  • 7. Re: Settings > Phone > My Number > Unknown
    Usama Sadiq Level 1 Level 1 (0 points)

    Hey people this is what greatlt helped me.
    " As far as the number being shown "UNKNOWN" was there, i pulled out my sim card for about 20 seconds and then put it in again. It promptly showed my number in the settings>phone>my number.
    NOW activating imessage and facetime was quite frustrating, it kept on saying to wait and showing error some times. What i did was made a call from my iphone to someone and then clicked on Facetime. It said ' Activating " on the Call screen. Then facetime was there working. I want to Settings>Messages,,,it also activated my iMessages. Now both are working smoothly. I hope it may help you if you encounter any problem regarding it.
    Stay blessed.!!!

  • 8. Re: Settings > Phone > My Number > Unknown
    Usama Sadiq Level 1 Level 1 (0 points)

    Hey people this is what greatlt helped me.

    " As far as the number being shown "UNKNOWN" was there, i pulled out my sim card for about 20 seconds and then put it in again. It promptly showed my number in the settings>phone>my number.

    NOW activating imessage and facetime was quite frustrating, it kept on saying to wait and showing error some times. What i did was made a call from my iphone to someone and then clicked on Facetime. It said ' Activating " on the Call screen. Then facetime was there working. I want to Settings>Messages,,,it also activated my iMessages. Now both are working smoothly. I hope it may help you if you encounter any problem regarding it.

    Stay blessed.!!!


  • 9. Re: Settings > Phone > My Number > Unknown
    Usama Sadiq Level 1 Level 1 (0 points)

    Hey people this is what greatlt helped me.

    " As far as the number being shown "UNKNOWN" was there, i pulled out my sim card for about 20 seconds and then put it in again. It promptly showed my number in the settings>phone>my number.

    NOW activating imessage and facetime was quite frustrating, it kept on saying to wait and showing error some times. What i did was made a call from my iphone to someone and then clicked on Facetime. It said ' Activating " on the Call screen. Then facetime was there working. I want to Settings>Messages,,,it also activated my iMessages. Now both are working smoothly. I hope it may help you if you encounter any problem regarding it.

    Stay blessed.!!!


  • 10. Re: Settings > Phone > My Number > Unknown
    rushdi.hameed Level 1 Level 1 (0 points)

    neither of the above worked for me...:(

  • 11. Re: Settings > Phone > My Number > Unknown
    paciific Level 1 Level 1 (0 points)

    i did the same thing, but nothing changed and this drives me crazy. what can i do now? any other idea?

  • 12. Re: Settings > Phone > My Number > Unknown
    Briansyddall Level 1 Level 1 (75 points)

    Hi in settings number unknown just type in your mobile number

    and make sure the correct network is on the iPhone.

    bsydd uk

  • 13. Re: Settings > Phone > My Number > Unknown
    paciific Level 1 Level 1 (0 points)

    Come on! This is the point, it's locked. We can not change it.