Skip navigation

Temp fix for iOS 6 not pushing Exchange mail

299359 Views 929 Replies Latest reply: Apr 14, 2014 10:35 AM by RaghuSatya RSS Branched to a new discussion.
  • DQMIA Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 5, 2012 11:49 AM (in response to chrisreilly)



    I appreciate your post and observations but this forum has to do strictly with Exchange PUSH email on the iphone 5 running IOS 6 and not a google gmail account setup as an Exchange account.  Talking about anything else other than Exchange PUSH email issues on iphone 5 running IOS 6 just confuses the readers and the issue itself.



  • sdorn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 5, 2012 11:55 AM (in response to chrisreilly)

    This is interesting.  My push stops working very quickly after I enable cellular data, almost immediately.  I do not have to try and access a folder other than my inbox first.  In fact, I don't even have to open the mail app for it to stop working.  It just stops on its own.  However, I do have my mail set up to push not only my inbox, but also my sent mail folder.  I wonder if there is any connection there.  I think I will try turning that off and see.

  • Frank Malloy Level 2 Level 2 (350 points)
    Currently Being Moderated
    Oct 5, 2012 12:04 PM (in response to DQMIA)

    Google push email *is* exchange push email:



    So how is this different?

  • RobM22 Calculating status...
    Currently Being Moderated
    Oct 5, 2012 12:13 PM (in response to sdorn)

    If my cellular data is enabled with LTE on or off, I do not recieve any push notifications for exchange. But when I enable Wifi and disable the cellular data it will not work right away. So I enable airplane mode for about one minute and once I take it off airplane mode, I have working push notifications for exchange.  Extremely annoying but its the only thing that works if i want my push notifications.

  • DQMIA Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 5, 2012 12:19 PM (in response to Frank Malloy)

    Google does not use Exchange servers to push gmail messages!  That's the difference.  PLease, I don't want to confuse the issue at hand:  Push email does not work on Iphone 5 with email accounts connected to a corporate Exchange server.  Any other issue, i.e. gmail setup as an exchange account IS ANOTHER ISSUE all together.

  • Frank Malloy Level 2 Level 2 (350 points)
    Currently Being Moderated
    Oct 5, 2012 12:25 PM (in response to DQMIA)

    Sorry. My assumption was that setting up Gmail to the Google Exchange server meant it was using EAS push the same as corporate EAS.

  • Saurabh N Calculating status...
    Currently Being Moderated
    Oct 5, 2012 9:19 PM (in response to superclay)

    I am also facing this issue. I upgraded to iOS 6 on IPhone 4

  • jlaalja Calculating status...
    Currently Being Moderated
    Oct 6, 2012 5:52 AM (in response to Greg547)

    Greg547 and greggabe,


    Stats:  I have a 64Gb iPhone 5 running, what else, iOS 6.  I have been having push problem with Exchange from the beginning.  My first method of set up after I got my phone was to restore my iPhone 4 backup to it, because it was semi-quick and easy.  I had push problems, before I found this thread, I assumed it was due to my restoration method.  I then reverted my phone to a clean load of iOS 6, not DFU restore, and then loaded everything by hand, no backup restore.  Same problem!!  I could get it to push if I turned off LTE at work while on wireless and also by turning off Cellular data.  That is not an acceptable fix!  I decided to wait Apple/Verizon out for a proper fix.


    Greg and greg posted that were having some success with a DFU restore, so yesterday I figured, why not...I am at work and my phone can pretty much restore, etc. automatically.


    Steps taken:

    1.  Performed a backup of my phone in iTunes.  (I am not using iCloud backup)

    2.  Went into DFU/recovery mode as described above while plugged into my laptop with iTunes running.

    3.  Only option is to restore, so I hit it and restored my phone.

    4.  Once that was completed, I went through the prompts on my phone, i.e. the initial setup screens.

    5.  Went into Settings, General, Reset, and Reset Network Settings.  Let it complete that task.

    6.  I restored from the backup performed in Step 1 above.  This can take some time depending on the number of apps, photos, music, etc. installed before the backup.

    7.  Once everything was restored I checked my settings to ensure everthing was normal, i.e. Cellular data on, LTE on, Exchange set to Push, etc.



    Everything has been working perfectly ever since.  I completed the steps abover around 1300 Central time yesterday and now almost 19 hours later, push is still pushing and everything is working great!  I am still expecting it to stop, but it hasn't yet.


    I did this at work on wireless, drove 48+ miles home on 3G towers, until closer to home when it switched to LTE, and then all night at home on my home wireless....  Still working!  Still pushing!


    I will update if anything changes or if no changes, tomorrow...


    I doubted it would work, but so far so good!


    Thanks Greg547 and greggabe for the idea!

  • spidertaker23 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 6, 2012 7:26 AM (in response to jlaalja)

    Thank you for posting your experiences!  I was very doubtful that this process would fix the problem.  I appreciate you trying it and posting your results.


    I tried it this morning.  For the past couple minutes it has been working.  Push email and iMessages. 


    I will report back throughout the weekend to see if it continues to work.

  • spidertaker23 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 6, 2012 8:00 AM (in response to spidertaker23)

    I did the entire process - it was reassuring for a few minutes.  After 15 minutes push crashed (shows the crash in the crash list - same as before).  So far iMessage is still working.  I'm not sure how long iMessage will continue to work. 


    I was really hoping this would fix it.  I guess the really only recourse I have is to wait for a update now.

  • Frank Malloy Level 2 Level 2 (350 points)
    Currently Being Moderated
    Oct 6, 2012 8:09 AM (in response to spidertaker23)

    Taking all this time and effort to wipe the phone and do a software restore is not going to fix the problem. The iOS push software has a bug, and it doesn't matter if you start with a fresh, clean phone with a restore - you are just restoring a fresh copy of the iOS software...that has the bug.


    Again, a restore does not fix an OS bug. An OS fix will address the bug. It is of course possible that thru some changes of settings, etc. it could avoid the apsd crash, but from everything that has been tried it is highly unlikely it can be avoided, unless you're willing to use your phone on WiFi 100% of the time and keeping your cellular data always off. That's unreasonable.


    Your other, more reasonable option is to turn off push for Exchange accounts and fetch every 15 mins. Not optimal, but workable.


    I believe there is really nothing we can do to fix or work around this issue. Apple has to issue an update, and soon we hope.

  • jlaalja Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 6, 2012 8:12 AM (in response to spidertaker23)



    Sorry to hear it is not working!


    My iMessage has always worked from the beginning and I have never seen the push process show up in the diagnostics as crashed.  Very odd that there are differences with the same problem... 


    How many of you have had the push process crash show up?  How many haven't?


    Like I said, mine never has shown crashed.

  • greggabe Calculating status...
    Currently Being Moderated
    Oct 6, 2012 11:16 AM (in response to jlaalja)

    I'm gonna make two final points and then I'm not likely to check back in here unless I have the problem again.  First, it is not so simple to say it is a bug and there is nothing we can do but wait.  I'm in an office of 25 people and there are now 3 Iphone 5s and I'm the only one that has had the problem.  This suggests to me there is some strange combinations of factors at play that have plagued my phone and that there is something that can be done to avoid the problem arising until an update comes out.  Second, for those who have done it and restored from backup and it did not work, that is what happened to me at first too.  I had to choose restore as new phone in Itunes and then all I did was sync my apps.  All the other settings I input manually.  I'm on three days with no problems now.  Good luck, and here's hoping the problem does not come back for me.

  • rackattacka Calculating status...
    Currently Being Moderated
    Oct 6, 2012 8:19 PM (in response to jlaalja)

    It works! Finally....all the other fixes tried and failed. Running for 24 hours now without a problem. The longest previously was like 5-10 min before it went back to no push

  • javajunkie Level 1 Level 1 (25 points)
    Currently Being Moderated
    Oct 8, 2012 7:01 AM (in response to superclay)

    The temporary fix seems to work for me also. Now we just need Apple to fix this bug...

1 ... 20 21 22 23 24 ... 62 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (19)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.