Skip navigation

7.5.2 Update causing skipping when playing via AirPlay

19083 Views 62 Replies Latest reply: Feb 3, 2013 7:59 AM by chemboy RSS
  • DrsP1 Calculating status...

    I'm having a related problem. As a classical music lover, this is driving me nuts. It's especially noticable in soft passages in the music, when the volume is turned up high. When the dynamics increase, little pops/clicks appear (they sound a bit like static noise). It happens at irregular intervals. When you play pop music, the clicks will disappear (drown) in the music. But for true audiophiles who listen mainly to jazz and classical music this is a severe problem.

    I have checked everything and it's definitely an airplay issue. My apple lossless files are 100% okay and play without any problem, except when streamed via airplay. Also, it makes no difference whether you use the analogue or the optical ouptut from the airport express.

     

    I've created a sine frequency sweep myself in Adobe Audition, from 20 Hz up to 20000 Hz with a duration of 25 seconds and a level of -6 dB.

    When played through airplay, the clicks always start to appear after 4 seconds in the sweep, only to disappear at 23 seconds.

    The clicks manifest themselves at different volume levels. To my ears, they make the same sound as when you change the volume in iTunes when streaming music through airplay. Only when you set the volume in iTunes extremely low, the clicks will disappear.

    Apple engineers should use a frequency sweep to recreate the problem, as this is very revealing.

     

    PS: file format isn't an issue here. I've converted the Apple Lossless file to MP3, and it makes no difference at all.

  • Blademan007 Calculating status...
    Currently Being Moderated
    Dec 21, 2012 11:28 AM (in response to DrsP1)

    Sounds like higher volume of iTunes is causing digital clipping.

  • chemboy Calculating status...

    I found changing channels fixed the skipping issue.

     

    The prob started when I recently updated the OS on my ipad. The tune would drop out for a moment, cut back in, then skip (to catch up?). Rather than resort to downgrading firmware, as suggested elsewhere in this thread, I thought I'd try garryrobson's channel-switching technique first.

     

    I had set my airport express base station channel to 6, so changed it to 12 and, hey presto, not a single skip for the last 4 albums :)

     

    As mentioned elsewhere, manual channel setting is done on the airport base station, which might not necessarily be the airport express unit you're streaming music to.

     

    To change channels:

     

    Open airport utility, select the main airport device, click edit, go to advanced > wifi settings > radio channel. I only changed the 2.4gh one from 6 to 12 and clicked the blue done button, ensuring auto was turned off. The unit then rebooted and everything was fine.

     

    I hope this works for others too - well done garryrobson - sort it out apple!

1 2 3 4 5 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.