6 Replies Latest reply: Mar 16, 2013 12:38 PM by The hatter
Cesare G. Level 1 Level 1 (95 points)

Bought as a full 64bit system and now even Apple is not  listing it as it would:

http://support.apple.com/kb/HT3770

So no Mountain Lion support on a +2,5K€ system boutght as a 64bit one?

 

Com'on Apple stop playing with those iThings and go back to Mac computers...


Mac Pro, Mac OS X (10.7.3), OWC-SSD 240GB, 10GB RAM, ATI 5870
  • 1. Re: Where are 1,1 (2006) Mac Pros?
    Linc Davis Level 10 Level 10 (118,005 points)

    It runs 64-bit applications. It can't boot a 64-bit kernel. Whether Apple plays with iThings or not will have no effect on a 6-year-old discontinued product.

  • 2. Re: Where are 1,1 (2006) Mac Pros?
    The hatter Level 9 Level 9 (58,880 points)

    you can't use 48GB of memory, and the cost would be as much as a new model.

     

    you can't really use GTX 570 to full advantage, and it is graphic subsystem and drivers that was probably one reason. It was and still is 64-bit cpu and registers, it never had a UEFI 2.x EFI64, and even the 2008's EFI is rather iffy and downright buggy and some PCIe 2.0 controllers and booting from same don't work properly.

     

    Apple Specials shows 2010 $1819. 6-yrs and it runs well is pretty good and better than a $2500 laptop of that age.

     

    Your are ranting to other end users.

  • 3. Re: Where are 1,1 (2006) Mac Pros?
    Cesare G. Level 1 Level 1 (95 points)

    Maybe you guys are just not getting the point.

     

    I bought it as a full 64bit computer and now the same company -Apple-  is telling her users that "sorry, that was not true!"

     

    The questiion is why should I upgrade buying a new Mac Pro if my actual config is just working as aspected and should work as a full 64bit config? Is just a silly Apple decision of not supporting a system that even today is better that some new non-Pro models. AAMOF I can even run Windows 7 64bit on it.... but not because Apple support it... of course you have to hack a bit just because Apple decided to give no support for such a config.

     

    That is a stupid move most of all because the current MacPro models are just "old": no USB3, no Thunderbolt, no SDXC slot, old video cards ... but of course same old price... in the mean time that price should have been lowered a lot (maybe up to 30-40% in those config whitout a super Xeon config). At an updated price I would have bought a new Mac Pro already (at least 8 months ago). New Xeon CPUs are coming... we'll see what's going to happen.

     

    Very old-school Mac user here guys... one of those user who always supported Apple especially when things were not going as well today.

     

     

    There is only one absolute certainty: Apple is no more investing in the Pro market. And it is a real shame.

  • 4. Re: Where are 1,1 (2006) Mac Pros?
    mediated Level 1 Level 1 (0 points)

    I'm shocked that Apple doesn't support 2006 Mac Pros. It's a cybercrime! As my machine has 8GB RAM, 2TB disk space, upgraded video card to Radeon 5770 it should be capable of running the latest and greatest Mac software. Basically this is going to force me to buy another machine, when as you point out the newer Mac Pros aren't really all that much better. (2x 2.66 Ghz Dual Cores vs. today) Pretty disappointed that Apple can't be bothered to support legacy Pro Macs.

  • 5. Re: Where are 1,1 (2006) Mac Pros?
    mediated Level 1 Level 1 (0 points)

    If it can't boot, why are there hackable ways to get Mountain Lion to run on this machine? Apple should be able to make an official solution.

  • 6. Re: Where are 1,1 (2006) Mac Pros?
    The hatter Level 9 Level 9 (58,880 points)

    they did. early DP builds would but they decided not to.

    windows 7 x64 pro runs, but does not boot the install DVD as is.

    Early 2008 3, 1 has preliminary first EFI64 that does not support UEFI required for Windows 8

    you have 32-bit EFI 1.1 and no work was done on it since 2007when EFI 2.X UEFI  standards was begun. some things cwn be oatched in various ways and even all the code compilers used now are pure 64-bit, so no 32-bit driver, ever the PCIE 1.1 is going to be an ussue and bug.

    TurboTax 2012 dropped support for 32-bit, for 10.6.8, for 32-bit processors.

    Long overdue seeing it took so long to transition to a 64-bit only architecture and kernel.

    for a hobby there is probably some learning value to play with a bootstrap loader.