Skip navigation

iPhone 5 wifi issues

1443497 Views 4,653 Replies Latest reply: Apr 5, 2014 1:09 PM by intuitionist RSS Branched to a new discussion.
  • Eric Maier Level 1 Level 1 (45 points)
    Currently Being Moderated
    Oct 6, 2012 7:52 PM (in response to SpanishCop)

    They are likely 2 separate things. iOS6 issues are clearly software on existing iDevices that worked fine before the update check the other discussions.

     

    With iPhone 5, there are absolutely some with hardware issues. I'd make it my priority to troubleshoot that before your return period runs out.

     

    Divide your problems and conquer them! Good luck!

  • JonnyITokyo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 6, 2012 9:19 PM (in response to Eric Maier)

    I agree, there seems to be a couple of different problems bundled under "WIFI issues" here.

     

    For me, I'm not having troubles connecting to WIFI and the connection does not drop. The trouble is the WIFI is VERY slow, like 0.3 Mbit/s (tested with a benchmarking app)

    I even tried another old router - same speed.

    I get around 2 Mbit/s with my previous iPhone 4 on both these routers.

    For now, I use 3G on my iPhone 5, which is way faster. Sometimes it kicks into LTE too which gives a great speed boost as well. But the WIFI issue... maybe I'll go ask my carrier shop where I bought it two days ago, or next step is to go to a genius desk for some genius advice.....

  • kidvicious1973 Calculating status...
    Currently Being Moderated
    Oct 7, 2012 5:45 AM (in response to tobifs)

    Same issues as above. Resetting router fixes temporarily. Turning wifi off then on on iPhone also works temporarily. All started when I upgraded my iPhone 4 to iOS6

  • mrs.nightly Calculating status...
    Currently Being Moderated
    Oct 7, 2012 6:01 AM (in response to tobifs)

    Ok so is Apple doing anything about this?  There are thousands of people having the issue, apparently. Apple, where are you?

  • firthy2009 Calculating status...
    Currently Being Moderated
    Oct 7, 2012 6:16 AM (in response to mrs.nightly)

    Come on apple do something PLEASE we are sick of issues out of the box. The android world are laughing at us. Orange here in the uk acknowledge there is an issue, listen to all your avid supporters and get your finger out.

  • omegis Level 1 Level 1 (15 points)
    Currently Being Moderated
    Oct 7, 2012 8:11 AM (in response to JonnyITokyo)

    Possible Wi-Fi Fix

     

    Settings > Safari

    - Clear History

    - Clear Cookies and Data

     

    I'll also add that a hard reset is recommended afterwards.

     

    Confirmed to fix Wi-Fi on my iPhone 5

  • SpanishCop Calculating status...
    Currently Being Moderated
    Oct 7, 2012 8:06 AM (in response to tobifs)

    Well.... As I hear more people say that they are having similar issues as I am when upgrading from older devices and having same connectivity issues with wifi it does make me feel a little more at ease that it's a software issue with iOS 6 and not so much a hardware issue with my iPhone 5. Hope an update comes out soon fixin this issue. Come'on apple lets get a patch out to fix these issues. 

  • superfox247 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 7, 2012 8:12 AM (in response to SpanishCop)

    It's not an iOS issue see below:

    Like to share with you my findings and resolution with the iPhone 5 Wi-Fi slow and unusable connection when using WPA, WPA2. I work as Network engineer and also hold a Cisco CCNP and other security qualifications. Hopefully this might resolve and help some people out.

     

    After experiencing unusable Wi-Fi on various networks with lots of network timeouts on my new IPhone 5 16GB Black I downloaded an app that allows you to ping from iPhone/iPad I used a paid app called Scany but there are lots of free apps that allow you to ping.

     

    What I discovered testing with my own wireless N access point 802.11n:

     

    From my iPhone 5 I ran a continuous ping of around 500 packets to my wireless N access point IP address.. Remember we are testing the Wi-Fi connection so don’t add complications of pinging across the internet which could introduce issues and latency out of your control.

     

    No Security – No Issues

    WEP Security – No Issues

    WPA with TKIP encryption - No Issues

    WPA2 with TKIP encryption - No Issues

    WPA with AES encryption – Approx. 70+% packet loss

    WPA2 with AES encryption - Approx. 70+% packet loss

     

    I used 2.4Ghz range and 5Ghz range. Same on both frequencies.

     

    So the issue I suffered and I suspect most people are suffering is down to WPA2 or WPA with AES encryption. If you can change to TKIP. I would not recommend selecting Automatic encryption as it is most likely to select AES as it is preferred encryption standard.

     

    Note WPA2 or WPA with TKIP encryption is very secure and should not really cause any real security concerns. AES is more secure though. The main difference you will notice though if you are using a wireless N Wi-Fi network is that TKIP will only allow data to pass at a theoretical speed of 54Mbits the same as a Wireless G network 802.11g

     

    I suspect most people connect to various secured Wi-Fi networks during our daily lives you would have no way of knowing or altering the security used or encryption in use. Most Wi-Fi networks I would imagine are WPA2 or WPA with AES encryption as this is the most secure standard you are likely suffer this problem.

     

    Don’t turn wireless off and I certainly cannot recommend using WEP as it is easily compromised.

     

    As there is no major stories in the media although growing along with the issue on this forum. I suspect the issue is limited to a small but substantial batch of iPhone 5’s. They reckon they’ve sold 5 million+ so it might not be that many when you sell that many phones.

     

    Resolution:

     

    Tried two system restores one from a backup and the next one setting the iPhone as a virgin/new phone. Issue still present. Resetting just your network connections will have no effect either.

     

    Phoned Apple Care first agent did not know about the issue, passed to supervisor who had only heard of one report of this but by the sound of it that seemed like another issue not connected to what I was reporting. They were not aware of it only being AES encryption as the issue. They only recommended dropping from WPA2 to WPA. Anyway I made an appointment with a Genius at my local Apple Store. (Milton Keynes, UK). They say they had not heard of the issue. I presented them with screenshots of the packet loss when using WPA/WPA2 with AES encryption and they were happy to exchange for a brand new phone as it was only 6 days old.

     

    New phone has no issues with any encryption.

     

    I have no idea if this issue is hardware or software. I have access to a IPhone 4 and IPhone 4s both running iOS6 neither of these suffer this problem. I would suggest getting your phone exchanged with apple sooner than later in case it does turn into a hardware issue.

     

    Hope this helps some people…….

  • kag49601 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 7, 2012 8:13 AM (in response to tobifs)

    I ha e confirmed on several occasions that when I stream data from my phone (either wifi sync, or AirPlay) my Internet speeds jump to 5-6mbps (what its supposed to be) when I turn the stream off, my speeds drop back to 300k.

     

    Has anyone else tried this yet? It has worked for me each time.

  • Danbricker Calculating status...
    Currently Being Moderated
    Oct 7, 2012 8:15 AM (in response to tobifs)

    Drove an hour to the apple store. Basically 10 minutes in and out with a new phone. Genius admitted they are looking into problems with the wifi. New phone 98:FE:94

  • WiseJD Level 4 Level 4 (1,120 points)
    Currently Being Moderated
    Oct 7, 2012 9:14 AM (in response to Danbricker)

    I'm 98:FE:94 with no issues!

  • Shaddow Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 7, 2012 10:04 AM (in response to tobifs)

    At least one person on the macrumors wifi thread reported that Apple support is now telling people about toggling the bluetooth for wifi problems.

     

    I find this hilarious. Apple support, when it comes to denying a problem, says "we don't look at those discussion forums", "we can't look at those to verify problems.." etc. But when we find something that seems to help a significant number of people like the relationship to bluetooth and wifi problems, it's not 1 day until they start suggesting it. Sure you don't pay attention to the forums.... sure you dont...

     

    *waves to apple support*

  • Garafraxa Calculating status...
    Currently Being Moderated
    Oct 7, 2012 10:22 AM (in response to kag49601)

    This describes my problems exactly. Identical setup, identical results.

    I'm on my 4th iPhone 5 and always have the same results.

    kag49601 wrote:

     

    Thanks for this!  I have an Apple AirPort Extreme - 5th gen.  I have tried everything including no security and still have wifi speed issues. I consistently get 300k down on an Internet service that pulls between 3-7mbps on all other devices.  Tried the Bluetooth thing, DNS, Auto-Proxy.  I usually get 2-3 full speed runs with the Speedtest app then my speeds return to 300k and stays there...

  • WiseJD Level 4 Level 4 (1,120 points)
    Currently Being Moderated
    Oct 7, 2012 10:36 AM (in response to Garafraxa)

    Something tells me you should not go get another iPhone.  However, perhaps you should turn off any and all other devices using your network and try the Speedtest again. If that doesn't do anything, can you reset the network on your iPhone and try once again.  One other thing that has increased speed is when you Re doing something network intensive from another device, like a iTunes Sync from an iPad.  All this just to see if anything changes.  If you haven't already, you could try setting the router complex back to factory settings.

  • kag49601 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 7, 2012 10:50 AM (in response to WiseJD)

    I just verified that doing a sync with another device (iPad) did not improve the speed with the iPhone 5. Only when I do a sync from the iphone5 or AirPlay to a ATV/Airport express is when I see normal Internet speeds.  I just played 10 hi-def videos on YouTube - sending them to my TV via AirPlay and all of them played with no buffering or hiccups!  This has been the best/most consistent speed I have seen from the 5 since recieving my first and now second unit...  I called Apple and let them know about my findings. I was told that they would let the engineers know.... Whatever that means... 

Actions

More Like This

  • Retrieving data ...

Bookmarked By (127)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.