Skip navigation

MMS fails on iPhone 5 with AT&T when APN configuration profile installed

3248 Views 9 Replies Latest reply: Apr 11, 2013 4:00 AM by claus.weymann RSS
onecount Calculating status...
Currently Being Moderated
Oct 6, 2012 8:40 PM

Installing a configuration profile containing APN information to the new AT&T iPhone 5 results in breaking the capability to send or receive MMS messages through the Messages app on the device. This is for MMS (Multimedia Messaging) and not iMessage (that works fine).

This happens regardless whether the device is on LTE mode or on 3G mode.

The configuration profile we are using has APN information and proxy settings for this APN as well (proxy host and port information). However, the problem happens even if the profile contains just APN without any proxy settings info.

This happens on iPhone 5 ONLY (commercially available through AT&T). This is important to note because iPhone 4S with iOS 6 DOES NOT HAVE THIS PROBLEM.

This problem happened last year too when iPhone4S was introduced. But it was fixed later.

iPhone 4S, iOS 5
  • diesel vdub Level 7 Level 7 (20,745 points)

    This in combination with your VVM issues confirms you have an APN setting issue.

  • diesel vdub Level 7 Level 7 (20,745 points)

    VVM and MMS both require access to the carriers cellular data network.  The proxy is most likely interferring.

     

    It is interesting that the issue does not exist on the 4S running iOS6.

     

    Unless there are unique settings on the 5 that do not exist on the 4S, there is no reason why the same settings should not work.

     

    Just to confirm, without this configuration profile installed, VVM and MMS both work, correct?

  • lcq072389 Calculating status...

    are you sure MMS data goes through your proxy? Had you capture packets on the pdp_ip0 interface?

  • claus.weymann Calculating status...

    I have a similar issue with an iPhone 4S running iOS 5.0.1 and reports from our client using other device (have to check with them again to find out which devices exactly with which iOS version). Both visual voicemail and MMS stop working as soon as you install an apn profile (with or without proxy does not matter, even tried setting the MMS proxy with out any luck)

    Provider tested is o2 in germany

    I would have liked to create a bug report, but the reporting system seems to be down.

    I hope to get some feedback from apple regarding this problem soon.

  • diesel vdub Level 7 Level 7 (20,745 points)

    This is a user to user technical support forum. If you want/need feedback from Apple then contact them.

  • claus.weymann Level 1 Level 1 (0 points)

    I did, filed a bug report using chrome, since it does not work with safari at the moment. I just wanted to let the op and other people know that we have a similar problem here and maybe encourage other people to post their experiences with different providers regarding MMS and APN-profiles.

    Btw. tested with:

    * iPhone 5 iOS 6.1 (10B143)  => does not work

    * iPhone 4S iOS 6.1 (10B143) => works

    * iPhone 4S iOS 5.0.1 => does not work

    * iPhone4 iOS 6.1.3(10B329) => works

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.