Skip navigation

TS2518: Aperture 3.5: Release notes

Learn about Aperture 3.5: Release notes

TS2518 Aperture 3.4.1 freezing after update - only on one user

529 Views 1 Reply Latest reply: Oct 7, 2012 10:46 AM by léonie RSS
jer. Calculating status...
Currently Being Moderated
Oct 7, 2012 9:51 AM

Since upgrading to Aperture 3.4.1 Apeture freezes everytime I open it up. The freezing on occurs on my main user. The library works fine in other user accounts and on my other Mac. Aperture also freezes when opening any library (even a new one) on my main user account. I have tried reinstalling (including deleteing Application Support/Aperture and plist files). am downloading through the AppStore. Have also tried repairing permissions through Disk Utility and Reseting ACL's for the user.   

 

Furthermore iPhoto freezes when launched from this user as well which leads me to believe this is a corrupt shared file between the two? any advice before I start systematically ruling out files in the library??

 

Thanks!

iMac, OS X Mountain Lion (10.8.2)
  • léonie Level 8 Level 8 (46,485 points)

    Where are your Aperture/iPhoto Libraries located? On an external drive or your system drive? If external: Is the drive locally connected, or a network volume? How is it formatted?

     

    Check the settings and preferences, that are shared by iPhoto and Aperture:

    • Your login items: Do you launch any third-party application/utilities on login? Or have preference panes installed to be used with image capture? Do you have any Aperture plugins, that may no longer be compatible?
    • The image capture preferences are shared between all photo apps: Try to remove them.
    • The iLifeAssetManagement folder in your library is shared by iPhoto and Aperture.

    To remove the image capture preferences:

     

    • If Aperture is running, quit Aperture,  and log off and on again.
    • Open your user library from the Finder's Go menu: Hit Command Shift G (⌘⇧G) and then type in: ~/Library/Preferences/  then hit return.
    • In the window that opens remove "com.apple.ImageCapture.plist"
    • and look into the subfolder "ByHost": if there are files named com.apple.ImageCapture  something .plist  remove them too. 

     

    then try again.

     

    If you are using PhotoStream, try to remove the iLifeAssetManagement folder from your User Library: (it is located in the Applications Support folder). This folder is also shared by Aperture and iPhoto in your User account.

     

    ~/Library/Application Support/iLifeAssetManagement/

     

    Removing this folder will remove the local copy of your PhotoStreams howver; so make a backup, if you want to save the images.

     

    Please report back with the results, if this does not help.

     

    Regards

    Léonie

    MacBook Pro, OS X Mountain Lion, 2.4 GHz I.Core i7, 16GB RAM, 500GB

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.