Skip navigation

TS3989: iCloud: My Photo Stream troubleshooting

Learn about iCloud: My Photo Stream troubleshooting

TS3989 new photos are not uploading to photostream

13237 Views 36 Replies Latest reply: Jun 7, 2013 9:10 AM by Robby Berman RSS
1 2 3 Previous Next
Bhags777 Calculating status...
Currently Being Moderated
Oct 7, 2012 12:03 PM

i have a iphone 4s, ipad 2 and a MacPro using iPhoto.  Yesterday my devices stopped uploading NEW pictures to PhotoStream.  I've tested it by taking pictures with each device and waiting to see if it shows up in photostream.  Nothing works.  Is still have the old photostream pics, but new pictures are NOT uploading to photostream.

iPhone 4S, iOS 6
  • randers4 Level 9 Level 9 (53,360 points)
    Currently Being Moderated
    Oct 7, 2012 12:12 PM (in response to Bhags777)

    Photos are only uploaded when your are connected to wifi, the camera app is closed, and you have at least 20% battery life remaining.  If that's not the issue, you may need to try turning photo stream off, then back on.  Be aware that photo stream only keeps photos for 30 days.  After that they are deleted, although they will remain on any device that has already received them.  If you turn photo stream off and then back on, photos older than 30 days will not be streamed back to your device.  If you have photos old than that in your photo stream album you'll need to save these to your camera roll first if you want to keep them on your device.

  • randers4 Level 9 Level 9 (53,360 points)

    I'm away at the moment but will get back to you in about an hour.

  • An Average User Calculating status...

    Since a couple of days I have exactly the same issue.

     

    I had not tried to add photos from my MacBook Air, but after reading from Bhags777 I did try and it works, exactly as for Bhags777.

     

    I have iphone 5, New iPad and MacBook Air.

     

    Frustrated too...

     

    Thank you Randers4 for your help

  • randers4 Level 9 Level 9 (53,360 points)

    Ok, back now.  At this point I suggest you try deleting the iCloud account from one of your devices and set it up again.  When you delete the account it only deletes it from the device, not from iCloud.  Your other devices will not be effected by this.  Deleting the account will also delete any data from the device that you may be syncing with iCloud such as contacts and calendars (but again, not from iCloud).  When you sign back into your account, this data will be synced back to your device.

     

    To do this, go to Settings>iCloud, scroll to the bottom and tap Delete Account.  Then set up the same account again with the same ID and turn your data syncing (contacts, etc.) back to On.  If prompted, choose Merge.  Then turn photo stream back on, take a photo and see if it appears on your other devices now.  If so, go through this same procedure with your other device.

     

    (I also just tested photo stream from my phone and it worked for me; and iCloud system status is not reporting any problems right now.)

  • randers4 Level 9 Level 9 (53,360 points)

    It doesn't show up immediately in the photo stream album on that device because the photo isn't being uploaded to photo stream.  The photos in the photo stream album are streamed back to your device from photo stream in iCloud;  if they were to appear in your photo stream album that indicates that they were successfully uploaded to photo stream and would also appear on any other device connected to your photo stream.

     

    Also, there are relatively few people reporting this issue after updating to iOS 6; if it were an iOS 6 problem there would be hundreds of people here with this problem. 

     

    Is your Mac connected to the internet using your wifi?  If it's using a wired connection, the next thing I would try is taking a photo on your phone while connected to a public wifi hotspot to see if this is related to your wireless network.  You'll know if it's successful if you see the photo appear in your photo stream album.

  • An Average User Level 1 Level 1 (0 points)

    Randers4:

     

    I tried too your suggestion and deleted, then re-signed in the account iCloud: same result as Bhags777.

     

    On iOS6: in my case, I updated last Tuesday and the issue did not start appearing till Thursday.

     

    On the wi-fi: your suggestion is worth trying for my case. I can say that the issue started when I came on Thursday to a different apartment, where I still am now. So, I cannot say that on a different wi-fi network (namely the one I was until Thursday) this would happen.

     

    I will have to try at a public wi-fi or wait till tomorrow when I will be back home.

     

    Thank you for your assistance.

  • randers4 Level 9 Level 9 (53,360 points)

    You're welcome.  If it turns out to be your wifi some things to try include:

     

    1. Power-cycling your router (unplug for 15 seconds and plug back in) and go to Settings>General>Reset>Reset Network Settings, the rejoin your wifi and try photo stream again;
    2. Disable any firewall you may be using in your wireless router;
    3. Change the wireless router Primary & Secondar DNS settings to 8.8.8.8 and 8.8.4.4 (these are Google's public DNS servers and are generally more reliable than your ISP's.
  • An Average User Level 1 Level 1 (0 points)

    UPDATE Randers4:

     

    I tried to "forget network" on the wi-fi where I am and activated the Personal Hotspot on my iPhone 5.

     

    Then I connected my iPad and my MacBook Air to my iPhone hotspot on the iPhone 5 instead of the "suspected" wi-fi network and bingo! On the iPad and on the MacBook the pictures I took with the iPad did appear (They are not appearing on the iPhone because I suspect they do not synch if not connected on a wi-fi, but the iPad and MacBook see it as a regular wi-fi so they do synch).

     

    So, I am optimistic that tomorrow, upon my retunr home, everything will be back to normal: the issue is probably the current wi-fi network at the house I am temporarely staying at.

     

    Thank you Randers4 and thank you Bhags77: I hope it will work out for you too.

  • randers4 Level 9 Level 9 (53,360 points)

    You're welcome.

  • An Average User Level 1 Level 1 (0 points)

    Extra piece of information:

     

    now I shut down the Personal Hotspot, bringing back the iPhone to the "suspected" wi-fi network and the photostream on the iPhone immediately showed the pics I took on the iPad (but not those I took on the iPhone, which are present in the Camera roll, but not on the Photostream). Those pics showed up on the Mac already earlier, thru the Personal Hotspot connection on the iPhone

     

    So it seems that this wi-fi network allows for very good download to the iOS6 devices but for some reasons does not allow the upload to the photostream of the new pics from the iOS6 devices.

     

    On the other hand, if the added pictures is on the Mac, then it is uploaded and immediately shows up on the iPad and iPhone.

     

    To make things even more complex, my girlfriend has iphone 4S and iPad 2 both on iOS6, and for her the photostream works perfect with this wi-fi network... really bizarre.

     

    I consider the issue closed: this network does not like me for some reason, I'll be back to my normal network tomorrow and things will be (hopefully) back to normal.

     

    Thank you again.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.