1 Reply Latest reply: Oct 7, 2012 8:36 PM by Niel
tgoneskiing Level 1 Level 1 (0 points)

I have version 10.5,8 and want to install a new hp photoshop 5520.  It states I need 10.6 or higher?   Can I download or do I need to buy snow leapard or mountain lion?


Mac OS X (10.5.8)