Skip navigation

Asked for Aperture serial number every single time

558 Views 4 Replies Latest reply: Oct 11, 2012 11:22 AM by Carlos F. RSS
hongkongais Calculating status...
Currently Being Moderated
Oct 7, 2012 7:38 PM

After re-installing Aperture on a new hard disk (the old one failed), I was asked for Aperture serial number every time I open the software.  How can I stop it? (iMac 2009, OSX Mountain Lion 10.8.2, Aperture 3.4.1)

Aperture 3, OS X Mountain Lion (10.8.2)
  • léonie Level 8 Level 8 (46,355 points)

    You may have a corrupted "ProAppSystemID" file or Aperture cannot write to the System Library.

     

    To stop Aperture asking for the serial number, first check, if you still have an old file "ProAppSystemID" in your System Library.

     

    • Quit Aperture.
    • Go to your MacintoshHD and open the folder "Library", then "Application Support", then "ProApps".
    • Remove the File "ProAppsSystemID" to the Desktop, if it exist and restart Aperture.
    • Reenter your serial number, hopefully for the last time.

     

    Sometimes Aperture writes this file to a temporary directory, when it cannot write to the Library. If the above does not work, look at the temporary directory /tmp

     

    Use the Finder's "Go" menu

     

         Go > Got to folder    and  enter /tmp into the textfield. If you see the file there, move it to its proper location.

     

    In this case you may want to repair the permissions on your system drive; you can do this using the "First Aid" tools in "Disk Utility" (located in Applications > Utilities)

     

    Regards

    Léonie

    MacBook Pro, OS X Mountain Lion, 2.4 GHz I.Core i7, 16GB RAM, 500GB
  • Carlos F. Calculating status...
    Currently Being Moderated
    Oct 11, 2012 8:34 AM (in response to léonie)

    I have the same issue. Followed your instructions, removed the ProAppSystem ID file to the Trash.

    However i did not find the /temp file. Repaired permissions also.

    What happens now is that once I enter the serial number, quit Aperture and open it again, this time it does make the request. But when I restart the computer the first time I open Aperture the request pops up.

    Thank you.

  • léonie Level 8 Level 8 (46,355 points)
    Currently Being Moderated
    Oct 11, 2012 8:41 AM (in response to Carlos F.)

    Carlos,

    have you tried to repair the permissions? Aperture needs to be able to write to your System Library for the prompting to stop.

     

    Léonie

  • Carlos F. Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 11, 2012 11:22 AM (in response to léonie)

    Yes, I repaired permissions and just did it again, just in case.

    But the prompting continues.

    Thank you.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.