8 Replies Latest reply: Oct 9, 2012 10:28 PM by fotoroeder
SuzanneT Level 1 Level 1 (0 points)

I have my Aperture Library on a 2TB External Seagate Drive, so that I can use it with both my iMac and MBP.  It's been running really slowly lately, so I ran Disk Utility on it to Verify and Repair, and just got the error message "Couldn't Unmount Disk".  Help, please!  I have backup vaults, but they are months old because this has been so slow and I just got lazy.  Ouch.

Sue

  • 1. Re: External Drive Problem...Error "Couldn't Unmount Disk"
    fotoroeder Level 1 Level 1 (15 points)

    Hi SuzanneT,

    do you still have access to your EXT HD?

    Then you could back up the vaults?

    Uwe

  • 2. Re: External Drive Problem...Error "Couldn't Unmount Disk"
    CorkyO2 Level 4 Level 4 (1,290 points)

    Did you try using Disk Utility from either the recovery partition (in Lion or Mountain Lion) or by booting from install DVD for previous versions?

     

    Make sure the external drive is connected and powered before launching Disk Utility.

     

    In case you are unfamiliar with procedure:

     

    Restart machine and press 'Option' key immediately after hearing 'Gong' sound (usually heard at same time grey screen shows). Select the Recovery drive or the DVD and use Disk Utility from there.

     

    Lion and Mountain Lion - Disk Utility shows in the displayed option window once booted.

    Snow Leopard and earlier - use the Utilities menu to access Disk Utility

     

    Hope that helps.

  • 3. Re: External Drive Problem...Error "Couldn't Unmount Disk"
    SuzanneT Level 1 Level 1 (0 points)

    Corky, I did as you said and restarted with the option key held down after the gong, but I never got past the grey screen.  I sat there for about 5 minutes with a grey screen and nothing happened.

     

    Uwe, I was finally able to access the library on the external drive (after it ran the repair sequence).  I thought maybe I could update a vault from there, but I have had just a spinning beach ball for about 20 minutes just trying to access the vault portion of the screen.  So, it looks like I have Aperture open, but I'm not able to do anything with it.

     

    Sue

  • 4. Re: External Drive Problem...Error "Couldn't Unmount Disk"
    SuzanneT Level 1 Level 1 (0 points)

    When I look at the contents of the external drive, I am able to see the Aperture library.  Would it work if I just copied that to another external?

     

    Sue

  • 5. Re: External Drive Problem...Error "Couldn't Unmount Disk"
    fotoroeder Level 1 Level 1 (15 points)

    Hi Sue,

     

    I would of course try this. Do you have all pictures organized by Aperture or referenced to from some Ext HDs?

    If referenced, I would think of trying to organize the Library new.

     

    The workaround suggestion: Copy the Aperture Library to one of your Macs

    and run it from there (as you already asked). If it works fine, take another Ext.HD (maybe you are asked

    by Aperture to repair because of any Inconsistencies, this takes most of the times quite long, but maybe helps),

    and take care as before.

     

    I wouldn't recommend Seagate HD's, but as always that's easy to tell afterwards.

    It seems like the EXT HD has a problem and hopefully not Aperture.

     

    This all is the reason for me, why I changed all pictures into referenced pictures, do my work, give names with Aperture, but keep the order in my hand. Back Up is of course as well in my responsability.

    I've had always a bad feeling about letting something do the most important work, without knowing and take

    care.

     

    Uwe

  • 6. Re: External Drive Problem...Error "Couldn't Unmount Disk"
    CorkyO2 Level 4 Level 4 (1,290 points)

    Sue,

     

    Sorry it took so long to post back.

     

    If you still want to try to repair disk permissions and verify external disk, you can try to shut down the computer completely > disconnect the external HD > try booting to either the recovery partition or install DVD mentioned earlier.

     

    If you successfully get to the boot options screen, connect the external HD and then load Disk Utility.

     

    Hopefully, Disk Utility will be able to see and mount the external HD allowing you to repair permissions and repair / verify disk.

     

    Message was edited by: CorkyO2 to remove 'wait' from third sentence.

  • 7. Re: External Drive Problem...Error "Couldn't Unmount Disk"
    SuzanneT Level 1 Level 1 (0 points)

    Neither of my internal HD's were large enough, so I went out and bought an external drive and copied the Aperture Library to that, crossing my fingers.  I took several hours, but copied successfully.  I then opened new copied library with Command, Option Shift held down, and rebuilt.  It took all night to generate previews, but all was good this morning.  Success!  I backed up a vault before I did anything, and then plugged the HD into my desktop which is backed up with Backblaze.  Thank you all for your suggestions.  The Seagate drive is going in the trash.

     

    Sue

  • 8. Re: External Drive Problem...Error "Couldn't Unmount Disk"
    fotoroeder Level 1 Level 1 (15 points)

    Hi SuzanneT,

     

    well the most important issue were your originals, right.

    The previews could have been done anytime.

    I don't know Backblaze as a Bachup software, but more important is, that you have a Backup on a really

    Ext HD, which is not all the time connected to your system.

    Because even RAID Levels (...) are not at all a Backup as you might know.

     

    For safety reason I would recommend to delete the Seagate and overwrite it at least one time with Zeros.

    (In German this is done with "Festplattendienstprogramm", I'm not sure about the right AE expression)

    In case the Seagate doesn't mount at all, skip this of course. And of course I do not know how critical

    you are with your pictures and if anybody could do something with it.

     

    So take care and nice that I could have helped.

     

    Uwe