Skip navigation

27" led cinema display goes black

19639 Views 46 Replies Latest reply: Apr 22, 2014 10:41 AM by Ssamnick1 RSS
1 2 3 4 Previous Next
Gregory247 Calculating status...
Currently Being Moderated
Aug 31, 2012 3:03 PM

My Apple 27" LED Cinema display has begun to go black for no apparent reason. I am running Mac OS X 10.6.8 on a Mac Pro with a6-Core Intel Xeon processor with 8 MB of memory. The system and dispaly are about a year old or less. I have had no problems with this system until today.  the display has gone black several times now. I shut off the computer and rebooted and it comes on again and then after a period of time goes black again (whether I am doing something or not on the computer).  I have zapped the PRAM and repaired permissions.  It does not seem to affect whatever is wrong with the display. Has anyone else experienced this? Does anyone have a solution other than sending the display in to Apple for repair?  Thanks.

apple 27" led cinema display, Mac OS X (10.6.8)
  • Henning Eckhardt Calculating status...
    Currently Being Moderated
    Sep 2, 2012 6:23 AM (in response to Gregory247)

    Same over here. It began a few days ago and seems to happen only when the displays has just been turned on. As someone else wrote (https://discussions.apple.com/message/19284042#19284042) disconnecting from power and reconnecting often helps - but this is not a real solution. The display is about 18 months old.

  • Henning Eckhardt Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 4, 2012 9:11 AM (in response to Gregory247)

    Hello Gregory, I tried that too but it does not work for me. The display still turns black. About 10-15 after turning on, if I can get it to work again by unplugging & replugging the power cord it works fine until the end of the day. But initially it just says good bye as before.

  • Henning Eckhardt Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 6, 2012 11:52 AM (in response to Gregory247)

    The only other "solution" I found so far seems to be not turning the Mac Pro off but putting it into sleep mode. If the display is turned on during waking up the Mac it doesn't go black.

  • bdemuth Calculating status...
    Currently Being Moderated
    Sep 6, 2012 12:47 PM (in response to Gregory247)

    I replied to another post as well about this.  I am having the same/similar issue and it seems to be something with power in the monitor....

     

    I have a mid-2009 Mac book pro 15" plugged into a 27" cinema display.  I notice the same kind of issue. Unplugging it and then plugging it back in usually solves the issue, but often only for another 15 minutes or so. Now the issue has become worse.  When the screen "blacks out" the led indicator on the magsafe power cord to the laptop also goes out.  It seems to me that this is some kind of internal power regulation issue in the display.  This monitor was replaced for the same issue about 14 months ago at an Apple store with no explation of the issue and ofcourse... now the replacement is not under warranty any longer... any thoughts?

  • Henning Eckhardt Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 25, 2012 10:33 AM (in response to Henning Eckhardt)

    Update: Today the workaround of putting the Mac into sleep mode only also stopped working, more than that: when the screen went black the devices connected to the monitor via USB lost their connection - which has not happened before. This seems to be the end of the monitor. After only 18 months.

  • Nico Tru Calculating status...
    Currently Being Moderated
    Oct 8, 2012 10:20 AM (in response to Henning Eckhardt)

    Have you found a solution yet ? Because I have had the same problem for a month or so and I haven't found anything useful yet... It's quite depressing knowing that it's really expensive ...
    The only thing that has made it work is unplugging/plugging it constantly until the screen finally turns on.

  • bdemuth Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 8, 2012 10:30 AM (in response to Nico Tru)

    Sounds like the same issue I have been having. Since Apple refuses to help me (without paying full cost) with a screen that is only a year old now (since they replaced it last for the SAME problem), I dove into the issue myself.   All troubleshooting points to the internal power supply. The part number is 661-5543.  I've ordered one to install myself. 

  • Nico Tru Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 8, 2012 10:39 AM (in response to bdemuth)

    So Apple doesn't offer a solution to the problem ?
    The only thing you found to fix the problem is to order a spare part that might fix ?
    Do you know how to replace the defect part and replace it ?

  • FrancoiseAgnes Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 14, 2012 2:23 AM (in response to Gregory247)

    Hi!

    I seem to have the same problem as well. My 27" Apple cinema display is about 18 month old. I use it with my MacBook Pro 2009. A month ago, the display went black and the magsafe plug stopped working as well. I unplugged it, replugged it, looked at it in dispair... Nothing worked. After 20mn, it just started to work again, by itself, mysteriously. Last night, the same thing happened. But it never started to work again. I am at a loss. I do have the Apple protection plan. But about 15 month ago, I moved to France. So now, I am really not sure how and whom to contact. Things are not so easy here in France and nobody is really helpful. I do live in the country so it is even harder to find out about an Apple store. I haven't seen one yet since I am here.

    How hard is it to replace the defective part if, indeed, it is the internal power supply?

    Thanks for helping me out!!

  • TonyAugust Calculating status...
    Currently Being Moderated
    Oct 16, 2012 1:41 PM (in response to bdemuth)

    Have you had any luck with the internal power supply? I have the same problem... For $1000 Apple could built a display that lasts longer then 12 months....

  • Nico Tru Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 16, 2012 1:54 PM (in response to TonyAugust)

    I went to a shop in order to get it fixed and guess what ?!
    To get it fixed, it will cost me about 900€ !!!!! Apparently, the screen is broken and it's a very expensive part so there you are ...
    I hope you can fix it yourself because otherwise you'll have to pay a lot to get it fixed ...

  • disappointed1000 Calculating status...
    Currently Being Moderated
    Oct 17, 2012 12:24 PM (in response to Gregory247)

    Exactly the same thing is happening to me with a 27" cinema display and an early 2011 MacBook Pro computer. After I did my own troubleshooting, reset the PRAM, made sure sure I had the latest pdate, etc., etc., I phoned Apple support and was prepared to pay the service call fee. When I explained the problem to the tech and told him what I had already done, he said there was nothing else he could suggest, except to recommend I go to a service centre, and he did not charge me for the call, which was decent enough. So I went to an Apple authorized service centre with my display and they found nothing wrong. In fact, it even worked beautifully there. They then asked me to bring my computer in as well, and still found nothing wrong. This is really frustrating and very disappointing. My display is only 15 months old. I don't know what to do.

1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.