7 Replies Latest reply: Oct 16, 2012 5:17 PM by PAZipster
PAZipster Level 1 Level 1 (0 points)

Not exactly sure what happened, and I don't know for sure it was the upgrade to Mountain Lion, but here's the background:

 

  • I have 5 iWeb sites uploaded to my ISP (1and1.com) and they currently work fine.
  • Now, on my computer, I had 5 websites on one iWeb "Domain.sites2", but it was taking too long to publish one site change without going through a publish of all the 5 sites.
  • So I made 5 folders and copied the iWeb main "Domain.sites2" into each folder
  • Then I deleted all but one of the sites in each folder, leaving me 5 separate folders with one site in each folder.
  • This allowed me to update, publish, and work on each individually.
  • After upgrading to Mountain Lion, I opened my external HD (which has my Time Machine Backup) and deleted the old backups.
  • Then I did a complete new Time Machine Backup.
  • Now each of the "Domain.sites2" in each of the separate folders will open only the main website I created, the "Domain.sites2" still exists in the folders but they all open only the first site I created.
  • In fact, the "~/Library/Application Support/iWeb" folder is gone as well?
  • Note:  I do have a master website folder with each of the 5 websites in the separate folders, and the html & files are still intact for each website
  • I could rebuild the websites, however, where did the other "Domain.sites2" go, and is there any other way to get them back.

 

Thank you so much in advance if you have an idea.

 

Craig


iMac, OS X Mountain Lion (10.8.2), 3.06 Ghz - 4 GB Ram
  • 1. Re: Upgrade to Mountain Lion - Lost Some iWeb Sites
    Roddy Level 6 Level 6 (17,265 points)

    See this page for how to get to the library folder and how to open Domain files when using Lion/Mountain Lion...

     

    http://www.iwebformusicians.com/iWeb/mountain-lion.html

  • 2. Re: Upgrade to Mountain Lion - Lost Some iWeb Sites
    PAZipster Level 1 Level 1 (0 points)

    Roddy,

    Thanks for your input, I now realize you cannot have more than one website at a time on Mountain Lion.  So, I decided to make several folders on my 500GB External and move all the Library "Domain.Sites2" to one folder, and all the separate folders that have my html & files into another folder.

    • One "Websites from Library"
    • Two "Website Master Folder"

    Then when I want to work on one of the websites I do the following:

    • Open the 500GB External Drive
    • Go to and open the hidden iWeb Folder in the Library
    • Make sure there are no "Domain.Sites2" in the folder
    • Drag and Drop the "Domain.Sites2" I want to work on into the iWeb Library folder from the external drive
    • Now open the iWeb application on the iMac and it will bring up the site.
    • When I'm done, I save the site to the "Websites Master Folder" on the external
    • Delete the "Domain.Sites2" from the iWeb Library folder
    • Upload the site to my Hosting Site

    You got me going in the correct direction, so I'll give you the credit.

     

    Thanks,

     

    Craig

  • 3. Re: Upgrade to Mountain Lion - Lost Some iWeb Sites
    Roddy Level 6 Level 6 (17,265 points)

    The Domain.sites2 files don't need to be in the default location. I keep mine in separate folders in an "iWeb" folder in the Home folder.

     

    Others keep them in the same folder and rename them ... web-site-name.sites2

  • 4. Re: Upgrade to Mountain Lion - Lost Some iWeb Sites
    Old Toad Level 10 Level 10 (115,715 points)

    Thanks for your input, I now realize you cannot have more than one website at a time on Mountain Lion.

     

    That's not correct.  You can have only one domain file titled Domain.sites2.  But you can name each file after creating it to the site name and have as many as you need.

    001.jpg

    Then use Roddy's DomainCracker to selelect the website you want to use or change to.

     

    OT

  • 5. Re: Upgrade to Mountain Lion - Lost Some iWeb Sites
    PAZipster Level 1 Level 1 (0 points)

    Roddy,

     

    I'm so sorry to bother you again.

     

    Your suggestion sound good but I'm still having a problem.  Here's what I did:

    -  Created a folder, lets call it "Websites", and placed it in my Home Folder

    -  Then created four folders inside the Website folder named with the website names

    -  Then I put the "Domain.Sites2" for each site in the respective folders, and renamed them "SiteName.Sites2".

    -  Then when I opened iWeb from the applications folder, and browsed to one of the sites, it did come up fine

    -  However, everytime I open any of the other Domain.Sites only the first one I browsed for comes up

    -  Even when I open iWeb from the Applications Folder only the first site I browsed to comes up

     

    I downloaded "DomainCracker", but it won't open, the message says it is from an unknown developer and won't open?

     

    Respectfully,

     

    Craig

  • 6. Re: Upgrade to Mountain Lion - Lost Some iWeb Sites
    Roddy Level 6 Level 6 (17,265 points)

    Go into System Prefs and do this...

     

    1.jpg

  • 7. Re: Upgrade to Mountain Lion - Lost Some iWeb Sites
    PAZipster Level 1 Level 1 (0 points)

    Roddy,

    You da Man...

    Sorry I bothered you so much. I got home and went in then changed the Security setting and everything is fine now. I was able to open each website with DomainCracker and it looks like I'm set.

    Come on over and I'll buy you a beer!!!!

    Thanks so much...

    Craig