Skip navigation

iBook G4 - Black screen in open firmware

864 Views 2 Replies Latest reply: Oct 18, 2012 11:28 PM by Dougal222 RSS
Dougal222 Level 1 Level 1 (0 points)
Currently Being Moderated
Oct 9, 2012 1:57 AM

Hi, i have a strange problem with my iBook G4.

 

When switched on it chimes and starts loading but the screen is completely black (not no backlight but completely black). In otherwords it does not show the grey screen or apple logo.

 

Once the OS boots the blue screen comes up and everything works perfectly.

 

So the problem is that anything before the actual OS loads is black. That means the grey screen with apple logo, open firmware and the drive selection screen (if you boot holding ALT/OPT) are all black.

 

I have tried resetting the PMU, Pram and blindly (with black screen) in open firmware did reset-nram and reset-all but nothing changed.

 

It is a late 2004 iBook G4 1.2Ghz with 512MB ram, 30GB HD and OSX Leopard 10.5.8.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.