Skip navigation

Why does UIBarButtonItem in navigation bar appears disabled?

894 Views 9 Replies Latest reply: Oct 9, 2012 4:06 AM by mapg RSS
mapg Calculating status...
Currently Being Moderated
Oct 4, 2012 10:48 AM

I have a UITabBarController with 4 UINavigationControllers in it. I successfully added a right UIBarButtonItem in the navigation bar of one of the controllers but it appears disabled and I can't click it. I've already tried to set enable property to true but nothing works...


Did someone already had the same problem? I'm struggling with this for hours...


Here's the code:


self.navigationItem.rightBarButtonItem = [[UIBarButtonItem alloc] initWithBarButtonSystemItem:UIBarButtonSystemItemAction target:self action:@selector(socialShare)];


And a screenshot:




I'll be waiting for an answer.


Thanks for your help!

iOS 4.3


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.