Skip navigation

MBP Retina - need to reset SMC after sleep

3971 Views 11 Replies Latest reply: Mar 11, 2013 8:23 PM by marciotrindade RSS
l85m Calculating status...
Currently Being Moderated
Sep 29, 2012 3:02 PM

Ever since the EFI update my MBPr has slowed down considerably after waking from sleep and stays that way until I do an SMC reset.  Games like Diablo 3 become unplayable and generally things are just slow and stuttery. 

 

Hope Apple fixes this fast - the SMC/Firmware updates they released have not fixed the issue.

MacBook Pro (Retina, Mid 2012), OS X Mountain Lion (10.8.2)
  • Baby Boomer (USofA) Level 9 Level 9 (55,540 points)
    Currently Being Moderated
    Sep 29, 2012 3:05 PM (in response to l85m)

    l85m wrote:

     

    Hope Apple fixes this fast - the SMC/Firmware updates they released have not fixed the issue.

    Did you report this to the Feedback website?  If you are still under warranty, have you called Apple tech support?  If not, why not?

     

    These are user to user forums.  Apple does not visit this site nor respond.

    MacBook Pro, Mac OS X (10.6.8), Original MBP (2/2008)
  • buttmonki Level 1 Level 1 (15 points)

    I just wanted to say, I have the exact same problem.  Would be useful to know if everyone else has it or if it is a faulty machine.

  • teggo Calculating status...
    Currently Being Moderated
    Oct 9, 2012 11:52 AM (in response to l85m)

    I did the below to solve my issues, so if you're still having trouble with performance after your macbook pro have been to sleep a couple of times, this may help:

     

    So looks like I may have stumbled on something that works, this is only for advanced users though and I take no responsibility for any issues arising from following the below steps.

     

    Nvidia released new MacOS 10.8.2 drivers, but you need to change the .dist file before they will install. Generally nvidia drivers work with all their GPUs, but they only release drivers for GPUs they actually specifically tested, anyways.

     

    First thing first, check that you are on MacOS 10.8.2 (Mountain Lion), installing these drivers on any other version of MacOS will break your system and you'll be unable to boot, you've been warned!

     

    1) Install the latest Nvidia CUDA drivers found here, no need to change anything these install without having to modify anything

    Link: http://www.nvidia.com/object/cuda-mac-driver.html

     

    2) Install the latest Nvidia MacOS drivers, these does not support MacBook pro retina by default so you'll have to modify the package.

    Link: http://www.nvidia.com/object/macosx-304.00.05f02-driver.html

     

    3) After you download open the Retail-304.00.05f02-macosx file and shortly after a new window should open called NVIDIA Drivers. Inside is an icon looking like an open box and the filename is 304.00.05f02 Web Release.

     

    4) Drag this box to your desktop

     

    5) Right click the file on your desktop and select Show Package Content

     

    6) Expand the Content folder and you'll see a file called Distribution.dist

     

    7) Right-click and select open with, then Other...

     

    8) Scroll down until you find TextEdit, double-click TextEdit

     

    9) Locate this line: var found_hardware = 0;

     

    10) change 0 to 1 so the line reads: var found_hardware = 1;

     

    11) Close Textedit

     

    12) Close Finder

     

    13) Double click the 304.00.05f02 Web Release file that you copied to your desktop

     

    14) Let it install, when it asks you to reboot, click reboot

     

    15) Hope it works!

     

    So far it's been working for me, but I only tested for a few hours, so no guarantees this fix is permanent, but for me it was worth a shot at least!

  • Zaepo Calculating status...
    Currently Being Moderated
    Oct 11, 2012 11:22 PM (in response to l85m)

    Jep i have the exact same problem. But i cant say its after sleep mode because sometimes it works for one week or so until the graphics are slowed down. I think its a random caused problem. I hope Apple will fix that, its annoying.

  • CaymanT Calculating status...
    Currently Being Moderated
    Nov 18, 2012 3:51 PM (in response to teggo)

    I had the same problem, so I tried this technique. The 1st step (Nvidia CUDA drivers) went fine. But after the 2nd step (Nvidia MacOS drivers), my computer wouldn't boot! Yes, I am running OS 10.8.2 on a Retina MBP.

     

    It's a good thing I took notes on how to run the Nvidia utility to revert to my old video drivers. My computer works fine again after the uninstall.

     

    The funny thing, though, is that the problem hasn't happened again since. Maybe it's the CUDA drivers that did the trick?

  • ikir Calculating status...
    Currently Being Moderated
    Feb 7, 2013 11:28 PM (in response to l85m)

    Same problems here, i need to reset SMC for taking back 3D performance!

     

    I hope APple fix it fast.... we must use feedback function all.

  • BenTristem Calculating status...
    Currently Being Moderated
    Mar 1, 2013 9:44 AM (in response to l85m)

    I have the same issue since a recent update. It's particularly bad in Windows 7 through bootcamp, where the CPU throttles back in gameplay after just a few seconds. The game(s) start at great framerate (e.g. 60 FPS) then rapidly slow to 15 or less. The GPU is not working hard, and the CPU indicates as throttled right back.

     

    Reading around on the web this seems to be "thermal throttling" issues, and I can't seem to stop it happening. Very annoying as it's crippled the performance of my machine.

     

    My current versions are below for reference, any idea when a fix will be released?

     

    Boot ROM Version:          MBP101.00EE.B02

    SMC Version (system):          2.3f32

  • grocklin Calculating status...
    Currently Being Moderated
    Mar 1, 2013 10:57 AM (in response to BenTristem)

    Is this actually the same problem, Ben?  Does an SMC reset fix the problem?  Or do you actually have a heating problem?

  • buttmonki Level 1 Level 1 (15 points)
    Currently Being Moderated
    Mar 1, 2013 12:51 PM (in response to grocklin)

    I am on my fourth MBPr.

     

    The first just locked up and I couldn't set up iCloud without it freezing - even after a reinstall - only had it for a day.

     

    The second and third both had the SMC reset problem (the second one also had a lot of dead pixels and made a strange grinding noise and the third one was also about 4-5mm out where the casing lined up with the base).

     

    So far (it's been about two months) the fourth one has not needed SMC resets (although the casing is about 1-2mm out where the casing lines up with the base).

     

    So I can only assume from my personal experience this is not, as I had originally thought, a fault accross the line but is in fact a fault found in a number of machines but not others.  Unless Apple brought out a fix between my exchange of my third and fourth machine.

     

    I can only suggest repeatadly asking for an exchange on machines until you get one that works or Apple realise how much money it's costing them and produce a fix for the machines that are affected.

  • marciotrindade Calculating status...
    Currently Being Moderated
    Mar 11, 2013 8:23 PM (in response to l85m)

    The same here with my MBP-retina.

     

    Please Apple fix it ASAP.

     

    tks,

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.