7 Replies Latest reply: Dec 6, 2012 12:13 PM by egocentrictheory
Jahad Suboh Level 1 Level 1 (0 points)



Has anyone got the Wireless Enterprise WIFI to work? Mainly, I am trying to get PEAP working on the AppleTV (3). I have a Windows 2008r2 NPS server setup for RADIUS. My iPhones, and iPads connect manually or by Apple Configurator Configuration file, however the AppleTV does not. I've used the same configurator file, created a new one with the same results. Windows Server Logs states that authenication fails. Any ideas?




Jahad Suboh

  • 1. Re: Apple TV latest update and 802.1x (PEAP)
    Jahad Suboh Level 1 Level 1 (0 points)



    I got an email from a source that told me to wait for the Apple Configurator Update. There should be a fix/update for this feature.

  • 2. Re: Apple TV latest update and 802.1x (PEAP)
    jpoblocki Level 1 Level 1 (0 points)

    I'm having the same problem. Did your source give you a time frame for the update?

  • 3. Re: Apple TV latest update and 802.1x (PEAP)
    Jahad Suboh Level 1 Level 1 (0 points)



    No time frame, he just told me it would be very soon.

  • 4. Re: Apple TV latest update and 802.1x (PEAP)
    Jahad Suboh Level 1 Level 1 (0 points)



    Apple Configurator 1.1.2 was released today. I tried a new profile and could not get it to work; at least initially. From my testing so far, what is required is the date and time needs to be current. I plugged in an ethernet cable and restarted the device, after it finished starting, I had the familiar desktop. I then removed the ethernet cable and the WIFI profile I setup took over and remained connected or I had t select it (during testing, i tried different scenarios). Restarting the device still worked for me, however if I unpluged the apple tv, it could not connect anymore after powering it back up until i repeated the steps above. I'll update this post when I get more information.

  • 5. Re: Apple TV latest update and 802.1x (PEAP)
    Lace666 Level 1 Level 1 (0 points)



    you are my hero! That´s in fact the problem! I have had numerous hours searching for a radius problem...


    To successfully connect to a 802.1x WLAN the AppleTV must have the date and time correctly setup - which is impossible, because it tries to set it via WLAN... :-/


    So I can confirm, the only working solution is to start the apple tv with ethernet and than after booting switch to WiFi.

  • 6. Re: Apple TV latest update and 802.1x (PEAP)
    dmccaffery Level 1 Level 1 (0 points)

    If you have an iPhone or iPad with a tethering plan, you can use the personal hotspot feature to connect to wifi long enough for the time to be updated then switch back to the 802.11x network and it seems to work okay.


    That being said, Apple needs to provide a way to set the time manually in some way as the certificate revocation check fails if the date/time is before the issue date of the certificate or after the expiration date, which causes the following error in the logs on the Apple TV:


    eapolclient <Notice>: peap_verify_server: server certificate not trusted, status 3 0


    I have no idea how Apple would have missed this unless they only ever tested the 802.11X wireless profiles when also connected to an ethernet port and it never occurred to them.  Who knows? :-/



  • 7. Re: Apple TV latest update and 802.1x (PEAP)
    egocentrictheory Level 1 Level 1 (0 points)

    I have created a profile with my wireless network, account, and pw. I applied it to my AppleTV and then removed the ethernet cable. The network shows up, but it does not have a router address of a DNS. Have I missed something?