7 Replies Latest reply: Oct 10, 2012 1:32 PM by Ralph Johns (UK)
maaaaurice Level 1 Level 1 (0 points)

My iChat won't accept incoming video calls or file transfers. I am able to send outgoing* video calls, but not file transfers.

Please help!!!!!


MacBook Pro, Mac OS X (10.7.2)
  • 1. Re: Not accepting incoming video calls/file transfers?
    Ralph Johns (UK) Level 9 Level 9 (67,490 points)

    Hi,

     

    The Mac Firewall only stops incoming stuff. (If On)

    This can depend on whether you "Called out" as it were.

     

    The router is likely to work the same way.

    Check the routers is allowing the ports for A/V chats.

     

    iChat 5 or earlier log in to AIM on port 5190 using the TCP Protocol.

    File Sharing is on Port 5190 on the UDP Protocol.

     

    Some routers don't like this dual use of the port.

    Zyxels are particularly bad in this respect as it goes on to effect A/V chats.

     

    Change the AIM Login  port to 443 (you have to Log out first)

     

     


    9:58 PM      Friday; September 28, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • 2. Re: Not accepting incoming video calls/file transfers?
    maaaaurice Level 1 Level 1 (0 points)

    Hello.

     

    My firewall is on, but is set to Off for iChat. Does that affect it in any way?

  • 3. Re: Not accepting incoming video calls/file transfers?
    Ralph Johns (UK) Level 9 Level 9 (67,490 points)

    HI,

     

    If you have a Lion Computer then the Firewall can be Off or On

     

    If On then apps needs to be Allowed or Not.

     

    If iChat is marked as Not Allowing incoming connections in the list of Apps that are allowed then it will block any incoming connections.

     

    This could be Incoming text invites but is more likely to be incoming A/V invites as this is on a different port to Text chats.

    Also Screen Sharing Invites.

     

    iChat 6 logs in to AIM on port 443.

    Historically it used to use port 5190 on the TCP Protocol whereas File Transfers were on the UDP Protocol

    The Firewall will treat this almost like another port being used.

     

    Currently Messages in Mountain Lion uses port 5190 on TCP for AIM File Transfers.

    I would expect iChat 6 to do the same.

    This would be a port change compared to the Login that the App did at launch.

     

     

     

     


    7:42 PM      Sunday; September 30, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • 4. Re: Not accepting incoming video calls/file transfers?
    maaaaurice Level 1 Level 1 (0 points)

    My Firewall is on, and my iChat is set to allow. But everytime I open iChat, the box where it "Allow iChat.app to accept incoming network connections" pops up. And when I click Allow, it asks for the admin password. I put it, but when I quit the app and reopen, the same box pops up.

     

    How do I stop this?

  • 5. Re: Not accepting incoming video calls/file transfers?
    Ralph Johns (UK) Level 9 Level 9 (67,490 points)

    HI,

     

    Try  turning the firewall Off.

     

    Will iChat launch then ?

    If this works it would appear you have Read and Write permissions to the place that holds the Firewall Info.

     


    If you turn the Firewall On again does it allow iChat ?

    If Not remove iChat from the List and then shut down the computer and re-add iChat after starting the computer again.

     

    As there is not a simple com.apple.firewall.plist we will have to look a little deeper if the first suggesting does not work. (i.e you get the same message and pop up with the Firewall Off.)

     

     


    7:34 PM      Tuesday; October 9, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • 6. Re: Not accepting incoming video calls/file transfers?
    maaaaurice Level 1 Level 1 (0 points)

    Hello

     

    My firewall is now Off and iChat launches without the popup box.

     

    But I would like to have my firewall on, without iChat having to ask permission to accept incoming connections everytime I reopen the app.

     

    Is there any way I could do this?

  • 7. Re: Not accepting incoming video calls/file transfers?
    Ralph Johns (UK) Level 9 Level 9 (67,490 points)

    Hi,

     

    The fact that the Firewall operates in  a changed state when you change the state  means you are able to Write to the .plist that is involved (the file that stores the Preferences)

     

    The thing now would be to try turning the Firewall On again

    First make sure iChat is deleted from the List then Re-add it.

     

    We may have to check the Keychain is allowing the System Preference Access to the Password.

     

     

     


    9:31 PM      Wednesday; October 10, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously