Skip navigation

Problems recording with MIDI in Garageband

576 Views 2 Replies Latest reply: Oct 10, 2012 6:23 AM by blake89 RSS
blake89 Calculating status...
Currently Being Moderated
Oct 9, 2012 3:55 PM

I have a Yamaha DTXplorer electronic drumset and I'm using Garageband '09 with Mac OSX 10.5.8.

I connected my drumset to the computer using an M-Audio Midisport UNO ("plug-and-play" midi to usb). I plug in the "to midi out" to my drumset. When it's connected, the UNO "midi in" light is green and the "usb" light pulses.

 

Garageband doesn't recognize that there's a midi attached (under preferences it says "0 MIDI inputs detected"), but I can see the UNO in my "Audio MIDI setup" utility, so I know the computer is aware that the device is plugged in. What's more strange is that when I first plugged everything in, everything worked ok. The drumset would trigger notes in GB. That only lasted for about two days though, and now it won't work at all. I really don't think there's an issue with the cord itself though.

 

I'm not sure if I need a driver. I downloaded the 10.5.8 one from the M-Audio site, but nothing is working. I'm getting extremely frustrated that GB won't recognize the midi. I'm not great with computers and I'm pretty new to all this, so I'd really appreciate any help I can get...

 

Thanks in advance for any input on this. 

GarageBand '09, Mac OS X (10.5.8)
  • hansard5 Calculating status...
    Currently Being Moderated
    Oct 10, 2012 3:50 AM (in response to blake89)

    Does your drum machine have a USB port? If so, you could go straight in via USB, not needing the MIDI adapter. The Mac would almost certainly recognise the drum machine, maybe needing a driver download. This happened with my Roland A300 Pro. I can use MIDI connections, but it's far more convenient and just as good to go USB. But this is just straight off the top of the head--you'd have worked out such a basic troubleshoot by now.  Try a new driver from the Yamaha site, if available. Try a restart of the Mac with the gear plugged in (it has been known to work). Try a different cable, just in case. Try a different USB port on the Mac. These tend to be generic fixes, and success varies wildly. Finally, you're sure you're going MIDI OUT of the drum unit, right?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.