Skip navigation

Mountain lion wifi problems

124128 Views 371 Replies Latest reply: Mar 1, 2014 10:21 PM by lfcitz RSS Branched to a new discussion.
  • lesdmd Calculating status...
    Currently Being Moderated
    Oct 10, 2012 8:06 AM (in response to henrijacobs)

    I am one of the fortunate? ones who loses wi-fi only when I allow the computer to sleep (late 2009 iMac).  I can re-connect by opening network preferences>assist me>diagnostics>select location . . . I mention this not as a fix,  but perhaps it will save a few people a few steps in re-establishing connection.  I have tried every fix posted with no better success, including reinstalling Mountain Lion.  The net result has been that instead of intermittantly losing connection when the machine sleeps, it now happens every time.

     

    To my knowledge, Apple has not even acknowledged that there is a problem, other than indirectly on these support communities.  When I went into the local apple store and spoke with one of the "geniuses" I was met with a blank stare.  OS upgrades have made no difference. 

     

    The mystique as well as the reputation of Apple has already been severely strained as a result of their "head stuck in the sand" approach to this issue.  I am a relatively new convert to Apple, if 3 years can be considered recent.  PC and microsoft is not looking so bad anymore, and a lot less expensive.

     

    I have had an iPad on the top of my wish list for a while but this OS problem is causing me to reconsider.  Maybe Android is not so much a compromise?

  • John Mul Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 10, 2012 8:15 AM (in response to lesdmd)

    Lesdmd, the sleep function is designed for the mac to sleep and reconnect with wifi, etc successfully after 24-36 hours between activations. If you leave it on past that time, then it shuts down the protocol to connect automatically with wifi/etc and you will need to do it manually. I would reccomend though that you shut it down completely if you are not using your mac for 2-3 days plus with a normal start when you get back into it. Sleep is a very short term convenience for the regular user which I find great, the normal shut down which is done in shorter time then any PC I've worked on is for longer term storage of the machine. 

     

    Hope this helps

    Rgds,

    John

  • roxan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 10, 2012 10:43 AM (in response to lesdmd)

    On my case, the biggest improvement was reached but reconfiguring my rout for WPA2 security instead of WEP. I had also noticed improvements by force MTU size to 1453, fixed IP (no DHCP) ...and disabling of sleep mode.

     

    I find this totally unacceptable (and had to abandon two WEP-only device) but a least I recuperate most of the stability ...but with poorer performances still.

  • NothingInCommon Calculating status...
    Currently Being Moderated
    Oct 10, 2012 11:17 AM (in response to henrijacobs)

    I finally "fixed" it by just running a patch cable to my imac.

     

    I am shocked this issue hasn't been fixed. We shouldn't have to look for resolutions in forums that may or may not work or find applications to uninstall or whatever.

     

    The fact of the matter is you expect it to work since you pay a premium for it (apple products) and wifi on ML is simply broken for certain hardware that Apple claims compatibility with, this is unacceptable.

     

    APPLE FIX THE DAMNED ML WIFI NETWORK STACK ALREADY!!!!!

  • pbardon98 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 10, 2012 2:19 PM (in response to NothingInCommon)

    Well if it's fixed, it's really a good new. Do you remember which patch did you apply?

     

    Message was edited by: pbardon98

  • slolifesux Calculating status...
    Currently Being Moderated
    Oct 10, 2012 2:22 PM (in response to John Mul)

    I find that hard to beleive as I leave for lunch and come back with in an hour and it has no network connection.  My wifi is off and I am using a wire to a gb switch.  This happens when I use wifi as well though I dont use Wi-Fi often.  Oddly enough, happens on my iPad (new iPad) with iOS 6.  While I hate lion with a passion, this did not happen with Lion.  This did not happen with iOS 5.  I am curious what is similar with iOS 6 and OSX 10.8 that would cause this.  I suspect Apple has no clue what to do other than ignore it.  Maybe there is a new OS on the horizon, they refused to do anything about permissions with Lion since ML was due out soon.  Then again, the permissions issues with Lion have been around since day 1 and are still present with 10.7.5.

  • chogokin666 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 10, 2012 3:23 PM (in response to slolifesux)

    Of course you are 100% correct the "explanation" above is pure nonsense. If you are transferring torrents all night should one have to continually drink coffee in order to prevent your Mac from sleeping and losing its connectivity? Of course not. The properly functioning OS knew to let the user decide. The peons to do clean installs from a thumbdrive annoy me even more, if that is what it takes to have an operational system than that is how the OS should be pushed. Not OTA if it cant be properly implimented that method. Im fed up even leaving this comment led me to have to change one of my myriad Apple passwords that they require for every single thing, cannot this be streamlined? Why must I seperately log in to, App store, Itunes,Comment threads,Website, My own friggen desktop asks for a seperate password on occasion to delete files etc. Its assinine. I had to buy a new  router to get the dropouts sorted only to now lose connectivity at the mbp's whim. This is aside from the incredible bouncing beachball that I rarely saw prior to this and the battery that now not only has a fraction of its life but is steadily losing capacity by the day. Maybe one of their exalted "geniuses" can come clean my apt in compensation for all the time Ive spent trouble shooting what is obviously a Beta level OS at best. #gag

  • Guimesquita2 Level 1 Level 1 (45 points)
    Currently Being Moderated
    Oct 10, 2012 4:14 PM (in response to lesdmd)

    Launch Temrinal and then paste this:

    sudo /usr/libexec/airportd debug +alluserland +alldriver +allvendor +LogFile

    (You can disable logging later on by using the command:  sudo /usr/libexec/airportd debug -alluserland -alldriver -allvendor -LogFile)

    Reboot your machine now.

     

    XD

  • kljay24 Calculating status...
    Currently Being Moderated
    Oct 11, 2012 9:00 AM (in response to henrijacobs)

    I have been having the same fun as you all!!!

     

    After months of not using my iMac I fixed the problem today by upgrading the firmware on my router.

     

    Since updating my iPhone to IOS 6 and upgrading my iMac to ML, my wifi connection would constantly stop working and I would have to disconnect and reconnect.

     

    Hope this helps somebody before Apple updates drive you insane!!

  • Ronald-E Calculating status...
    Currently Being Moderated
    Oct 17, 2012 2:10 PM (in response to henrijacobs)

    Hello,

    I did read quite the whole thread and found so many of malfunctions like you.

    I did tray so much and got different results.

    Now I made a tray and had an hit. The Wi-Fi came up so fast after the restart,

    I never had befor. It looks really good.

     

    I got a new iMac 27 last week. I use a Fritzbox with VDSL since two years.

    Never probs with XP PC.

    I did read yesterday about the WEP and WAP keys. ASCII beginning with "

    and HEX with ?. I never saw.

    I always used the 16 digit long numeric WAP key of the Fritzbox.

    What I did:

    deaktivate Wi-Fi

    Now I changed it to a 10 digits long alpha-numeric-specialsigns password in the ROUTER.

    I deleted the Airport-keys in Keychain, one in Login and on in System on the iMac.

    And I deleted all environments on Networksetup

    Than I started to setup a new Wi-Fi .

    Choosed my router, entered the new WAP-key

    and in 0,01 seconds the iMac was connected.

     

    I tested a Off and ON.

    0,01s connected.

     

    Please tray it and let us know.

  • Ronald-E Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 17, 2012 2:24 PM (in response to henrijacobs)

    Guys,

    I made restart again.

    I had keep open the email and the browser with this thread,

    it came up with the restart w/o WiFi delays or probs.

    I get crazy...

     

    no Youtube brakes after 25 seconds...

     

    CHECK IT OUT

  • KAOS1705 Calculating status...
    Currently Being Moderated
    Oct 23, 2012 9:33 AM (in response to henrijacobs)

    Same problem since updated to Mountain Lion.

     

    Tried everything, and now also Youtube crashes each 20 seconds... It's incredible!!!

    Of course bootcamp's W7 runs perfect, and yesterday had a online simrace with rfactor, 1,5 hours, no lag, no disconnection, every thing perfect !!!

     

    But ML doesn't work.

     

    Apple, please, in the next Keynote you could tell us when are you going to fix this, instead of showing new products.

  • neale121 Calculating status...
    Currently Being Moderated
    Oct 23, 2012 10:39 AM (in response to henrijacobs)

    I had the same problem as did my wife with dropped wifi connections after sleep in lion and mountain lion

    I fixed the problem by following the steps below for both macbooks and still working great over a month later

    Hope this may be of help

    Our router is an Airport Extreme base station

     

    1. Make sure Wi-Fi is turned on but with no current connection to any Network

    2. Delete all Airport/Router Network Passwords that are stored in Keychain that are associated with your Wireless device

    Do a search for Keychain with Apple 'Spotlight

    Open Keychain Access and delete all Network Passwords certificates that are related to your wireless account

    You may have to enter your administrator password to unlock and delete files

    • Exit

     

    3. Add a New Network Location

    • Open System Preferences from the  Apple menu and choose “Network”
    • Pull down the “Location” menu and choose “Edit Locations
    • Delete all locations listed except Automatic
    • Click the [+] button to add a new location, name it whatever you want (I used my chosen network name) then click Done

     

    4. Join Other Network

    • Back in Network System Preferences screen click on Wi-Fi on left
    • Click the “Network Name” menu and select 'Join other Network' enter your Network name and enter your password (if needed) in  the Security bar. (I picked 'WPA personal' for my security setting)
    • Make sure Remember this Network is checked and click join      

           at this point my wireless network was active 

     

    5. Renew DHCP

    • From the Network panel, click on the “Advanced” button in the lower right corner, then click the “TCP/IP” tab
    • Make sure “Configure IPv4:” is set to “Using DHCP” and then click the “Renew DHCP Lease” button, click “Apply” when prompted
    • The appropriate DHCP settings should be renewed from the connected router, click “OK” and exit out of System Prefs

     

    After completing these steps in this order I now have my Wireless back and reconnects automatically after sleep and after 5 weeks no dropped connections.

  • willys2939 Calculating status...
    Currently Being Moderated
    Oct 25, 2012 7:00 PM (in response to neale121)

    Problem:  OS X M.L., v10.8.1 (4+)  wireless connected to HP Officejet Pro 8600 Plus printer. Arris N type router provided by cable company.  No problem with wireless connection for our 2 Imacs. Problem with connecting to the printer. Sometimes there is no problem printing or scanning. At other time, whenever printer takes a notion, it will not print. Print & Scan in System Preferences shows that it is looking for the printer or cannot locate the device.

    Have latest updates from H.P. and Apple but still is persistant problem. A print job may be looking for printer for 15 minutes or longer until it decides to print. Printer indicates it is connected to the wireless router.

     

    Any ideas, anyone. Driving me crazy.

  • KAOS1705 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 25, 2012 11:47 PM (in response to neale121)

    Thanks neale121

    It works better now.

1 ... 6 7 8 9 10 ... 25 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.