Skip navigation

Airport Express (square) skips unbearably with Airplay

49660 Views 147 Replies Latest reply: Apr 17, 2014 3:01 AM by metamedia RSS
  • JLinSLC Calculating status...

    I have the same issue with Airport Express stuttering.  The best solution I've found has been to change my base station, which is a Time Capsule to a 5 GHz network.  Open Airport Utility>Airport>Wireless>Wireless Network Option...> 5 GHz network checkbox.  > Update.  I still get an occasional dropout, but not like it used to be, which was every 10 seconds. 

     

    Also, I've read somewhere that turning off the set time automatically in the Time Capsule and Airport Express also helps fix the stuttering. 

  • chatoos Calculating status...

    I bought the Airport Express mainly because of the airplay feature. My objective was to connect my AE and my Samsung TV to my Sony Receiver through the audio optical cable but my Sony Receiver only has one optical audio input, so I bought a Recoton ADS 1000 Optical Switcher, which has 3 inputs and 1 output.

     

    When I connect my AE to the switcher, which is already connected to the Sony Receiver, it doesn’t work, it just doesn’t play the music in the receiver but the optical cable does work because the red light is showing.

    But when I connect it directly from the AE to the Sony Reciver it does work, it does play the music.

     

    Why might be causing this problem?

     

    by the way the swithcer does work because it does play the sound from the tv, which is also connected to the switcher

  • Charles Campbell2 Level 1 Level 1 (120 points)

    I have been using Airplay with an optical connection into a Benchmark DAC1 Pre for years without problems. Lately I too have been plagued by frequent skips. I tried stereo out also, but still had the skips. I tried the solutions mentioned in this thread without success.

     

    I accidentally noticed that the Sound settings in System Preferences have changed since the last time I looked--I suppose since I upgraded to Mountain Lion, but I'm really not sure. Anyway, Airplay devices are now choices in the Sound preferences. I changed my preferences to my Airport Express and the skips went away. I next changed back to Line Out for regular sound from my computer speakers and my Airport Express continued to work without skips whien I selected Airplay in iTunes!

     

    I'm not smart enough to have an explanation, but I've waited two days to post this and the skips haven't come back. I hope it works for others--and I hope someone can explain it to me...

     

    Charlie

  • Odenslayer Calculating status...

    Buried in this thread was a tip that has worked for me. I opened Airport Utility on the serving mac mini and voila! no more dropping. I have tested for the last 4 hours and Airplay hasn't dropped yet. Fingers crossed this workaround lasts until a patch is in place.

     

    I have an old (n) AE and a new AE, when I play from just the old one it is fine, when I add the 2nd AE (the new one) it makes the entire network drop the signal.

     

    I also noticed that after dropping the signal, the connection to the new AE was lost from my "multiple speakers" AP link.

     

    Apple, I brag about your products all the time, I often tell folks that Sonos is a rip off when you can play with AP. Don't make me look bad, you gotta fix this!

  • Odenslayer Level 1 Level 1 (0 points)

    FAIL. Please ignore the last post. As soon as I opened my macbook while AP was playing I stted getting drops. To many connections?

  • MrJoshua Calculating status...

    So, I just bought a new Airport Extreme (square) and a Cambridge Audio DacMagic 100 (and a mini-to-toslink optical cable).

     

    When playing music wirelessly from my early 2011 MacBook Pro 13", it's sweet - no problems at all.

     

    If I play music wirelessly from either my iPhone 5 or "New" iPad, I get random dropouts of the audio and the blue light next to 44.1 flicks off and back on.

     

    All three devices are getting the music from iTunes Match, but I also downloaded music locally to the iOS devices to make sure it wasn't a problem with streaming the music over the internet.

     

    If I bypass the DAC and use a 3.5mm to Phono cable into my pre-amp, music streams fine from both iOS devices and my MacBook...  It just doesn't sound as good as it does via the DAC!

     

    I hope this is just a firmware issue and that Apple will listen to us and issue an update to fix it.

     

    Fingers crossed!

     

    Cheers - Josh (UK)

  • dambor Level 1 Level 1 (0 points)

    I do have your same problem. I have 3 old AE (2 n and 1 g) that work perfectly with airplay either thorugh an analog connection to the amplifier or through an optical connection to a Musical Fidelity X-DAC V3. The new model of AE works well connected analogically but will keep on skipping music when conneted optically, no matter what changes I make to the wifi network (radio frequencies, 2,5ghz vs 5ghz, you name it). The same happens to a friend of mine when connecting the new AE optically to a Musical Fidelity V-DAC3. I called apple and they do not aknowledge that the new AE has a problem on its optical connection. They will substitute my unit, but I'm sure the problem will persist. Any ideas on how to solve it?

     

    On a paralell topic, has any of you tried the apple tv as an airplay client connected optically to a dac? does it work well?

  • dambor Level 1 Level 1 (0 points)

    I just tried the apple tv v2 connected optically to my X-DAC V3 and works perfectly. No skipping at all. I didn't do a strict a/b comparison, but I think it sounds better than the AE. Subjective? Maybe... Only hassle is you need to connect it to a TV through an HDMI cable for initial set up.

  • luke foley Calculating status...

    I have the solution! I had the same issue and called apple. My airport express (2nd gen) was joined to my time capsule on the 5 GHz network. Apple suggested to move to the 2.5GHz network. I did this and no more skipping. They told me if my problems persisted to change the channel the time capsule is operating on. Default it automatic move around channels to find which one works for your area!! Good luck!

  • MrJoshua Level 1 Level 1 (0 points)

    My workaround has been to keep my MacBook Pro on all the time with iTunes running, and control this via the Remote app for iOS.  When streaming wirelessly from my Mac to my square AEx, Optical Cable and Cambridge Audio DacMagic 100, I get no skips at all, ever.

     

    But!

     

    As soon as I stream from an iOS device (iPhone 5, iPad 3) I get regular skips.

     

    Very frustrating!!

     

    iOS 6.0.1 hasn't improved things either.

  • MrJoshua Level 1 Level 1 (0 points)

    I've now formally raised this with Apple Support and it's gone up to the engineering team.

     

    I'll respond again when they get back to me.

  • Neometro Level 1 Level 1 (5 points)

    Same problem as everyone here. I hope you hear something from Apple's engineering team soon.

  • Dendya Level 1 Level 1 (0 points)

    Ditto. I just bought an airport express for the purpose of streaming audio. Streaming from IOS device is brutal. Regular skipping and cutting out. Please fix this, Apple.

  • MrJoshua Level 1 Level 1 (0 points)

    I got a call back today and went through a bunch more tests to try to get to the bottom of it.

     

    Even with the AEX totally standalone with an iPad and the DAC, it skipped (ie not connected to any other network).

     

    Cellular and BT were turned off on my iPad3, tried 2.4GHz and 5GHz, WiFi encryption on and off...  Kept cutting out periodically.

     

    It's now gone back up to the engineering team.

     

    If anyone else wants to raise this, call the iOS support team as that's who is dealing with mine.

  • neodoc01 Calculating status...

    I, like most in this post, have recently bought a new AE and upgraded my Time Capsule as well.  I've been having the same problem.  I spent two days reading posts, reviews, blogs...etc and tried everything.  I won't go into great detail, but I've tried almost, or possibly more, changes that were all recommended in this post.  Long story short, it still skipped and dropped out.

     

    I took it back today for a refund.  I bought the new Apple TV two days ago and it works fine.  It really seems like there was a "bad batch" distributed by Apple.  If all you want to do is stream music, or wireless media, go with the Apple TV. My fingers are croseed, but I haven't had a single skip from my computer, iPhone, Pandora or internet radio. Going with Apple TV is not an option if you want to extend your network, so I hope this issue is addressed soon. I liked my old AE (and still use it) but would like to upgrade from time to time and use them throughout the house. 

     

    Keep trying different settings, but if you're spending too much time on it, I would suggest returning it.

     

    Thanks.

1 2 3 4 5 ... 10 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (7)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.