Skip navigation

Photo sync issues after 10.8.2, iOS 6, iPhoto 9.4 upgrades

64269 Views 267 Replies Latest reply: Jan 10, 2014 11:39 AM by sungyle RSS
  • Mr. Luigi Level 1 Level 1 (5 points)

    I did use the workarounds suggested in this forum (get rid of "&") on MY MBP and it solved the problem .  However, I was not willing to mess with my daughter's MBP for fear I would trash it and then she would trash me. (Senior in High School.  Most dangerous species on the planet.)

     

    So, I waited for the v9.4.1 update.

     

    Just updated her laptop and synced her iPhone 4S.

     

    No problems at all!

     

    Sorry for those that don't appear to be finding relief with the v9.4.1 update.  But, it did work for me.

  • garyMacPro Calculating status...

    The extra events with dates arise from the conversion of iPhoto and Aperture to a common library format.

    The extra events can be eliminated by exiting iPhoto and opening the converted library in Aperture.  Then in Aperture look for the extra event dates under the Projects heading and eliminate them in Aperture.  Then exit Aperture and re-open the library in iPhoto and one should find that the extraneous events have been removed.

     

    The second issue I would like to address concerns the order in which events seen in iPhoto 9.4.1 are displayed on the iPhone using IOS 6.0.

    The phone will show will show events sorted by the earliest date seen in the iPhoto info panel under the event title.  It takes the date of the earliest photo in a given event.  This is the case even if you set iPhoto to sort by title.  The order will not been seen on the iPhone by title, it will be seen by date.

    Apple will need to address this problem for the sort to work properly.

  • ChrisBoston Calculating status...

    I was experiencing the same issue with extra date only events being synced to IOS6 iPad and iPhone so I purchased Aperture today.  After starting Aperture, I could now see the bad events in the Library which showed only thumbnails but no pictures and I was able to remove them.  Now my iPhoto sync to IOS is working as expected.  Oh well, at least I have a real photo editing application now and $79 wasn't too bad a price.

  • BlueLux Calculating status...

    I am one of those unlucky ones who have had only problems updating to 9.4 or 9.4.1. iTunes does not talk well to iPhoto at all. I don't have any slideshows, just 10.000+ photos and an eternity spent on naming all the faces. What I'm experiencing is:

     

    1. Events are not sorted in iTunes as they are in iPhoto.

    2. Multiple duplicates of Faces in iTunes, many of them even unknown to me.

    3. Syncing my iPad with iPhoto version 9.4 or 9.4.1 is like syncing to a whole new library, and when the syncing is over, there are still photos missing.

    4. Albums sorted other than by date is not respected by iTunes. They are sorted by date, even if I have them by title in iPhoto.

     

    I've already provided feedback twice to Apple. I hope they are aware that some of us still have problems with iTunes syncing, and that they are providing a fix for it. Otherwise, I might have to "upgrade" to Aperture as well, but that's my last resort. I don't like spending money for another product because of a defective update.

     

    I'm curious though, if version 9.4 and 9.4.1 are designed with the upcoming iTunes version in mind. Maybe all the problems will sort themselves out with the new iTunes...

  • bhurte Calculating status...

    I had the problem, and solved it with 9.4.1.  However, I just migrated to a new laptop using Migration Assistant and the problem came back (not synching all my library, just about 80% of it).  I tried rebuilding my library and I don't have any '&' issues.  Am I missing something?

  • neimannj Calculating status...

    Please check, if this is related to my problem which I reported here: https://discussions.apple.com/message/20143792

     

    Open iPhoto-Library and check if ApertureData.xml instead of AlbumData.xml is updated every time.

  • BlueLux Level 1 Level 1 (0 points)

    There is no ApertureData.xml in my library. But then again, I don't have Aperture...

  • neimannj Level 1 Level 1 (0 points)

    Thanks! I just thought there might be anyone else affected.

     

    I do not use Aperture, too. But somehow iPhoto decided to create this file after some update.

     

    I finally got it fixed. But your problem seems a bit different.

  • violentlove Calculating status...

    After a long wait, apple finally pushed out a update to both iphoto and aperture. After downloading them both all my events are back in order, and everythign seems to be ok once again. 

  • BlueLux Level 1 Level 1 (0 points)

    Just wanted to mention what I wrote in another thread, after updating to 9.4.2 (from 9.3.2), I also no longer have issues with the Events and Albums order or duplicates of Faces. The only problem I have now is missing photos from Events and Albums in iTunes. For instance, an album which contains 47 photos in iPhoto only shows up as 42 in iTunes, and subsequently only 42 photos are syncing to my iPhone/iPad. Also, som Albums/Events have messed up order inside them. I have made all my Albums sorted by date in iPhoto, and they do so only to a degree in iOS. Some Albums are fine, other are not. Why this happens, I have no idea. I just hope that Apple can sort this last problem out in the next update.

     

    Oh, I should probably mention that I already tried to delete the iPod cache folder without luck...

  • violentlove Level 1 Level 1 (0 points)

    I had the same problem, it is possible that your album is missing the actual photo but still showing the thumbnail. I had the same problem. I noticed it when in aperture the photos themselves were missing. I've up dated to aperture and use both programs on my Mac. In aperture you can adjust the sort by event in that album and what ever you do in one reflects the other because they use the same library. I found that it actually works in aperture when syncing, unlike iPhoto the changes never reflect.

  • Fred driver Calculating status...

    I've tried everything and still cannot get iTunes to reliably sync any photos from iPhoto.

    iMac with OS 10.8.2

    iPhoto 9.4.2

    iTunes 10.7

    iPhone 4S with iOS 6.0.1

     

    Have tried:

    - deleting iPod Photo Cache

    - elminated every "&" symbol in iPhoto (from photos, events and albums). Both .XML files show zero "&"s by themselves. Not in any slideshows or photos.

    - rebuilt iPhoto library

    - restored the iPhone to factory settings

     

    Occasionally I can get iTunes to sync photos, usually after deleting the iPod Photo Cache. It re-examines the iPhoto library and loads the photos on the phone. But then they get deleted the very next time I sync. iTunes still shows "Selected albums, Events, etc.." selected, but nothing is on the phone. The color band at the bottom of iTunes which shows what is on the phone shows 1.33GB of Photos. Occassionally when I sync that color band will expand to several GB, indicating how much the photos should be taking up, and it will appear as if it's going to sync, then it will stop and revert back to 1.33GB of Photos displayed in the band.

     

    Also, in iTunes, on the Photos tab for my iPhone, even though "Sync Photos from iPhoto" is selected, off to the right where it's supposed to show the tally of photos, it says "0 photos". So even though it's showing all the respective events/albums below, where I can select what I want to sync, everything I select shows up as "0" to the right, as if iTunes is reading the event/album structure but doesn't see any photos in library.

     

    Don't know if it's related, but I also have a curious issue that a couple events in iPhoto show up in iTunes as a whole series of events. For example, a single event in iPhoto with 50+ pictures from 25 Aug 2012, shows up as 50 or so separate events in iTunes, each with one picture, and each called "25 Aug 2012". This occurs for several events, where iTunes is breaking the photos into individual events instead of keeping them as a single event. Can't figure out why as it does not show up that way in iPhoto. I try to correct it by exporting the event with those photos from iPhoto, deleting them from iPhoto, and re-importing the photos as a fresh event. Same problem re-appeared in iTunes.

     

    Extremely frustrating. Any help is appreciated so I can sync photos again.

  • Dragon Pensando Calculating status...

    I SOLVED THE PROBLEM !!!

    SIMPLY REINSTALLED THE PREVIOUS VERSION OF iPHOTO

     

    Hello.

    As with many in this forum I was having the problem of iTunes not recognizing my iPhoto library and therefore it would not sync any pictures to my iPhone nor iPad. I tried many of the solutiones written here and either they didn't work or were to advanced for my level of expertise.

    Untill... yesterday...

    Y reinstaled the previous version of iPhoto (9.4 -the current is 9.4.4) and its working fine. YEPPPPP

    As I said, my level of expertise is not very advanced so it makes me even happier to have solved the problem by myself, and I hope this solution helps more users.

    Best regards

     

    BTW: in my case, I retrieved the previous version from my Time Machine backup.

  • EastDog Level 1 Level 1 (10 points)

    I've got these same exact symptoms/problems, Fred.  Thank you for saving me all the typing!

     

    Just to reiterate for others, deleting the iPod Photo Cache fixes it... until the very next sync.

     

    Also, whatever is causing this problem has now also prevented iPhoto from working with the Apple TV (3) via Home Sharing.  Similiarly to what's seen when trying to sync photos with the iPhone via iTunes, Home Sharing shows "0 photos" in the "Choose Photos to Share" window for Home Sharing.

     

    Not quite sure when this started, but it's within the last week or two.

  • Dragon Pensando Level 1 Level 1 (0 points)

    Hi EastDog.

    Did you read my post inmediately ahead of yours. Because I really solved the problem

Actions

More Like This

  • Retrieving data ...

Bookmarked By (23)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.