2 Replies Latest reply: Dec 14, 2012 2:04 PM by cat-tamer
cat-tamer Level 1 Level 1 (0 points)

Hi Fellows,

 

Since a couple of days I can't upload images and pdf's to my wiki anymore. What happens is that the image or pdf gets uploaded once and processed 3 or 4 times (I can find them in the corresponding /Library/Collaboration/ folder). But the image or pdf does not show up in the wikipage and throws up a server error message instead: There was an error uploading the file. Please try again.

Stop/Start the wikid proces solves the problem shortly until after a couple of hours the problems start occuring again.

 

On the server side I see this:

 

Oct 10 08:08:37 myserver com.apple.wikid[41152]: Wed Oct 10 08:08:37 myserver.x.net QTKitServer[45631] <Error>: kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.

Oct 10 08:08:37 myserver /System/Library/Frameworks/QTKit.framework/Resources/QTKitServer[45631]: _RegisterApplication(), FAILED TO establish the default connection to the WindowServer, _CGSDefaultConnection() is NULL.

Oct 10 08:08:37 myserver com.apple.wikid[41152]: _RegisterApplication(), FAILED TO establish the default connection to the WindowServer, _CGSDefaultConnection() is NULL.

 

My questions:

 

1. How can I catch errors / set breakpoint

2. How can I make sure the QTKitserver can 'talk' to the windowserver

 

Colocated productionserver with DNS, Firewall, iCal, Mail, MySQL, OD, Push Notification & Web + wikis

 

Thanks in advance!

the cat-tamer


Mac mini Server (Mid 2010), Mac OS X (10.6.8)