Skip navigation

QuickTime 10 Close Window

2737 Views 13 Replies Latest reply: Oct 6, 2013 9:29 AM by Kittihawk RSS
Dreaded Neil Calculating status...
Currently Being Moderated
Apr 10, 2011 11:05 AM
Is there any way to close a widow in QuickTime 10 without quitting and starting the programme again? I know this has been asked before, but no solutions have been proposed.
Black Intel MacBook, Mac OS X (10.6.7)
  • QuickTimeKirk Level 8 Level 8 (47,390 points)
    Currently Being Moderated
    Apr 10, 2011 11:25 AM (in response to Dreaded Neil)
    Command - w closes the window.
    The app remains running.
    iMac 3.06, (Mac mini and G3 given to the grandkids), Mac OS X (10.6.7)
  • tanner1294 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 14, 2011 3:56 PM (in response to Dreaded Neil)
    You could try Command+H. It's the "Hide" command. Also try looking under Quicktime>Hide Quicktime Player. I don't have Quicktime 10 so I don't know for sure. (I'm stuck using 7.6 on OS X Tiger haha)
    PowerMac G4 Quicksilver (2001) 384mb RAM at 733mhz, Mac OS X (10.4.11)
  • tanner1294 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 15, 2011 3:11 PM (in response to Dreaded Neil)
    I'm sorry, I don't fully understand what you mean then. Hiding the application means means that the window is gone but the app is running. So the window is closed. Are you wanting something like iTunes on Windows, in which there's an icon in the tray and you can control iTunes from right-clicking the icon?
    PowerMac G4 Quicksilver (2001) 384mb RAM at 733mhz, Mac OS X (10.4.11)
  • tanner1294 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 15, 2011 4:11 PM (in response to Dreaded Neil)
    Oh okay, I think I know what you mean now. Well, I think it's just a glitch in the software then. There's probably a com preference file somewhere with the wrong code in it. I'd suggest searching those first. I would for you but as I said, I'm stuck on OS X Tiger with 7.6.4. Best of luck
    PowerMac G4 Quicksilver (2001) 384mb RAM at 733mhz, Mac OS X (10.4.11)
  • Kellerman Calculating status...
    Currently Being Moderated
    Apr 20, 2011 2:11 AM (in response to Dreaded Neil)

    Had the same problem: Close Window in the menu was permanently greyed out and there was no close button in the window title bar (or any other buttons for that matter).

     

    Trashing the Quicktime preference files solved the problem for me.

     

    Quit Quicktime, then in the Finder, go into your user folder, Library folder, Preferences and search for "quicktime" while limiting the search scope to the “Preferences” folder and “File Name” (using the search options at the top of the window), then select the files listed and trash them, and restart Quicktime.

  • Kellerman Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 20, 2011 2:19 AM (in response to tanner1294)

    Hiding an application doesn't close it's open windows, it just hides them from view … but they're still open and active, and if a movie is playing in them it remains playing when hidden even though you can't see it (you can still hear it though). The same is true for pretty much all apps and windows. In Safari windows, banners and flash animations and javascript applications in hidden windows keep running and slowing the machine down and draining the battery even when hidden or otherwise out of view. So there's a lot to be said for actually closing a window rather than just hiding it.

     

    All of this may change when Lion is released and apps are rewritten to take advantage of the new OS features that will make MacOS work more like iOS.

  • Alexander Robinson1 Calculating status...
    Currently Being Moderated
    Aug 3, 2011 12:00 AM (in response to Dreaded Neil)

    I've been having this issue since Snow Leopard... Lion it got worse because it restores the previous window even when you quit so I was inspired to try to fix it and was able to do so deleting the .plist

     

    Quit the Quicktime.app

     

    Finder > Go > hold option key and click Library > open the Preferences. In the ~/Library/Preferences and delete the com.apple.QuickTimePlayerX.plist and you will get an option to hit an x on hover in the upper left of the window and Command+W will work

     

    I am guessing the MGCinematicWindowDebugForceNoTitlebar set to -1 was a problem

  • martinfrommanningtree Calculating status...
    Currently Being Moderated
    Aug 15, 2011 10:40 AM (in response to Dreaded Neil)

    Alexander Robinson1 is correct; you don't need to delete all your preferences - just set them up correctly.

     

    You just need to type this into a terminal window:

     

    defaults write com.apple.QuickTimePlayerX MGCinematicWindowDebugForceNoTitlebar 0

     

    This turns on the title bar of the movies you are opening (it is not there at the moment I am sure). For some reason, when the titlebar is absent the Close option on the File menu is also unavailable - that is really rather daft, but there you go.

     

    In order to prevent persistent windows between innovations, you also need this:

     

    defaults write com.apple.QuickTimePlayerX NSQuitAlwaysKeepsWindows -bool false

  • mattue Calculating status...
    Currently Being Moderated
    Oct 13, 2012 12:52 PM (in response to martinfrommanningtree)

    @ martinfrommanningtree,

     

    I tried to do what you said but it didn't work. I wonder if i pasted it in wrong. I'm a noob.. could you tell me exactly what to type in the terminal after my computer name with a dollar sign?

  • Kittihawk Calculating status...
    Currently Being Moderated
    Oct 6, 2013 9:29 AM (in response to mattue)

    Yes - this greyed out thing is a complete time wasting pain. There seem to be teams of software experts inventing new time wasting things with every generation of OS X - they probably haven't got enough to do and they should sack a few!

     

    It is particularly frustrating in Lion etc due to it always reopening windows when they are not shut down (a feature I don't ever want - can be switched off in an obscure tab in General Preferences but why? Making extra work for us - a concept those bored sorftware engineers don't seem to grasp).

     

    So in summary - now whenever I open Quicktime 10 I have hundreds of older files that open too because I can't close them down. Brilliant Apple - give yourselves a medal.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.