Skip navigation

netflix is not working on my atv3.

601 Views 4 Replies Latest reply: Nov 2, 2012 8:58 AM by zootdaze RSS
steakandkidleypie Calculating status...
Currently Being Moderated
Oct 8, 2012 11:37 AM

netflix is not working on my atv3.  since i did an update a couple of weeks ago this has been the case.  Netflix have been through turn off/on, reset wifi, restore settings and none of this works.  Netflix are now blaming apple as they say they have gone through everything.

Apple TV, iOS 6
  • zootdaze Calculating status...
    Currently Being Moderated
    Oct 8, 2012 4:43 PM (in response to steakandkidleypie)

    Having the same issue.  After the update Netflix and some of the other non-Apple online services have stopped working.  Under general info in the settings on the Apple TV it says that activation has failed.  If I reset the settings nothing changes.  If I do a restore it fails.  I have tried to restore it multiple times.

  • adam60 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 13, 2012 5:47 PM (in response to steakandkidleypie)

    Hi Everyone,

    hope this message finds you all in time. The recent Apple TV update 5.1 is terrible. Apple knows it is which is why (thankfully for some relentless user -I have no idea who but I believe it was under threat) they have allowed to sign 5.0.2 again which means you can downgrade your Apple TV 2 and 3 to a 5.0.2 version via iTunes. Who knows how long they will keep the window open but I have downgraded my ATV early this morning. I couldn't post this earlier because I was out all day but I am doing it now.

     

    Here's how to do it:

     

    1) Connect your ATV to your computer via a Mini USB (not included with ATV but included with many other electronic devices) - in order for your ATV to appear in iTunes you must FIRST plug the USB cable to your computer and ATV and only THEN plug the power cable.

     

    2) Download your ipsw restore file from Apple.

     

    5.0.2 (ATV 2): AppleTV2,1_5.0.2_9B830_Restore.ipsw

    5.0.2 (ATV 3): AppleTV3,1_5.0.2_9B830_Restore.ipsw

     

    3) In iTunes select yout ATV, hold SHIFT and click on Restore

    4) Find and choose the downloaded IPSW file in the Open Dialog Box and hit Next

    5) As long as Apple still signs that version the Restore process will begin and will take a few minutes to complete.

     

    Enjoy!

     

    raadore

  • Dougerus Calculating status...
    Currently Being Moderated
    Nov 2, 2012 8:38 AM (in response to adam60)

    When I click Shift and then restore it does not give me the option to find and choose the file? This is an apple 3 TV and iTunes 10.7 it pops up another box that says "Are you sure you want to restore the Apple TV "Apple TV" to its factory settings? All your media and other data will be erased, and the newest version of Apple TV software will be installed. iTunes will verify the restore with Apple." I can then click cancel or Restore and Update and holding shift hear does not work as well. The reason I am trying to downgrade is the Apple TV will no verify or register with Apple it fails doing this and many of the Apps/Channels do not work like youtube, netflix, wsj some do like the movie trailers and apple apps??

  • zootdaze Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 2, 2012 8:58 AM (in response to Dougerus)

    I think the directions are wrong.  You actually need to option click.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.