Skip navigation

Mission Control issue : some windows disppear

1360 Views 19 Replies Latest reply: Oct 25, 2013 6:27 PM by baopham RSS
1 2 Previous Next
Yoyor94 Calculating status...
Currently Being Moderated
Aug 24, 2012 2:22 AM

Hi all,

 

I'm experiencing some weird issue with Mission Control (it was with Lion ... and Mountain Lion did not correct this) :

You can see a video I've taken yesterday (sorry for the poor quality) : http://youtu.be/gAwIcF4JINc

 

As you can see :

- Mission-Control makes some of my windows (all windows in the example video) disappearing : they're reduced to "0" pixel

- Sometimes, the App icon stays visible (but I cannot select the windows as it is 0pixel size ...). Sometimes, even the App icon is not shown (often with Safari)

- Sometimes : only Safari is experiencing the issue ==> all other windows stay OK (Finder, etc... can be selected in Mission Control and Safari is the only 0 pixel sized). In the enclosed video, all apps are affected which is quite rare.

 

if I close the impacted app(s) and relaunch it, mission control handle the re-opened app(s) correctly.

 

Is there any way to fix this ?

I was hoping it was a 10.7.x issue but as 10.8 (incl. 10.8.1) is not fixing this, I'm losing patience.

 

Thanks in advance,

 

Yo

iMac, OS X Mountain Lion (10.8.1), iPhone 4 4.2.1
  • bd297 Calculating status...
    Currently Being Moderated
    Oct 13, 2012 12:41 PM (in response to Yoyor94)

    I'm having a mission control issue as well that may be the same... 

    When I do a 4 finger swip up on my touchpad, my safari windows goes to a tiny thin line.  I can see my other windows find, Finder, Mail, etc....  but the safari one all but dissapears except for a small line like a thread..  I cant choose this line to switch to safari so it is quite annoying

  • bd297 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 14, 2012 6:41 AM (in response to Yoyor94)

    I'm not sure if that's a fix for me or not..but the next time it happens I will try...  Up till now it seemed to randomly occur and go away...

  • bispymusic Level 2 Level 2 (270 points)
    Currently Being Moderated
    Oct 14, 2012 8:29 AM (in response to Yoyor94)

    I believe that some of Mission Control's preferences are tied to your Dock settings. Try this and see if it fixes it:

     

    Open Finder.

    Press and hold the "Option" key and click on "Go" from the menu bar up top. Select "Library".

    From the Finder window, open your "Preferences" folder.

    Find a file called "com.apple.dock.plist". Rename it "com.apple.dockbackup.plist".

    Restart your Mac.

     

    Does this fix your Mission Control issues?

     

    Also note that this will reset your Dock to it's original configuration. You may want to tweak the Dock back to your liking after this is done.

  • Josh Passey Calculating status...
    Currently Being Moderated
    Jan 16, 2013 9:19 AM (in response to Yoyor94)

    Hey!

    I'm sorry for such a late reply but this same problem happened to me today and I chanced upon this thread.

    As you said it is onl happening with Safari. I tried deleting the com.apple.dock.plist as well and restarting but that did not solve the problem so obviously its not tied to the dock preferences. Have any of you managed to find a workaround to this problem as this MacBook is pretty new and I'm getting very irritated with that horrible white line

  • Josh Passey Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 20, 2013 4:08 AM (in response to Yoyor94)

    Okay so I kinda found a workaround to it. Umm it had only started after I installed Windows 7 via Bootcamp and I think one of the drivers didnt install properly and then "something" happened

    I know this doesnt make any sense ^^^ but yeah i just reinstalled my drivers and the problems now permanently gone. I also deleted the com.apple.dock.plist yet again and this time before rebooting i switched off safari and cross checked it was closed by going into Apple Logo->Force Quit and then closing it from there and then rebooting. After that it worked properly and hasnt given me trouble since studying.

    So i dont know what sorted it out but something did and im happy

  • Josh Passey Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 26, 2013 2:51 AM (in response to Yoyor94)

    Forget the earlier reply...it's started again! I'm getting seriously ****** with this bug now. I really hope Apple fixes it in the next update. Have a look at this! Now it's started doing it with other applications as well, not only Safari!

     

    Mission Control.png

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.