1 Reply Latest reply: Oct 14, 2012 5:20 PM by Christian A. Burkert
acbourre Level 1 Level 1 (0 points)

My folks got a new iMac today, and I've got a 2007 iMac on the same network. We're both running 10.8.2.

 

I had a few folders set up to share files. My public folder, Movies, and then a new fold called "Mom" that I set up specifically for them. The settings are identical on all the folders, but they can only access "Movies." If I try to access any other shared folders from their machine, I get the following error:

 

"The operation cannot be completed because the original item for "[insert folder name]" cannot be found."

 

 

I have read the Mac 101: File Sharing document (http://support.apple.com/kb/HT1549?viewlocale=en_US) and followed the directions to no avail. I have removed and re-added all the folders, and still, only "Movies" is readable from their iMac (it too was removed and re-added). The settings for all the folders are identical to the settings for "Movies."

 

Additionally, after a short period any new folder I create and use as a shared folder will no longer allow me to rename it, even after I remove it from the shared folders list. The folders are not locked, and I have full admin privileges.

 

(Things work fine the other way, though: I can set up shared folders on their new iMac and access them just fine from my 2007 iMac.)

  • 1. Re: Mac to Mac file sharing not working for new folders
    Christian A. Burkert Level 2 Level 2 (300 points)

    hi there,

     

    that error message sounds like you placed a shared folder within a parent folder that is not shared. It also can help to boot into Recovery Mode (pressing Command and R simultanously when hearing the startup tune), launch Disk Utility, select the disk containing your OSX installation (usually named Macintosh HD) and choose Verify Disk Permissions. Should any problems be reported select Repair Disk Permissions. Once that is finished, reboot normally.

     

    Though unlikely, it might have happened during all the folder removing and readding that some Permissions are out of sync. So checking these Permissions is merely a precaution

     

    Once you are back in "normal" OSX using your admin account, try this:

     

    • Open Terminal from the Utilites folder
    • enter the following commands one line at a time:
    • mkdir /Users/Shared/Family
    • mkdir /Users/Shared/Family/Movies
    • mkdir /Users/Shared/Family/Mom
    • chown -R <placeholder> /Users/Shared/Family           
    • chmod -R 755 /Users/Shared/Family

     

    Be sure to replace <placeholder> with your account's short name (no brackets!)

     

    • Now open System Preferences and select Sharing
    • Select File Sharing from the left pane
    • Click on the little plus and add /Users/Shared/Family to your shares (The subfolders are automatically included)
    • in the right most pane check the access privileges. They are set, so that you can read and write to those folders, while everyone else can only read. If you want everybody to have read and write privileges, use 777 instead of 755 within the terminal last command.
    • Now the other computers should be able to see and use the shared folder you just created.

     

    If you create individual user accounts on your machine for every family member you want to access the shared folders, you can choose far more sophisticated levels of access privileges.

     

    Hope this helps,

     

    Chris