1 Reply Latest reply: Oct 14, 2012 1:57 PM by baltwo
sami A Level 1 Level 1 (0 points)

i constantly get a update software requese "compressor 1.2.1" so i update and restart, then it pops up again. ***? can anyone help? i have an Early 2008 desktop. Leapord 10.5.