Skip navigation

Unable to delete TM orphaned files - Permission denied

204 Views 3 Replies Latest reply: Oct 14, 2012 11:03 PM by baltwo RSS
cubytus Level 1 Level 1 (0 points)
Currently Being Moderated
Oct 13, 2012 8:54 PM

Hi community,


I had a previous configuration with a dual-boot 10.6 and 10.7 in it. For some reason, after booting 10.7 trying to debug an issue that was later attributed to a faulty hard drive cable, I went back to 10.6, where I noticed that, for some reason:

1- The computer name was changed to its Lion's name;

2- The whole Lion HD was backed up in full during each TM backup, not just the changed files

3- At one point, the full SL HD was also re-backed up.


Probably that, during the crash due to this faulty cable, volumes may have been marked as "un-backed-up". The result is, available space on the TM disk has been dramatically reduced. Fortunately, I know that I haven't edited any important document in Lion, and thus, can safely delete its backup. Also, some heavy folders from SL can be safely deleted. I already performed the latter without a hitch. Top prevent any false maneuover in SL, the Lion partition was hidden from it, and this property was passed down to the TM backup.


However, for some reason I can't do the same for the Lion hierarchy, even as I tried to simply completely delete three days of backup (SL + Lion hierarchies). In the meantime, Lion hasn't been reinstalled, and I tried to follow this topic, to no avail. It seems no command can get the Lion hierarchy to be displayed and, I suppose, deleted. I don't have any additional drive to dump the full TM drive before formatting it. There must be a cleaner solution.


How can I unlock this hierarchy and erase it in full, without screwing the other, SL, backups?

Mac OS X (10.6.8), MacBook Pro 8,1
  • baltwo Level 9 Level 9 (59,150 points)

    See Pondini's TM FAQs for starters.

    27" i7 iMac SL, Lion, OS X Mountain Lion (10.8.2), G4 450 MP w/Leopard, 9.2.2
  • baltwo Level 9 Level 9 (59,150 points)

    I don't do TM and if the FAQs didn't give an answer, then you'll have to wait for someone who does to pop in.

    27" i7 iMac SL, Lion, OS X Mountain Lion (10.8.2), G4 450 MP w/Leopard, 9.2.2


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.