Skip navigation

postgres/roundcube issues since 2.1.1

551 Views 4 Replies Latest reply: Oct 15, 2012 11:33 AM by Mark23 RSS
niwrik Level 1 Level 1 (0 points)
Currently Being Moderated
Oct 13, 2012 8:14 AM

Since installation of the Server App 2.1.1 update, roundcube is no longer accessible.  I get the following when attempting to login:


DB Error in /Library/Server/Web/Data/Sites/Default/webmail/program/include/rcube_mdb2.php (107): _doConnect: [Error message: unable to establish a connection]

[Native message: ]

** pgsql(pgsql)://roundcube:xxx@localhost/roundcubemail

Warning: session_start(): Cannot send session cache limiter - headers already sent in /Library/Server/Web/Data/Sites/Default/webmail/program/include/rcmail.php on line 784


I've attempted to create a new postgres database for roundcube to use, but in the end, the result was the same.  The installation tests return the following result:


Check DB config

DSN (write):  NOT OK(MDB2 Error: connect failed)

Make sure that the configured database exists and that the user has write privileges
DSN: pgsql://roundcube:xxx@localhost/roundcubemail


Additionally, I cannot seem to access port 5432 via telnet on the local server.  I started looking at making changes to tge postgres configuration files:  postgresql.conf and pg_hba.conf in /library/server/postgres/data


Note:  everything worked perfectly before 2.1.1


Any help would be appreciated.  I'm four hours into this with no results...

Mac mini, OS X Server


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.