Skip navigation

iOS 6 "lost" my calendar data

6741 Views 5 Replies Latest reply: Dec 26, 2012 5:26 AM by sitcom987 RSS
Tippytin Calculating status...
Currently Being Moderated
Sep 26, 2012 6:41 PM

When I updated my iPad to the new OS all the data on my calendar from previous months disappeared! I was keeping track of some important information and now it is gone. I am not able to reconstruct some of this data. Where did it go and can I retrieve it somehow? Please help!

iPad, iOS 6
  • ikita Calculating status...
    Currently Being Moderated
    Sep 27, 2012 7:43 PM (in response to Tippytin)

    I had exactly the same problem with my iPhone. Unfortunately I had not made any backups in iTunes or iCloud and I lost all my calendar events. I called Apple tech support and they said I should have made backups. The unfortunate thing is that when iPhone prompted me for the update, there was no warning that this could happen or that I should back up my phone! E.g. Windows always warns you before these kinds of critical installataions to back up the data.

  • BKelsey4 Calculating status...
    Currently Being Moderated
    Oct 15, 2012 5:25 PM (in response to Tippytin)

    I had the same problem. If you go to Settings > General > Mail, Contacts, Calendars... Down toward the bottom it asks how long you would like to syncs events for. Mine was set to one month back. Set it to "All Events" and everything should come back shortly. At least it did for me. Hope this helps!

  • karenmillares Calculating status...
    Currently Being Moderated
    Oct 21, 2012 12:22 PM (in response to ikita)

    Thanks for the tip! That's really handy. Guess the best/safest is to keep backups.

  • sitcom987 Calculating status...
    Currently Being Moderated
    Dec 26, 2012 5:26 AM (in response to Tippytin)

    I had the same problem with my iphone 4S, but I don't have a menu item BKesley4 mentioned. My solution was:

     

    To sync your calendars using iTunes:

    1. With iTunes open, connect your iPhone or iPod to your computer.
    2. Click the Info tab (or the Contacts tab)
    3. Click on Sync Calendars checkbox if it's not checked in
    4. Uncheck "Do not sync events older than x days"
    5. Click Apply

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.