Skip navigation

XCode 4.5 simulator not working!!

743 Views 2 Replies Latest reply: Oct 16, 2012 7:31 AM by gmazza RSS
gmazza Calculating status...
Currently Being Moderated
Oct 13, 2012 7:34 AM

Hey there,

I have an app that I have someone creating for me. He has Xcode 4.5, so do I.


When he gives me his project it opens fine and everything but it won't start the simulator when I hit Run, it just errors out saying:


No provisioned iOS devices are available with a compatible iOS version. Connect an iOS device with a recent enough version of iOS to run your application or choose an iOS simulator as the destination.


So is the solution to rewrite it ? Will it happen again though? I have tried changing all the settings and choosing a different target destinations to use a different version, but nothing can seem to build again. I have done this four times, building then having to rebuild a couple days later.


Does anyone have any ideas or have experienced similar problems?


Thanks in advance for your help!

  • Llessur999 Level 4 Level 4 (1,155 points)
    Currently Being Moderated
    Oct 15, 2012 7:18 PM (in response to gmazza)

    Is your active scheme set to use the simulator?



    Are you able to create a new empty project, and run it in the simulator?


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.