Skip navigation

AppleMobileDeviceService.exe is hogging up to %50 of CPU

208443 Views 193 Replies Latest reply: Dec 19, 2013 2:12 PM by Mike S HT RSS Branched to a new discussion.
  • kamrath Calculating status...

    Seriously, Apple?  This problem has been around for several yrs, and there's not so much as an honest acknowledgment that this is Apple's problem?

     

    Because the battery life on the iPhone 4S is so heinously deplorable, I often park my iPhone in the cradle -- attached to the Windows computer -- whenever not in use.  During the course of the day I insert/remove it repeatedly.  ITunes isn't happy with this in-n-out, it appears, and often crashes.

     

    I've tried the "netsh winsock reset" solution mentioned here and elsewhere.  Works fine ... for the time being.  But soon enough the problem returns.  I don't want to have to reboot my computer several times a day.

  • brianmorristech Calculating status...

    Kamrath,

     

    I'm sorry to report that Apple doesn't care of this problem. If you have any software that adds an LSP (Layered Service Protocol) to your computer, it will make this problem reoccur. Thankfully in the case of Bsecure CloudCare users, Bsecure figured out a workaround since Apple wasn't willing to fix it.

     

    In case you haven't already read these, here is Apple's KB:

     

    http://support.apple.com/kb/TS4123

     

    And my reporting:

     

    http://brianmorristech.com/?p=762

  • Apersonfs Calculating status...

    This is a serious issue, which I hope Apple are making a priority.

     

    After years of iTunes working normally, after upgrading to the most recent version my Laptop fan started deafening me when the computer was apparently idle.

     

    After looking through Windows Task Manager (I'm using Windows 7 64 bit) there was nothing listed as using the 13% of the CPU so I had to dig deeper.

     

    I clicked on Resource Monitor and click sort by CPU usage, at the top of the list was AppleMobileDeviceService.exe using about 13% the only way to fix this issue for me is to manually kill the service, I right clicked it and pressed "end process" and even that took several seconds as though the process was hung.

     

    I can't believe an update has not been sent out yet to fix this issue!

     

    My anger at Apple over this has driven me off Apple a bit, switched my phone over to Android & started selling some Apple products because this is an infurating issue when all my hundreds or even thousands of dollars of content can ONLY be played on iTunes so it made me question how much more money I should invest when Apple can't even make the software work right.

     

    Edit: If they do not fix this soon I may switch completely off from Apple and sell everything.

     

    Message was edited by: Apersonfs

  • GoochyB Calculating status...

    Apersonfs

     

    Apple are not making this a priority. In fact, they couldn't care less about it. It has been an issue for a year now. See brianmorristech's post above yours and link for more info

  • phikapopp Calculating status...

    craziest thing for me is that it pops us randomly with iTunes updates. I'm losing about 13% CPU to the service, this just started after the last iTunes "upgrade".  Last time it happened was 4 versions ago I think. Weird.

     

    My solution is Splashtop. iTunes stays off until I need it. If i want to watch something thru ATV, I just go to my computer thru Splashtop and launch itunes. same with streaming music on the go.

     

    honestly, it's not affecting performance at all. but still annoying. temps on my cpu cores are contsantly up 6-10 degrees while iTunes has this nonsense going on. long term effect is likely negligible, but I still close it whenever I can

  • Michael -MT- Tom Calculating status...

    All,

     

    I've posted this in some other threads to share on my findings given the fact that we're on the same **** boat -

    I face the same problem, Windows XP that moves like snail with that downloaded iTunes 10.7.0.21.

     

    The problem is definitely on the Apple Mobile Device Support that's been hogging 50% of the CPU.

    This is what I discovered, experimented and did a moment ago:

     

    1. Go to C:\Documents and Settings\All Users\Application Data\Apple\Installer Cache

    2. Go inside the folder Apple Mobile Device Support 6.0.0.59

    3. Right-click and Uninstall

    4. Go inside the folder Apple Mobile Device Support 4.0.0.97

    5. Right-click and Install

     

    Voila.

    The iTunes 10.7.0.21 runs as smooth as silk.

     

    Give it a try and feedback please?

     

     

    Cheers,

    MT

    From Indonesia-Singapore

  • phikapopp Level 1 Level 1 (0 points)

    This worked!

    Though I didn't have that version, I used 5.2.0.6.

     

    Thanks!

  • Michael -MT- Tom Level 1 Level 1 (0 points)

    Apparently I figured out that my previous solution doesn't work twice. I searched through another solution from

    https://discussions.apple.com/thread/3383758?start=45&tstart=0.

    There are quite a number of more complicated solutions to follow, including resetting windows nesch, LSP, blablabla. Perhaps will be clearer for computer experts out there.

     

    However the simpler solution that I found is surprisingly here:

    http://support.apple.com/kb/TS4123

     

    I found out that my Speedbit Video Accelarator was 1 of the software has a conflict with Apple software.

    I tried uninstalling it, and another Voila.

    Apple Mobile Device Services (AMDS) stopped hogging up the CPU. I can now sync my iPod.

    Maybe by uninstalling all other softwares that were indicated as a conflict by Apple, this can solve the problem.

     

    Let's see if this works for everyone else?

     

     

    Cheers,

    MT

  • Irrotational Calculating status...

    I used the service stopping/starting trick and that works fine, i hardly dock my ipad so i can live with that.

     

    Apple's solution is comically bad - I ran the "autorun" tool but I don't have any random LSP providers. I have two windows live nameid things but I assume they have been there for a long time! (Maybe they haven't!?)

  • Nestofc Calculating status...

    Does anyone know if today's iTunes version release addresses this problem?

  • nilaz Calculating status...

    It did not solve it for me. I just updated without manually uninstalling anything before the upgrading.

  • Wakkorotti Calculating status...

    Same here. No change. Updated iTunes without uninstalling anything first.

  • CenturioNeto Calculating status...

    I have found that after applying this fix the issue comes back after a while! For anyone that is having similar issues with iTunes I have found a permanent fix!  It fixes this high CPU problem and it also fixes iTunes stalling while backups and syncing!  The fix costs a little but it’s all worth it as it gets to the root of the problem and puts it away for good!  Here’s the link http://for-the-people-online.com    Good Luck! There's also this info from Squidoo that may help: http://www.squidoo.com/applemobileservices-exe-and-no-backups-or-syncing-with-it unes-and-iphone

  • Grey_Area Calculating status...

    Bump, same issue.  Fix it Apple you 'tards.

  • Jivesinger Calculating status...

    I have this problem (MobileDeviceHelper hogging all CPU).

     

    However when I use Autoruns to lool at Winsock providers (as recommended by Apple) there is just the one - Bonjour from Apple.

     

    Any ideas what I can try next?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (8)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.